BGP load balancing configuration example

Network requirements

As shown in Figure 71, run EBGP between Switch A and Switch B, and between Switch A and Switch C. Run IBGP between Switch B and Switch C. Configure load balancing over the two EBGP links on Switch A.

Figure 71: Network diagram

Configuration considerations

On Switch A:

On Switch B:

On Switch C:

Configure load balancing on Switch A.

Configuration procedure

  1. Configure IP addresses for interfaces. (Details not shown.)

  2. Configure BGP connections:

    # Configure Switch A.

    <SwitchA> system-view
    [SwitchA] bgp 65008
    [SwitchA-bgp-default] router-id 1.1.1.1
    [SwitchA-bgp-default] peer 3.1.1.1 as-number 65009
    [SwitchA-bgp-default] peer 3.1.2.1 as-number 65009
    [SwitchA-bgp-default] address-family ipv4 unicast
    [SwitchA-bgp-default-ipv4] peer 3.1.1.1 enable
    [SwitchA-bgp-default-ipv4] peer 3.1.2.1 enable
    [SwitchA-bgp-default-ipv4] network 8.1.1.0 24
    [SwitchA-bgp-default-ipv4] quit
    [SwitchA-bgp-default] quit
    

    # Configure Switch B.

    <SwitchB> system-view
    [SwitchB] bgp 65009
    [SwitchB-bgp-default] router-id 2.2.2.2
    [SwitchB-bgp-default] peer 3.1.1.2 as-number 65008
    [SwitchB-bgp-default] peer 3.3.3.3 as-number 65009
    [SwitchB-bgp-default] peer 3.3.3.3 connect-interface loopback 0
    [SwitchB-bgp-default] address-family ipv4 unicast
    [SwitchB-bgp-default-ipv4] peer 3.1.1.2 enable
    [SwitchB-bgp-default-ipv4] peer 3.3.3.3 enable
    [SwitchB-bgp-default-ipv4] network 9.1.1.0 24
    [SwitchB-bgp-default-ipv4] quit
    [SwitchB-bgp-default] quit
    [SwitchB] ip route-static 3.3.3.3 32 9.1.1.2
    

    # Configure Switch C.

    <SwitchC> system-view
    [SwitchC] bgp 65009
    [SwitchC-bgp-default] router-id 3.3.3.3
    [SwitchC-bgp-default] peer 3.1.2.2 as-number 65008
    [SwitchC-bgp-default] peer 2.2.2.2 as-number 65009
    [SwitchC-bgp-default] peer 2.2.2.2 connect-interface loopback 0
    [SwitchC-bgp-default] address-family ipv4 unicast
    [SwitchC-bgp-default-ipv4] peer 3.1.2.2 enable
    [SwitchC-bgp-default-ipv4] peer 2.2.2.2 enable
    [SwitchC-bgp-default-ipv4] network 9.1.1.0 24
    [SwitchC-bgp-default-ipv4] quit
    [SwitchC-bgp-default] quit
    [SwitchC] ip route-static 2.2.2.2 32 9.1.1.1
    

    # Display the BGP routing table on Switch A.

    [SwitchA] display bgp routing-table ipv4
    
     Total number of routes: 3
    
     BGP local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - dampened, h - history,
                   s - suppressed, S - stale, i - internal, e - external
                   Origin: i - IGP, e - EGP, ? - incomplete
    
         Network            NextHop         MED        LocPrf     PrefVal Path/Ogn
    
    * >  8.1.1.0/24         8.1.1.1         0                     32768       i
    * >e 9.1.1.0/24         3.1.1.1         0                     0       65009i
    *  e                    3.1.2.1         0                     0       65009i
    
    • The output shows two valid routes to destination 9.1.1.0/24. The route with next hop 3.1.1.1 is marked with a greater-than sign (>), indicating that it is the optimal route (because the ID of Switch B is smaller). The route with next hop 3.1.2.1 is marked with an asterisk (*), indicating that it is a valid route, but not the optimal route.

    • By using the display ip routing-table command, you can find only one route to 9.1.1.0/24 with next hop 3.1.1.1 and output interface VLAN-interface 200.

  3. Configure loading balancing:

    Because Switch A has two routes to reach AS 65009, configuring load balancing over the two BGP routes on Switch A can improve link usage.

    # Configure Switch A.

    [SwitchA] bgp 65008
    [SwitchA-bgp-default] address-family ipv4 unicast
    [SwitchA-bgp-default-ipv4] balance 2
    [SwitchA-bgp-default-ipv4] quit
    [SwitchA-bgp-default] quit
    

Verifying the configuration

# Display the BGP routing table on Switch A.

[SwitchA] display bgp routing-table ipv4

 Total number of routes: 3

 BGP local router ID is 1.1.1.1
 Status codes: * - valid, > - best, d - dampened, h - history,
               s - suppressed, S - stale, i - internal, e - external
               Origin: i - IGP, e - EGP, ? - incomplete

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

* >  8.1.1.0/24         8.1.1.1         0                     32768       i
* >e 9.1.1.0/24         3.1.1.1         0                     0       65009i
* >e                    3.1.2.1         0                     0       65009i