Dynamic route backup configuration example 4

Network requirements

As shown in Figure 61, Router A and Router B are connected through an FR network. They are also connected through an ISDN switched network, enabling them to call each other. The telephone number of Router A is 660330, and that of Router B is 660220.

Use Router A as the master device of a dynamic route backup group to monitor three network segments 10.0.0.1/8, 11.0.0.1/8, and 12.0.0.1/8, which are all connected to Router B.

The FR link functions as the primary link between Router A and Router B. When the routes to all the three network segments become invalid, Router A automatically establishes an ISDN BRI link to Router B.

Figure 61: Network diagram

This network diagram only illustrates a simple application where a dynamic route backup group is used to monitor multiple subnets. In actual use, the monitored network segments can be connected to multiple devices.

Configuration procedure

  1. Configure Router A:

    # Create a dialer access group rule.

    <RouterA> system-view
    [RouterA] dialer-rule 1 ip permit
    

    # Create a dynamic route backup group to monitor three network segments.

    [RouterA] standby routing-rule 1 ip 10.0.0.0 255.0.0.0
    [RouterA] standby routing-rule 1 ip 11.0.0.0 255.0.0.0
    [RouterA] standby routing-rule 1 ip 12.0.0.0 255.0.0.0
    

    # Bundle timeslots on the CE1 interface into a PRI group.

    [RouterA] controller e1 2/1
    [RouterA-E1 2/1] pri-set
    [RouterA-E1 2/1] quit
    

    # Configure Serial 2/0 as an FR interface.

    [RouterA] interface serial 2/0
    [RouterA-Serial2/0] ip address 1.0.0.1 255.0.0.0
    [RouterA-Serial2/0] link-protocol fr
    [RouterA-Serial2/0] fr interface-type dte
    [RouterA-Serial2/0] fr inarp
    [RouterA-Serial2/0] fr map ip 1.0.0.2 100
    [RouterA-Serial2/0] quit
    

    # Configure C-DCC on the PRI interface.

    [RouterA] interface serial 2/1:15
    [RouterA-Serial2/1:15] ip address 2.0.0.1 255.0.0.0
    [RouterA-Serial2/1:15] dialer enable-circular
    [RouterA-Serial2/1:15] dialer-group 1
    [RouterA-Serial2/1:15] dialer route ip 10.0.0.0 mask 8 660220
    [RouterA-Serial2/1:15] standby routing-group 1
    [RouterA-Serial2/1:15] quit
    

    # Configure RIP.

    [RouterA] rip
    [RouterA-rip-1] network 1.0.0.0
    [RouterA-rip-1] network 2.0.0.0
    [RouterA-rip-1] import-route direct
    

    # Configure the routes used by the serial interface to adopt higher priorities than those used by the dialup interface.

    [RouterA] interface serial 2/1:15
    [RouterA-Serial2/1:15] rip metricin 2
    
  2. Configure Router B:

    # Create a dialer access group rule for dialup.

    [RouterB] system
    [RouterB] dialer-rule 1 ip permit
    

    # Bundle timeslots on the CE1 interface into a PRI group.

    [RouterB] controller e1 2/1
    [RouterB-E1 2/1] pri-set
    [RouterB-E1 2/1] quit
    

    # Configure Serial 2/0 as an FR interface.

    [RouterB] interface serial 2/0
    [RouterB-Serial2/0] ip address 1.0.0.2 255.0.0.0
    [RouterB-Serial2/0] link-protocol fr
    [RouterB-Serial2/0] fr interface-type dte
    [RouterB-Serial2/0] fr inarp
    [RouterB-Serial2/0] fr map ip 1.0.0.1 200
    [RouterB-Serial2/0] quit
    

    # Configure C-DCC on PRI interface Serial 2/1:15.

    [RouterB] interface serial 2/1:15
    [RouterB-Serial2/1:15] ip address 2.0.0.2 255.0.0.0
    [RouterB-Serial2/1:15] dialer enable-circular
    [RouterB-Serial2/1:15] dialer-group 1
    [RouterB-Serial2/1:15] dialer route ip 2.0.0.1 mask 8 660330
    [RouterB-Serial2/1:15] quit
    

    # Configure the Ethernet interfaces with the network segments attached.

    [RouterB] interface ethernet 1/0
    [RouterB-Ethernet1/0] ip address 10.0.0.1 255.0.0.0
    [RouterB-Ethernet1/0] quit
    [RouterB] interface ethernet 1/1
    [RouterB-Ethernet1/1] ip address 11.0.0.1 255.0.0.0
    [RouterB-Ethernet1/1] quit
    [RouterB] interface ethernet 1/2
    [RouterB-Ethernet1/2] ip address 12.0.0.1 255.0.0.0
    [RouterB-Ethernet1/2] quit
    

    # Configure RIP.

    [RouterB] rip
    [RouterB-rip-1] network 1.0.0.0
    [RouterB-rip-1] network 2.0.0.0
    [RouterB-rip-1] network 10.0.0.0
    [RouterB-rip-1] network 11.0.0.0
    [RouterB-rip-1] network 12.0.0.0
    [RouterB-rip-1] import-route direct