Configuring a remote CCC connection

Network requirements

Create a remote CCC connection between PE 1 and PE 2 to allow communication between CE 1 and CE 2.

Figure 114: Network diagram

Table 43: Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

GE2/1/1

10.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.2/24

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE2/1/1

100.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.1/24

Configuration procedure

  1. Configure CE 1.

    <CE1> system-view
    [CE1] interface gigabitethernet 2/1/1
    [CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24
    [CE1-GigabitEthernet2/1/1] quit
    
  2. Configure PE 1:

    # Configure an LSR ID.

    <PE1> system-view
    [PE1] interface loopback 0
    [PE1-LoopBack0] ip address 192.2.2.2 32
    [PE1-LoopBack0] quit
    [PE1] mpls lsr-id 192.2.2.2
    

    # Enable L2VPN.

    [PE1] l2vpn enable
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to the P device), and enable MPLS on the interface.

    [PE1] interface gigabitethernet 2/1/2
    [PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24
    [PE1-GigabitEthernet2/1/2] mpls enable
    [PE1-GigabitEthernet2/1/2] quit
    

    # Configure OSPF.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    # Create a cross-connect group named ccc, and create a remote CCC connection that has incoming label 101, outgoing label 201, and next hop 10.1.1.2.

    [PE1] xconnect-group ccc
    [PE1-xcg-ccc] connection ccc
    [PE1-xcg-ccc-ccc] ccc in-label 101 out-label 201 nexthop 10.1.1.2
    

    # Bind GigabitEthernet 2/1/1 to the CCC connection.

    [PE1-xcg-ccc-ccc] ac interface gigabitethernet 2/1/1
    [PE1-xcg-ccc-ccc] quit
    [PE1-xcg-ccc] quit
    
  3. Configure the P device:

    # Configure an LSR ID.

    <P> system-view
    [P] interface loopback 0
    [P-LoopBack0] ip address 192.4.4.4 32
    [P-LoopBack0] quit
    [P] mpls lsr-id 192.4.4.4
    

    # Configure GigabitEthernet 2/1/1 (the interface connected to PE 1), and enable MPLS on the interface.

    [P] interface gigabitethernet 2/1/1
    [P-GigabitEthernet2/1/1] ip address 10.1.1.2 24
    [P-GigabitEthernet2/1/1] mpls enable
    [P-GigabitEthernet2/1/1] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to PE 2), and enable MPLS on the interface.

    [P] interface gigabitethernet 2/1/2
    [P-GigabitEthernet2/1/2] ip address 10.2.2.2 24
    [P-GigabitEthernet2/1/2] mpls enable
    [P-GigabitEthernet2/1/2] quit
    

    # Configure a static LSP to forward packets from PE 1 to PE 2.

    [P] static-lsp transit pe1-pe2 in-label 201 nexthop 10.2.2.1 out-label 202
    

    # Configure a static LSP to forward packets from PE 2 to PE 1.

    [P] static-lsp transit pe2-pe1 in-label 102 nexthop 10.1.1.1 out-label 101
    

    # Configure OSPF.

    [P] ospf
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    
  4. Configure PE 2:

    # Configure an LSR ID.

    <PE2> system-view
    [PE2] interface loopback 0
    [PE2-LoopBack0] ip address 192.3.3.3 32
    [PE2-LoopBack0] quit
    [PE2] mpls lsr-id 192.3.3.3
    

    # Enable L2VPN.

    [PE2] l2vpn enable
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to the P device), and enable MPLS on the interface.

    [PE2] interface gigabitethernet 2/1/2
    [PE2-GigabitEthernet2/1/2] ip address 10.2.2.1 24
    [PE2-GigabitEthernet2/1/2] mpls enable
    [PE2-GigabitEthernet2/1/2] quit
    

    # Configure OSPF.

    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    

    # Create a cross-connect group named ccc, and create a remote CCC connection that has incoming label 202, outgoing label 102, and next hop 10.2.2.2.

    [PE2] xconnect-group ccc
    [PE2-xcg-ccc] connection ccc
    [PE2-xcg-ccc-ccc] ccc in-label 202 out-label 102 nexthop 10.2.2.2
    

    # Bind GigabitEthernet 2/1/1 to the CCC connection.

    [PE2-xcg-ccc-ccc] ac interface gigabitethernet 2/1/1
    [PE2-xcg-ccc-ccc] quit
    [PE2-xcg-ccc] quit
    
  5. Configure CE 2.

    <CE2> system-view
    [CE2] interface gigabitethernet 2/1/1
    [CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24
    [CE2-GigabitEthernet2/1/1] quit
    

Verifying the configuration

# Verify that a remote CCC connection (identified by PW ID/Rmt Site "-" and Proto Static) has been established on PE 1.

[PE1] display l2vpn pw
Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1
1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

Xconnect-group Name: ccc
Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State
10.1.1.2        -                 101/201         Static  M     0        Up

# Verify that a remote CCC connection has been established on PE 2.

[PE2] display l2vpn pw
Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1
1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

Xconnect-group Name: ccc
Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State
10.2.2.2        -                 202/102         Static  M     0        Up

# Verify that CE 1 and CE 2 can ping each other. (Details not shown.)