Configuring a BGP PW

Network requirements

Create a BGP PW between PE 1 and PE 2 to allow communication between CE 1 and CE 2.

Figure 113: Network diagram

Table 42: Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

GE2/1/1

10.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.2/24

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE2/1/1

100.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.1/24

Configuration procedure

  1. Configure CE 1.

    <CE1> system-view
    [CE1] interface gigabitethernet 2/1/1
    [CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24
    [CE1-GigabitEthernet2/1/1] quit
    
  2. Configure PE 1:

    # Configure an LSR ID.

    <PE1> system-view
    [PE1] interface loopback 0
    [PE1-LoopBack0] ip address 192.2.2.2 32
    [PE1-LoopBack0] quit
    [PE1] mpls lsr-id 192.2.2.2
    

    # Enable L2VPN.

    [PE1] l2vpn enable
    

    # Enable global LDP.

    [PE1] mpls ldp
    [PE1-ldp] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to the P device), and enable LDP on the interface.

    [PE1] interface gigabitethernet 2/1/2
    [PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24
    [PE1-GigabitEthernet2/1/2] mpls enable
    [PE1-GigabitEthernet2/1/2] mpls ldp enable
    [PE1-GigabitEthernet2/1/2] quit
    

    # Configure OSPF for LDP to create LSPs.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    # Create an IBGP connection to PE 2, and enable BGP to advertise L2VPN information to PE 2.

    [PE1] bgp 100
    [PE1-bgp-default] peer 192.3.3.3 as-number 100
    [PE1-bgp-default] peer 192.3.3.3 connect-interface loopback 0
    [PE1-bgp-default] address-family l2vpn
    [PE1-bgp-default-l2vpn] peer 192.3.3.3 enable
    [PE1-bgp-default-l2vpn] quit
    [PE1-bgp-default] quit
    

    # Create a cross-connect group named vpnb, create a local site named site 1, and create a BGP PW from site 1 to the remote site site 2.

    [PE1] xconnect-group vpnb
    [PE1-xcg-vpnb] auto-discovery bgp
    [PE1-xcg-vpnb-auto] route-distinguisher 2:2
    [PE1-xcg-vpnb-auto] vpn-target 2:2 export-extcommunity
    [PE1-xcg-vpnb-auto] vpn-target 2:2 import-extcommunity
    [PE1-xcg-vpnb-auto] site 1 range 10 default-offset 0
    [PE1-xcg-vpnb-auto-1] connection remote-site-id 2
    

    # Bind GigabitEthernet 2/1/1 to the PW.

    [PE1-xcg-vpnb-auto-1-2] ac interface gigabitethernet 2/1/1
    [PE1-xcg-vpnb-auto-1-2] return
    
  3. Configure the P device:

    # Configure an LSR ID.

    <P> system-view
    [P] interface loopback 0
    [P-LoopBack0] ip address 192.4.4.4 32
    [P-LoopBack0] quit
    [P] mpls lsr-id 192.4.4.4
    

    # Enable global LDP.

    [P] mpls ldp
    [P-ldp] quit
    

    # Configure GigabitEthernet 2/1/1 (the interface connected to PE 1), and enable LDP on the interface.

    [P] interface gigabitethernet 2/1/1
    [P-GigabitEthernet2/1/1] ip address 10.1.1.2 24
    [P-GigabitEthernet2/1/1] mpls enable
    [P-GigabitEthernet2/1/1] mpls ldp enable
    [P-GigabitEthernet2/1/1] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to PE 2), and enable LDP on the interface.

    [P] interface gigabitethernet 2/1/2
    [P-GigabitEthernet2/1/2] ip address 10.2.2.2 24
    [P-GigabitEthernet2/1/2] mpls enable
    [P-GigabitEthernet2/1/2] mpls ldp enable
    [P-GigabitEthernet2/1/2] quit
    

    # Configure OSPF for LDP to create LSPs.

    [P] ospf
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit
    
  4. Configure PE 2:

    # Configure an LSR ID.

    <PE2> system-view
    [PE2] interface loopback 0
    [PE2-LoopBack0] ip address 192.3.3.3 32
    [PE2-LoopBack0] quit
    [PE2] mpls lsr-id 192.3.3.3
    

    # Enable L2VPN.

    [PE2] l2vpn enable
    

    # Enable global LDP.

    [PE2] mpls ldp
    [PE2-ldp] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to the P device), and enable LDP on the interface.

    [PE2] interface gigabitethernet 2/1/2
    [PE2-GigabitEthernet2/1/2] ip address 10.2.2.1 24
    [PE2-GigabitEthernet2/1/2] mpls enable
    [PE2-GigabitEthernet2/1/2] mpls ldp enable
    [PE2-GigabitEthernet2/1/2] quit
    

    # Configure OSPF for LDP to create LSPs.

    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    

    # Create an IBGP connection to PE 1, and enable BGP to advertise L2VPN information to PE 1.

    [PE2] bgp 100
    [PE2-bgp-default] peer 192.2.2.2 as-number 100
    [PE2-bgp-default] peer 192.2.2.2 connect-interface loopback 0
    [PE2-bgp-default] address-family l2vpn
    [PE2-bgp-default-l2vpn] peer 192.2.2.2 enable
    [PE2-bgp-default-l2vpn] quit
    [PE2-bgp-default] quit
    

    # Create a cross-connect group named vpnb, create a local site named site 2, and create a BGP PW from site 2 to the remote site site 1.

    [PE2] xconnect-group vpnb
    [PE2-xcg-vpnb] auto-discovery bgp
    [PE2-xcg-vpnb-auto] route-distinguisher 2:2
    [PE2-xcg-vpnb-auto] vpn-target 2:2 export-extcommunity
    [PE2-xcg-vpnb-auto] vpn-target 2:2 import-extcommunity
    [PE2-xcg-vpnb-auto] site 2 range 10 default-offset 0
    [PE2-xcg-vpnb-auto-2] connection remote-site-id 1
    

    # Bind GigabitEthernet 2/1/1 to the PW.

    [PE2-xcg-vpnb-auto-2-1] ac interface gigabitethernet 2/1/1
    [PE2-xcg-vpnb-auto-2-1] return
    
  5. Configure CE 2.

    <CE2> system-view
    [CE2] interface gigabitethernet 2/1/1
    [CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24
    [CE2-GigabitEthernet2/1/1] quit
    

Verifying the configuration

# Verify that a BGP PW has been established on PE 1.

<PE1> display l2vpn pw
Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1
1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate
 
Xconnect-group Name: vpnb
Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State
192.3.3.3       2                 1036/1025       BGP     M     1        Up

# Verify that a BGP PW has been established on PE 2.

<PE2> display l2vpn pw
Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1
1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

Xconnect-group Name: vpnb
Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State
192.2.2.2       1                 1025/1036       BGP     M     1        Up

# Verify that CE 1 and CE 2 can ping each other. (Details not shown.)