Switch automation status shows Failed

Symptom
The nps show --service switch command displays the status of the switch automation process as:
Failed
Cause

This issue can be caused due to any number of reasons. To identify the exact cause of failure, see the <topology_name>_switch_config_<date>.log file.

Action
  1. Navigate to /var/nps/logs/<topology_name>/ in NPS toolkit VM.
  2. Identify the error messages in <topology_name>_switch_config_<date>.log file.
  3. Fix the issue.
  4. Rerun the switch automation deployment command:

    nps deploy -s switch -l debug -p <profile name> -t <type of switch> -nos <nos_type> -ip <comma seperated switch iLO_OOBM IPs>

    OR

    nps deploy -s switch -l debug -p <profile name> -t <type of switch> -nos <nos_type> -ip <comma seperated data, borderleaf, spine switch iLO_OOBM IPs>

    Where,

    <profile name> - switch profile you have selected.

    <type of switch> - data

    <nos_type> - comware or cumulus or aruba