Configuring a remote CCC connection

Network requirements

Create a remote CCC connection between PE 1 and PE 2 so VLAN 10 on CE 1 can communicate with VLAN 10 on CE 2.

Figure 75: Network diagram

Table 24: Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

PE 1

Loop0

192.2.2.2/32

P

Loop0

192.4.4.4/32

Vlan-int20

10.1.1.1/24

Vlan-int20

10.1.1.2/24

PE 2

Loop0

192.3.3.3/32

Vlan-int30

10.2.2.2/24

Vlan-int30

10.2.2.1/24

Configuration procedure

Before you perform the following configurations, configure VLANs and add ports to VLANs on switches.

  1. Configure CE 1.

    <CE1> system-view
    [CE1] interface ten-gigabitethernet 1/0/1
    [CE1-Ten-GigabitEthernet1/0/1] port link-type trunk
    [CE1-Ten-GigabitEthernet1/0/1] port trunk permit vlan 10
    [CE1-Ten-GigabitEthernet1/0/1] quit
    
  2. Configure PE 1:

    # Configure an LSR ID.

    <PE1> system-view
    [PE1] interface loopback 0
    [PE1-LoopBack0] ip address 192.2.2.2 32
    [PE1-LoopBack0] quit
    [PE1] mpls lsr-id 192.2.2.2
    

    # Enable L2VPN.

    [PE1] l2vpn enable
    

    # Configure VLAN-interface 20 (the interface connected to P), and enable MPLS on the interface.

    [PE1] interface vlan-interface 20
    [PE1-Vlan-interface20] ip address 10.1.1.1 24
    [PE1-Vlan-interface20] mpls enable
    [PE1-Vlan-interface20] quit
    

    # Create service instance 10 on Ten-GigabitEthernet 1/0/1 to match packets that have an outer VLAN ID of 10.

    [PE1] interface ten-gigabitethernet1/0/1
    [PE1-Ten-GigabitEthernet1/0/1] service-instance 10
    [PE1-Ten-GigabitEthernet1/0/1-srv10] encapsulation s-vid 10
    [PE1-Ten-GigabitEthernet1/0/1-srv10] quit
    [PE1-Ten-GigabitEthernet1/0/1] quit
    

    # Create a cross-connect group named ccc, create a remote CCC connection that has incoming label 101, outgoing label 201, and next hop 10.1.1.2, and bind service instance 10 on Ten-GigabitEthernet 1/0/1 to the CCC connection.

    [PE1] xconnect-group ccc
    [PE1-xcg-ccc] connection ccc
    [PE1-xcg-ccc-ccc] ccc in-label 101 out-label 201 nexthop 10.1.1.2
    [PE1-xcg-ccc-ccc] ac interface Ten-GigabitEthernet 1/0/1 service-instance 10
    [PE1-xcg-ccc-ccc] quit
    [PE1-xcg-ccc] quit
    
  3. Configure the P device:

    # Configure an LSR ID.

    <P> system-view
    [P] interface loopback 0
    [P-LoopBack0] ip address 192.4.4.4 32
    [P-LoopBack0] quit
    [P] mpls lsr-id 192.4.4.4
    

    # Configure VLAN-interface 20 (the interface connected to PE 1), and enable MPLS on the interface.

    [P] interface vlan-interface 20
    [P-Vlan-interface20] ip address 10.1.1.2 24
    [P-Vlan-interface20] mpls enable
    [P-Vlan-interface20] quit
    

    # Configure VLAN-interface 30 (the interface connected to PE 2), and enable MPLS on the interface.

    [P] interface vlan-interface 30
    [P-Vlan-interface30] ip address 10.2.2.2 24
    [P-Vlan-interface30] mpls enable
    [P-Vlan-interface30] quit
    

    # Configure a static LSP to forward packets from PE 1 to PE 2.

    [P] static-lsp transit pe1-pe2 in-label 201 nexthop 10.2.2.1 out-label 202
    

    # Configure a static LSP to forward packets from PE 2 to PE 1.

    [P] static-lsp transit pe2-pe1 in-label 102 nexthop 10.1.1.1 out-label 101
    
  4. Configure PE 2:

    # Configure an LSR ID.

    <PE2> system-view
    [PE2] interface loopback 0
    [PE2-LoopBack0] ip address 192.3.3.3 32
    [PE2-LoopBack0] quit
    [PE2] mpls lsr-id 192.3.3.3
    

    # Enable L2VPN.

    [PE2] l2vpn enable
    

    # Configure VLAN-interface 30 (the interface connected to P), and enable MPLS on the interface.

    [PE2] interface vlan-interface 30
    [PE2-Vlan-interface30] ip address 10.2.2.1 24
    [PE2-Vlan-interface30] mpls enable
    [PE2-Vlan-interface30] quit
    

    # Create service instance 10 on Ten-GigabitEthernet 1/0/1 to match packets that have an outer VLAN ID of 10.

    [PE2] interface ten-gigabitethernet1/0/1
    [PE2-Ten-GigabitEthernet1/0/1] service-instance 10
    [PE2-Ten-GigabitEthernet1/0/1-srv10] encapsulation s-vid 10
    [PE2-Ten-GigabitEthernet1/0/1-srv10] quit
    [PE2-Ten-GigabitEthernet1/0/1] quit
    

    # Create a cross-connect group named ccc, create a remote CCC connection that has incoming label 202, outgoing label 102, and next hop 10.2.2.2, and bind service instance 10 on Ten-GigabitEthernet 1/0/1 to the CCC connection.

    [PE2] xconnect-group ccc
    [PE2-xcg-ccc] connection ccc
    [PE2-xcg-ccc-ccc] ccc in-label 202 out-label 102 nexthop 10.2.2.2
    [PE2-xcg-ccc-ccc] ac interface Ten-GigabitEthernet 1/0/1 service-instance 10
    [PE2-xcg-ccc-ccc] quit
    [PE2-xcg-ccc] quit
    
  5. Configure CE 2.

    <CE2> system-view
    [CE2] interface ten-gigabitethernet 1/0/1
    [CE2-Ten-GigabitEthernet1/0/1] port link-type trunk
    [CE2-Ten-GigabitEthernet1/0/1] port trunk permit vlan 10
    [CE2-Ten-GigabitEthernet1/0/1] quit
    

Verifying the configuration

# Display L2VPN PW information on PE 1. The output shows that a remote CCC connection (identified by PW ID/Rmt Site "-" and Proto Static) has been established.

[PE1] display l2vpn pw
Flags: M - main, B - backup, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1, 1 up, 0 blocked, 0 down, 0 defect

Xconnect-group Name: ccc
Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State
10.1.1.2        -                 101/201         Static  M     0        Up

# Display L2VPN PW information on PE 2. The output shows that a remote CCC connection has been established.

[PE2] display l2vpn pw
Flags: M - main, B - backup, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1, 1 up, 0 blocked, 0 down, 0 defect

Xconnect-group Name: ccc                                                        
Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State  
10.2.2.2        -                 202/102         Static  M     0        Up     

# Verify that CE 1 and CE 2 can ping each other. (Details not shown.)