Configuring a static PW

Network requirements

Create a static PW between PE 1 and PE 2 over the backbone so CE 1 and CE 2 can communicate within VLAN 10.

Figure 72: Network diagram

Table 21: Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

PE 1

Loop0

192.2.2.2/32

P

Loop0

192.4.4.4/32

Vlan-int20

10.1.1.1/24

Vlan-int30

10.2.2.2/24

PE 2

Loop0

192.3.3.3/32

Vlan-int20

10.1.1.2/24

Vlan-int30

10.2.2.1/24

Configuration procedure

Before you perform the following configurations, configure VLANs and add ports to VLANs on switches.

  1. Configure CE 1.

    <CE1> system-view
    [CE1] interface ten-gigabitethernet 1/0/1
    [CE1-Ten-GigabitEthernet1/0/1] port link-type trunk
    [CE1-Ten-GigabitEthernet1/0/1] port trunk permit vlan 10
    [CE1-Ten-GigabitEthernet1/0/1] quit 
    
  2. Configure PE 1:

    # Configure an LSR ID.

    <PE1> system-view
    [PE1] interface loopback 0
    [PE1-LoopBack0] ip address 192.2.2.2 32
    [PE1-LoopBack0] quit
    [PE1] mpls lsr-id 192.2.2.2
    

    # Enable L2VPN.

    [PE1] l2vpn enable
    

    # Enable global LDP.

    [PE1] mpls ldp
    [PE1-ldp] quit
    

    # Configure VLAN-interface 20 connected to the P device and enable LDP on the interface.

    [PE1] interface vlan-interface 20
    [PE1-Vlan-interface20] ip address 10.1.1.1 24
    [PE1-Vlan-interface20] mpls enable
    [PE1-Vlan-interface20] mpls ldp enable
    [PE1-Vlan-interface20] quit
    

    # Configure OSPF on PE 1 for LDP to create LSPs.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    # Create service instance 10 on Ten-GigabitEthernet 1/0/1 to match packets that have an outer VLAN ID of 10.

    [PE1] interface ten-gigabitethernet1/0/1
    [PE1-Ten-GigabitEthernet1/0/1] service-instance 10
    [PE1-Ten-GigabitEthernet1/0/1-srv10] encapsulation s-vid 10
    [PE1-Ten-GigabitEthernet1/0/1-srv10] quit
    [PE1-Ten-GigabitEthernet1/0/1] quit
    

    # Create a cross-connect group named vpna, create a cross-connect named svc in the group, and bind service instance 10 on Ten-GigabitEthernet 1/0/1 to the cross-connect.

    [PE1] xconnect-group vpna
    [PE1-xcg-vpna] connection svc
    [PE1-xcg-vpna-svc] ac interface Ten-GigabitEthernet 1/0/1 service-instance 10
    

    # Create a static PW for the cross-connect to bind the AC to the PW.

    [PE1-xcg-vpna-svc] peer 192.3.3.3 pw-id 3 in-label 100 out-label 200
    [PE1-xcg-vpna-svc-192.3.3.3-3] quit
    [PE1-xcg-vpna-svc] quit
    [PE1-xcg-vpna] quit
    
  3. Configure the P device:

    # Configure an LSR ID.

    <P> system-view
    [P] interface loopback 0
    [P-LoopBack0] ip address 192.4.4.4 32
    [P-LoopBack0] quit
    [P] mpls lsr-id 192.4.4.4
    

    # Enable global LDP.

    [P] mpls ldp
    [P-ldp] quit
    

    # Configure VLAN-interface 20 connected to PE 1 and enable LDP on the interface.

    [P] interface vlan-interface 20
    [P-Vlan-interface20] ip address 10.1.1.2 24
    [P-Vlan-interface20] mpls enable
    [P-Vlan-interface20] mpls ldp enable
    [P-Vlan-interface20] quit
    

    # Configure VLAN-interface 30 connected to PE 2 and enable LDP on the interface.

    [P] interface vlan-interface 30
    [P-Vlan-interface30] ip address 10.2.2.2 24
    [P-Vlan-interface30] mpls enable
    [P-Vlan-interface30] mpls ldp enable
    [P-Vlan-interface30] quit
    

    # Configure OSPF on the P device for LDP to create LSPs.

    [P] ospf
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit
    
  4. Configure PE 2:

    # Configure an LSR ID.

    <PE2> system-view
    [PE2] interface loopback 0
    [PE2-LoopBack0] ip address 192.3.3.3 32
    [PE2-LoopBack0] quit
    [PE2] mpls lsr-id 192.3.3.3
    

    # Enable L2VPN.

    [PE2] l2vpn enable
    

    # Enable global LDP.

    [PE2] mpls ldp
    [PE2-ldp] quit
    

    # Configure VLAN-interface 30 connected to the P device and enable LDP on the interface.

    [PE2] interface vlan-interface 30
    [PE2-Vlan-interface30] ip address 10.2.2.1 24
    [PE2-Vlan-interface30] mpls enable
    [PE2-Vlan-interface30] mpls ldp enable
    [PE2-Vlan-interface30] quit
    

    # Configure OSPF on PE 2 for LDP to create LSPs.

    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 10.2.2.1 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    

    # Create service instance 10 on Ten-GigabitEthernet 1/0/1 to match packets that have an outer VLAN ID of 10.

    [PE2] interface ten-gigabitethernet1/0/1
    [PE2-Ten-GigabitEthernet1/0/1] service-instance 10
    [PE2-Ten-GigabitEthernet1/0/1-srv10] encapsulation s-vid 10
    [PE2-Ten-GigabitEthernet1/0/1-srv10] quit
    [PE2-Ten-GigabitEthernet1/0/1] quit
    

    # Create a cross-connect group named vpna, create a cross-connect named svc in the group, and bind service instance 10 on Ten-GigabitEthernet 1/0/1 to the cross-connect.

    [PE2] xconnect-group vpna
    [PE2-xcg-vpna] connection svc
    [PE2-xcg-vpna-svc] ac interface Ten-GigabitEthernet 1/0/1 service-instance 10
    

    # Create a static PW for the cross-connect to bind the AC to the PW.

    [PE2-xcg-vpna-svc] peer 192.2.2.2 pw-id 3 in-label 200 out-label 100
    [PE2-xcg-vpna-svc-192.2.2.2-3] quit
    [PE2-xcg-vpna-svc] quit
    [PE2-xcg-vpna] quit
    
  5. Configure CE 2.

    <CE2> system-view
    [CE2] interface ten-gigabitethernet 1/0/1
    [CE2-Ten-GigabitEthernet1/0/1] port link-type trunk
    [CE2-Ten-GigabitEthernet1/0/1] port trunk permit vlan 10
    [CE2-Ten-GigabitEthernet1/0/1] quit
    

Verifying the configuration

# Display L2VPN PW information on PE 1. The output shows that a static PW has been established.

[PE1] display l2vpn pw
Flags: M - main, B - backup, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1, 1 up, 0 blocked, 0 down, 0 defect

Xconnect-group Name: vpna
Peer            PW ID      In/Out Label    Proto  Flag  Link ID    State
192.3.3.3       3          100/200         Static M     0          Up

# Display L2VPN PW information on PE 2. The output shows that a static PW has been established.

[PE2] display l2vpn pw
Flags: M - main, B - backup, H - hub link, S - spoke link, N - no split horizon
Total number of PWs: 1, 1 up, 0 blocked, 0 down, 0 defect

Xconnect-group Name: vpna
Peer            PW ID      In/Out Label    Proto  Flag  Link ID    State
192.2.2.2       3          200/100         Static M     0          Up

# Verify that CE 1 and CE 2 can ping each other. (Details not shown.)