Static PW configuration example

Network requirements

CEs are connected to the PEs through Layer 3 Ethernet interfaces (GigabitEthernet 2/1/1).

Configure a VSI on each PE, and establish static PWs between the PEs to interconnect the CEs.

Figure 123: Network diagram

Configuration procedure

This task includes the following configurations:

  1. Configure PE 1:

    # Configure an LSR ID.

    <PE1> system-view
    [PE1] interface loopback 0
    [PE1-LoopBack0] ip address 1.1.1.9 32
    [PE1-LoopBack0] quit
    [PE1] mpls lsr-id 1.1.1.9
    

    # Enable L2VPN.

    [PE1] l2vpn enable
    

    # Enable global LDP.

    [PE1] mpls ldp
    [PE1-ldp] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to PE 2), and enable LDP on the interface.

    [PE1] interface gigabitethernet 2/1/2
    [PE1-GigabitEthernet2/1/2] ip address 20.1.1.1 24
    [PE1-GigabitEthernet2/1/2] mpls enable
    [PE1-GigabitEthernet2/1/2] mpls ldp enable
    [PE1-GigabitEthernet2/1/2] quit
    

    # Configure GigabitEthernet 2/1/3 (the interface connected to PE 3), and enable LDP on the interface.

    [PE1] interface gigabitethernet 2/1/3
    [PE1-GigabitEthernet2/1/3] ip address 30.1.1.1 24
    [PE1-GigabitEthernet2/1/3] mpls enable
    [PE1-GigabitEthernet2/1/3] mpls ldp enable
    [PE1-GigabitEthernet2/1/3] quit
    

    # Configure OSPF for LDP to create LSPs.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    # Create a VSI, specify the peer PEs, and establish static PWs to the peer PEs.

    [PE1] vsi svc
    [PE1-vsi-svc] pwsignaling static
    [PE1-vsi-svc-static] peer 2.2.2.9 pw-id 3 in-label 100 out-label 100
    [PE1-vsi-svc-static-2.2.2.9-3] quit
    [PE1-vsi-svc-static] peer 3.3.3.9 pw-id 3 in-label 200 out-label 200
    [PE1-vsi-svc-static-3.3.3.9-3] quit
    [PE1-vsi-svc-static] quit
    [PE1-vsi-svc] quit
    

    # Bind Layer 3 Ethernet interface GigabitEthernet 2/1/1 to VSI svc.

    [PE1] interface gigabitethernet 2/1/1
    [PE1-GigabitEthernet2/1/1] xconnect vsi svc
    [PE1-GigabitEthernet2/1/1] quit
    
  2. Configure PE 2:

    # Configure an LSR ID.

    <PE2> system-view
    [PE2] interface loopback 0
    [PE2-LoopBack0] ip address 2.2.2.9 32
    [PE2-LoopBack0] quit
    [PE2] mpls lsr-id 2.2.2.9
    

    # Enable L2VPN.

    [PE2] l2vpn enable
    

    # Enable global LDP.

    [PE2] mpls ldp
    [PE2-ldp] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to PE 1), and enable LDP on the interface.

    [PE2] interface gigabitethernet 2/1/2
    [PE2-GigabitEthernet2/1/2] ip address 20.1.1.2 24
    [PE2-GigabitEthernet2/1/2] mpls enable
    [PE2-GigabitEthernet2/1/2] mpls ldp enable
    [PE2-GigabitEthernet2/1/2] quit
    

    # Configure GigabitEthernet 2/1/3 (the interface connected to PE 3), and enable LDP on the interface.

    [PE2] interface gigabitethernet 2/1/3
    [PE2-GigabitEthernet2/1/3] ip address 40.1.1.2 24
    [PE2-GigabitEthernet2/1/3] mpls enable
    [PE2-GigabitEthernet2/1/3] mpls ldp enable
    [PE2-GigabitEthernet2/1/3] quit
    

    # Configure OSPF for LDP to create LSPs.

    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    

    # Create a VSI, specify the peer PEs, and establish static PWs to the peer PEs.

    [PE2] vsi svc
    [PE2-vsi-svc] pwsignaling static
    [PE2-vsi-svc-static] peer 1.1.1.9 pw-id 3 in-label 100 out-label 100
    [PE2-vsi-svc-static-1.1.1.9-3] quit
    [PE2-vsi-svc-static] peer 3.3.3.9 pw-id 3 in-label 300 out-label 300
    [PE2-vsi-svc-static-3.3.3.9-3] quit
    [PE2-vsi-svc-static] quit
    [PE2-vsi-svc] quit
    

    # Bind Layer 3 Ethernet interface GigabitEthernet 2/1/1 to VSI svc.

    [PE2] interface gigabitethernet 2/1/1
    [PE2-GigabitEthernet2/1/1] xconnect vsi svc
    [PE2-GigabitEthernet2/1/1] quit
    
  3. Configure PE 3:

    # Configure an LSR ID.

    <PE3> system-view
    [PE3] interface loopback 0
    [PE3-LoopBack0] ip address 3.3.3.9 32
    [PE3-LoopBack0] quit
    [PE3] mpls lsr-id 3.3.3.9
    

    # Enable L2VPN.

    [PE3] l2vpn enable
    

    # Enable global LDP.

    [PE3] mpls ldp
    [PE3-ldp] quit
    

    # Configure GigabitEthernet 2/1/2 (the interface connected to PE 1), and enable LDP on the interface.

    [PE3] interface gigabitethernet 2/1/2
    [PE3-GigabitEthernet2/1/2] ip address 30.1.1.3 24
    [PE3-GigabitEthernet2/1/2] mpls enable
    [PE3-GigabitEthernet2/1/2] mpls ldp enable
    [PE3-GigabitEthernet2/1/2] quit
    

    # Configure GigabitEthernet 2/1/3 (the interface connected to PE 2), and enable LDP on the interface.

    [PE3] interface gigabitethernet 2/1/3
    [PE3-GigabitEthernet2/1/3] ip address 40.1.1.3 24
    [PE3-GigabitEthernet2/1/3] mpls enable
    [PE3-GigabitEthernet2/1/3] mpls ldp enable
    [PE3-GigabitEthernet2/1/3] quit
    

    # Configure OSPF for LDP to create LSPs.

    [PE3] ospf
    [PE3-ospf-1] area 0
    [PE3-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [PE3-ospf-1-area-0.0.0.0] quit
    [PE3-ospf-1] quit
    

    # Create a VSI, specify the peer PEs, and establish static PWs to the peer PEs.

    [PE3] vsi svc
    [PE3-vsi-svc] pwsignaling static
    [PE3-vsi-svc-static] peer 1.1.1.9 pw-id 3 in-label 200 out-label 200
    [PE3-vsi-svc-static-1.1.1.9-3] quit
    [PE3-vsi-svc-static] peer 2.2.2.9 pw-id 3 in-label 300 out-label 300
    [PE3-vsi-svc-static-2.2.2.9-3] quit
    [PE3-vsi-svc-static] quit
    [PE3-vsi-svc] quit
    

    # Bind Layer 3 Ethernet interface GigabitEthernet 2/1/1 to VSI svc.

    [PE3] interface gigabitethernet 2/1/1
    [PE3-GigabitEthernet2/1/1] xconnect vsi svc
    [PE3-GigabitEthernet2/1/1] quit
    

Verifying the configuration

# Verify that two static PWs in up state have been established on PE 1.

[PE1] display l2vpn pw verbose
VSI Name: svc
  Peer: 2.2.2.9          PW ID: 3
    Signaling Protocol  : Static
    Link ID             : 8          PW State : Up
    In Label            : 100        Out Label: 100
    MTU                 : 1500
    PW Attributes       : Main
    VCCV CC             : -
    VCCV BFD            : -
    Tunnel Group ID     : 0x160000001
    Tunnel NHLFE IDs    : 1027
  Peer: 3.3.3.9          PW ID: 3
    Signaling Protocol  : Static
    Link ID             : 9          PW State : Up
    In Label            : 200        Out Label: 200
    MTU                 : 1500
    PW Attributes       : Main
    VCCV CC             : -
    VCCV BFD            : -
    Tunnel Group ID     : 0x260000002
    Tunnel NHLFE IDs    : 1028