Configuration procedure
Procedure
- Configure Switch A.
- # Configure IP addresses for interfaces (omitted.)
- # Configure the eBGP connection.
switch(config)# router bgp 65008 switch(bgp)# bgp router-id 1.1.1.1
- # Configure BGP GR stalepath-timeout (optional.)
switch(bgp)# bgp graceful-restart stalepath-time 360 switch(bgp)# neighbor 200.1.1.1 remote-as 65009
- # Add network 8.0.0.0/8 to the BGP routing table.
switch(bgp)# network 8.0.0.0/8
- # Enable GR for BGP Peer.
switch(bgp)# neighbor 200.1.1.1 graceful-restart
- Configure Switch B.
- # Configure IP addresses for interfaces (omitted.)
- # Configure the eBGP connection.
switch(bgp)# router bgp 65009
- # Configure BGP GR restart-time and stalepath-timeout
(Optional.)
switch(bgp)# bgp graceful-restart restart-time 120 stalepath-time 360 switch(bgp)# bgp router-id 2.2.2.2 switch(bgp)# neighbor 200.1.1.2 remote-as 65008
- # Configure the iBGP connection.
switch(bgp)# neighbor 9.1.1.2 remote-as 65009
- # Configure BGP to redistribute direct routes.
switch(bgp)# redistribute connected
- # Enable GR capability for BGP Peers.
switch(bgp)# neighbor 200.1.1.2 graceful-restart switch(bgp)# neighbor 9.1.1.2 graceful-restart
- # Configure BGP for non-stop forwarding
switch(bgp)# non-stop
- Configure Switch C.
- # Configure IP addresses for interfaces (omitted.)
- # Configure the iBGP connection.
switch(config)# router bgp 65009 switch(bgp)# bgp router-id 3.3.3.3 switch(bgp)# neighbor 9.1.1.1 remote-as 65009
- # Configure BGP to redistribute direct routes.
switch(bgp)# redistribute connected
- BGP Configuration Example
- # Enable GR for BGP Peer.
switch(bgp)# neighbor 9.1.1.1 graceful-restart