Printable version

Drivers & software

* RECOMMENDED * HPE Dynamic Smart Array B120i/B320i SATA RAID Controller Driver for Red Hat Enterprise Linux 7 (64-bit)

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Driver - Storage Controller
Version: 1.2.16-114(8 Dec 2017)
Operating System(s): Red Hat Enterprise Linux 7 Server
Multi-part download
File name: kmod-hpvsa-1.2.16-114.rhel7u3.x86_64.rpm (641 KB)
File name: kmod-hpvsa-1.2.16-114.rhel7u4.x86_64.rpm (642 KB)
This RPM is used to provide binary driver modules that have been pre-built for Red Hat Enterprise Linux 7 (64-bit) to enable the HPE Smart Array B120i/B320i SATA RAID controller.

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 Update 4.

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

9e029476cfbc992d0ff2713afef273950fe12643eb20df3827ecfb29609387e2 kmod-hpvsa-1.2.16-114.rhel7u3.x86_64.rpm
09a82ef9ab66c606a6b404baa90f72aaacc2f877e432d3dec135c7f0c400be99 kmod-hpvsa-1.2.16-114.rhel7u4.x86_64.rpm

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Login as the system administrator (root), download the RPM to a directory on
your hard drive and change to that directory.

To install or upgrade the driver type:

# rpm -Uvh Kmod-hpvsa-<version>.<OSupdate>.x86_64.rpm

Setup is now complete. Please REBOOT your computer NOW!!

NOTE: If the installation fails or if you see any warning or error messages, STOP, do NOT reboot the computer. The driver will not be operational and you must uninstall the driver by typing the following command:

# rpm -e Kmod-hpvsa-<version>.<OSupdate>.x86_64.rpm

Enterprise Support
For support on Smart Array controllers, visit http://www.hpe.com/support


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Supported Devices and Features:

SUPPORTED KERNELS:
The kernels of Red Hat Enterprise Linux 7 (AMD64/EM64T) supported by this binary rpm are:
3.10.0-514.el7- Red Hat Enterprise Linux 7 Update 3 (64-bit) and future errata kernels for update 3.
3.10.0-693.el7- Red Hat Enterprise Linux 7 Update 4 (64-bit) and future errata kernels for update 4.

 


Version:1.2.16-136 (30 Apr 2020)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Add support for Red Hat Enterprise Linux 7 Update 8


Version:1.2.16-132 (13 Sep 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 update 7


Version:1.2.16-125 (8 Jan 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 update 6


Version:1.2.16-121 (15 Oct 2018)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7.5


Version:1.2.16-114 (8 Dec 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 Update 4.


Version:1.2.16-102 (2 Dec 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Improved Performance levels.

Added support for Red Hat Enterprise Linux 7 Update 3.


Version:1.2.14-113 (22 Dec 2015)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The following issues were resolved:

  • Intermittent blue screen 0x133 (DPS_WATCHDOG_VIOLATION) error would display and the system would stop responding. This error was caused by a race condition that was exposed under particular IO patterns for controllers with write cache enabled.
  • CPU pinning enabled- PARSE and FLUSH tasks are pinned to the same CPU to prevent a potential race condition in the driver which might result in an OS panic with system restart.

 

Enhancements

 

Added Red Hat Enterprise Linux 7 Server Update 2 support.

 


Version:1.2.14-100 (15 Jun 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes the below issue:

When issuing the "shutdown -h now" command at the Linux prompt, the server begins shutting down, but instead of halting and powering off, the server resets itself and boots back up.


Version:1.2.12-112 (6 Apr 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 Update 1.


Version:1.2.12 (30 Mar 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Spin lock update to fix a potential boot hang.

Version:1.2.10 (9 Sep 2014)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Support added for Red Hat Enterprise Linux 7.

Type: Driver - Storage Controller
Version: 1.2.16-114(8 Dec 2017)
Operating System(s):
Red Hat Enterprise Linux 7 Server

Description

This RPM is used to provide binary driver modules that have been pre-built for Red Hat Enterprise Linux 7 (64-bit) to enable the HPE Smart Array B120i/B320i SATA RAID controller.

Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 Update 4.

Installation Instructions

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

9e029476cfbc992d0ff2713afef273950fe12643eb20df3827ecfb29609387e2 kmod-hpvsa-1.2.16-114.rhel7u3.x86_64.rpm
09a82ef9ab66c606a6b404baa90f72aaacc2f877e432d3dec135c7f0c400be99 kmod-hpvsa-1.2.16-114.rhel7u4.x86_64.rpm

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Login as the system administrator (root), download the RPM to a directory on
your hard drive and change to that directory.

To install or upgrade the driver type:

# rpm -Uvh Kmod-hpvsa-<version>.<OSupdate>.x86_64.rpm

Setup is now complete. Please REBOOT your computer NOW!!

NOTE: If the installation fails or if you see any warning or error messages, STOP, do NOT reboot the computer. The driver will not be operational and you must uninstall the driver by typing the following command:

# rpm -e Kmod-hpvsa-<version>.<OSupdate>.x86_64.rpm

Enterprise Support
For support on Smart Array controllers, visit http://www.hpe.com/support


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Supported Devices and Features:

SUPPORTED KERNELS:
The kernels of Red Hat Enterprise Linux 7 (AMD64/EM64T) supported by this binary rpm are:
3.10.0-514.el7- Red Hat Enterprise Linux 7 Update 3 (64-bit) and future errata kernels for update 3.
3.10.0-693.el7- Red Hat Enterprise Linux 7 Update 4 (64-bit) and future errata kernels for update 4.

 


Revision History

Version:1.2.16-136 (30 Apr 2020)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Add support for Red Hat Enterprise Linux 7 Update 8


Version:1.2.16-132 (13 Sep 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 update 7


Version:1.2.16-125 (8 Jan 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 update 6


Version:1.2.16-121 (15 Oct 2018)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7.5


Version:1.2.16-114 (8 Dec 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 Update 4.


Version:1.2.16-102 (2 Dec 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Improved Performance levels.

Added support for Red Hat Enterprise Linux 7 Update 3.


Version:1.2.14-113 (22 Dec 2015)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The following issues were resolved:

  • Intermittent blue screen 0x133 (DPS_WATCHDOG_VIOLATION) error would display and the system would stop responding. This error was caused by a race condition that was exposed under particular IO patterns for controllers with write cache enabled.
  • CPU pinning enabled- PARSE and FLUSH tasks are pinned to the same CPU to prevent a potential race condition in the driver which might result in an OS panic with system restart.

 

Enhancements

 

Added Red Hat Enterprise Linux 7 Server Update 2 support.

 


Version:1.2.14-100 (15 Jun 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes the below issue:

When issuing the "shutdown -h now" command at the Linux prompt, the server begins shutting down, but instead of halting and powering off, the server resets itself and boots back up.


Version:1.2.12-112 (6 Apr 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added support for Red Hat Enterprise Linux 7 Update 1.


Version:1.2.12 (30 Mar 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Spin lock update to fix a potential boot hang.

Version:1.2.10 (9 Sep 2014)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Support added for Red Hat Enterprise Linux 7.

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.