Printable version

Drivers & software

* RECOMMENDED * HPE ProLiant Gen10 Smart Array Controller Driver for VMware vSphere 6.5 (Driver Component).

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Driver - Storage Controller
Version: 2019.06.01(10 Jun 2019)
Operating System(s): VMware vSphere 6.5
Multi-part download
File name: cp039887.compsig (2.0 KB)
File name: cp039887.zip (94 KB)
HPE Smart Array controller driver component for VMware vSphere 6.5, for use with HPE Smart Update Manager.

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

756a12f66d8e5761aa06410328542d1ab5298d5fcbde1f421b27de08af7a0c42 cp039887.compsig
bcb028a599c31a0f2bd2ae537bdbe671cefcb173bdfe30bb1b5075c17992b4a4 cp039887.zip

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

To use Smart Update Manager from the HPE Service Pack for ProLiant

Remote Online:

  •  Place the SPP on a USB key using the HPE USB Key Creator Utility.
  •  Place the desired driver to be updated in the directory, /SPP20xxxxx/hp/swpackages on the USB key.
  •  Mount the USB key on a remote server running Windows or Linux
  •  CD /hp/swpackages and ./hpsum
  •  Select the next button
  •  Click Add Single Target
  •  Type the IP or DNS address of the ESXi host to be updated
  •  Enter the ESXi host credentials (root or administrator username and password)
  •  Follow Smart Update Manager Steps and complete the update.

To update the driver using VMware tools:

  •  Unzip this HPE component to extract the driver offline bundle
  •  Use VMware VUM or esxcli commands to install the offline bundle.
  •  Refer to VMware documentation for information on VUM and the esxcli commands.


 


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Important:

This component is intended to be used by HPE applications.  It is a zip that contains the same driver deliverable available from the vmware.com and the HPE vibsdepot.hp.com webpages, plus an HPE specific CPXXXX.xml file.


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes the following issues

  • During hotplug reinsertion and while under heavy I/O system can return a checksum error.
  • Customer could encounter a data coherency issue that will cause the system to return a Purple Screen Of Death (PSOD) when system fails to complete I/O's. Please reference Customer Advisory a00071158en_us for more details.
  • Possible PSOD when a TMF request timed out
  • Fixed an issue where I/O tags could get exhausted when Task Management Function (TMF) fails.
  • Possible PSOD while Lun reset completes with service response failure
  • Possible PSOD due to incorrect queue selection logic for AIO TaskManagement
  • Controller could stop responding due to outstanding IO during pqi reset.
  • Inquiring command could potentially fail during device discovery
  • Refer to the Customer Advisory  a00071158en_us for details for use in the VMware vSAN environment as well as minimal Synergy Core SPP requirements for Synergy environments.

This component is intended to be used by HPE applications.  It is a zip that contains the same driver deliverable available from the vmware.com and the HPE vibsdepot.hp.com webpages, plus an HPE specific CPXXXX.xml file.

Version:2019.12.01 (20 Dec 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Add Timeout support field in pass-through and task management request in order to enable a recover mechanism when a when a pass-through command fails to complete.


Version:2019.06.01 (10 Jun 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes the following issues

  • During hotplug reinsertion and while under heavy I/O system can return a checksum error.
  • Customer could encounter a data coherency issue that will cause the system to return a Purple Screen Of Death (PSOD) when system fails to complete I/O's. Please reference Customer Advisory a00071158en_us for more details.
  • Possible PSOD when a TMF request timed out
  • Fixed an issue where I/O tags could get exhausted when Task Management Function (TMF) fails.
  • Possible PSOD while Lun reset completes with service response failure
  • Possible PSOD due to incorrect queue selection logic for AIO TaskManagement
  • Controller could stop responding due to outstanding IO during pqi reset.
  • Inquiring command could potentially fail during device discovery
  • Refer to the Customer Advisory  a00071158en_us for details for use in the VMware vSAN environment as well as minimal Synergy Core SPP requirements for Synergy environments.

Version:2019.03.12 (2 Apr 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes the following issues

  • While in multipath, driver could go offline when the active path is removed.
  • Incorrect SAS address is displayed under multipath information for MSA attached arrays.
  • Disk might become unresponsive after a vSphere Quick Boot.
  • Driver unload could failed after an expander device is removed.
  • PSOD could be observe while performing a hard drive hot remove/re-insert.
  • PSOD might occur after lockup followed by an ESXI shell reboot.
  • Crash dump might not be generated in a NUMA machine.
  • While performing array creation and deletion a PSOD could be observe after two controller lockup.
  • Drivers could go offline during running time when DMA memory is not available

Version:2018.07.18 (20 Jul 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • For systems running VMware vSphere 6.0, 6.5, or 6.7 and configured with multiple paths to a supported disk enclosure, a single path failure might result in a loss of disk connectivity.

Version:2018.06.04 (26 Jun 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Only one path was visible when running VMware with a multi-path configuration.

Version:2018.03.21 (27 Mar 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Only one path was visible when running VMware with a multi-path configuration.

Version:2018.02.12 (5 Feb 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


    • VMware driver not exposing more than 8 controllers to the system.
    • Cloning or copying a Virtual Machine Disk (VMDK) might not progress if HardwareAcceleratedMoveEnabled (XCOPY) is set.
    • Path failure/failover on ESXi 6.x when using an RDM might result in IO errors.
    • Controller might go offline while running vSAN in a hybrid configuration.

Version:2017.06.05(A) (25 Sep 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The following changes are included in version 2017.06.05(A)

Added support for the following Gen10 servers:

  • HPE ProLiant XL190r Gen10 Server
  • HPE ProLiant XL170r Gen10 Server
  • HPE ProLiant DL180 Gen10 Server
  • HPE ProLiant DL160 Gen10 Server
  • HPE ProLiant DL580 Gen10 Server
  • HPE ProLiant ML110 Gen10 Server
  • HPE ProLiant ML350 Gen10 Server
  • HPE ProLiant XL450 Gen10 Server
  • HPE ProLiant DL120 Gen10 Server

 


Version:2017.06.05 (12 Jul 2017)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Initial driver release for HPE P/E-Class SR Gen10 controllers.

Type: Driver - Storage Controller
Version: 2019.06.01(10 Jun 2019)
Operating System(s):
VMware vSphere 6.5

Description

HPE Smart Array controller driver component for VMware vSphere 6.5, for use with HPE Smart Update Manager.

Installation Instructions

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

756a12f66d8e5761aa06410328542d1ab5298d5fcbde1f421b27de08af7a0c42 cp039887.compsig
bcb028a599c31a0f2bd2ae537bdbe671cefcb173bdfe30bb1b5075c17992b4a4 cp039887.zip

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

To use Smart Update Manager from the HPE Service Pack for ProLiant

Remote Online:

  •  Place the SPP on a USB key using the HPE USB Key Creator Utility.
  •  Place the desired driver to be updated in the directory, /SPP20xxxxx/hp/swpackages on the USB key.
  •  Mount the USB key on a remote server running Windows or Linux
  •  CD /hp/swpackages and ./hpsum
  •  Select the next button
  •  Click Add Single Target
  •  Type the IP or DNS address of the ESXi host to be updated
  •  Enter the ESXi host credentials (root or administrator username and password)
  •  Follow Smart Update Manager Steps and complete the update.

To update the driver using VMware tools:

  •  Unzip this HPE component to extract the driver offline bundle
  •  Use VMware VUM or esxcli commands to install the offline bundle.
  •  Refer to VMware documentation for information on VUM and the esxcli commands.


 


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Important:

This component is intended to be used by HPE applications.  It is a zip that contains the same driver deliverable available from the vmware.com and the HPE vibsdepot.hp.com webpages, plus an HPE specific CPXXXX.xml file.


Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes the following issues

  • During hotplug reinsertion and while under heavy I/O system can return a checksum error.
  • Customer could encounter a data coherency issue that will cause the system to return a Purple Screen Of Death (PSOD) when system fails to complete I/O's. Please reference Customer Advisory a00071158en_us for more details.
  • Possible PSOD when a TMF request timed out
  • Fixed an issue where I/O tags could get exhausted when Task Management Function (TMF) fails.
  • Possible PSOD while Lun reset completes with service response failure
  • Possible PSOD due to incorrect queue selection logic for AIO TaskManagement
  • Controller could stop responding due to outstanding IO during pqi reset.
  • Inquiring command could potentially fail during device discovery
  • Refer to the Customer Advisory  a00071158en_us for details for use in the VMware vSAN environment as well as minimal Synergy Core SPP requirements for Synergy environments.

Important

This component is intended to be used by HPE applications.  It is a zip that contains the same driver deliverable available from the vmware.com and the HPE vibsdepot.hp.com webpages, plus an HPE specific CPXXXX.xml file.

Revision History

Version:2019.12.01 (20 Dec 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Add Timeout support field in pass-through and task management request in order to enable a recover mechanism when a when a pass-through command fails to complete.


Version:2019.06.01 (10 Jun 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes the following issues

  • During hotplug reinsertion and while under heavy I/O system can return a checksum error.
  • Customer could encounter a data coherency issue that will cause the system to return a Purple Screen Of Death (PSOD) when system fails to complete I/O's. Please reference Customer Advisory a00071158en_us for more details.
  • Possible PSOD when a TMF request timed out
  • Fixed an issue where I/O tags could get exhausted when Task Management Function (TMF) fails.
  • Possible PSOD while Lun reset completes with service response failure
  • Possible PSOD due to incorrect queue selection logic for AIO TaskManagement
  • Controller could stop responding due to outstanding IO during pqi reset.
  • Inquiring command could potentially fail during device discovery
  • Refer to the Customer Advisory  a00071158en_us for details for use in the VMware vSAN environment as well as minimal Synergy Core SPP requirements for Synergy environments.

Version:2019.03.12 (2 Apr 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes the following issues

  • While in multipath, driver could go offline when the active path is removed.
  • Incorrect SAS address is displayed under multipath information for MSA attached arrays.
  • Disk might become unresponsive after a vSphere Quick Boot.
  • Driver unload could failed after an expander device is removed.
  • PSOD could be observe while performing a hard drive hot remove/re-insert.
  • PSOD might occur after lockup followed by an ESXI shell reboot.
  • Crash dump might not be generated in a NUMA machine.
  • While performing array creation and deletion a PSOD could be observe after two controller lockup.
  • Drivers could go offline during running time when DMA memory is not available

Version:2018.07.18 (20 Jul 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • For systems running VMware vSphere 6.0, 6.5, or 6.7 and configured with multiple paths to a supported disk enclosure, a single path failure might result in a loss of disk connectivity.

Version:2018.06.04 (26 Jun 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Only one path was visible when running VMware with a multi-path configuration.

Version:2018.03.21 (27 Mar 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Only one path was visible when running VMware with a multi-path configuration.

Version:2018.02.12 (5 Feb 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


    • VMware driver not exposing more than 8 controllers to the system.
    • Cloning or copying a Virtual Machine Disk (VMDK) might not progress if HardwareAcceleratedMoveEnabled (XCOPY) is set.
    • Path failure/failover on ESXi 6.x when using an RDM might result in IO errors.
    • Controller might go offline while running vSAN in a hybrid configuration.

Version:2017.06.05(A) (25 Sep 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The following changes are included in version 2017.06.05(A)

Added support for the following Gen10 servers:

  • HPE ProLiant XL190r Gen10 Server
  • HPE ProLiant XL170r Gen10 Server
  • HPE ProLiant DL180 Gen10 Server
  • HPE ProLiant DL160 Gen10 Server
  • HPE ProLiant DL580 Gen10 Server
  • HPE ProLiant ML110 Gen10 Server
  • HPE ProLiant ML350 Gen10 Server
  • HPE ProLiant XL450 Gen10 Server
  • HPE ProLiant DL120 Gen10 Server

 


Version:2017.06.05 (12 Jul 2017)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Initial driver release for HPE P/E-Class SR Gen10 controllers.

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.