Printable version

Drivers & software

HP Insight Management WBEM Providers for Windows Server 2008 x64 Editions

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Software - System Management
Version: 9.1.0.0(4 Jun 2012)
Operating System(s): Microsoft Windows Server 2008 R2
Microsoft Windows Server 2008 R2 Foundation Edition
Microsoft Windows Server 2008 x64
Microsoft Windows Server 2012
File name: cp015350.exe (14 MB)
The HP Insight Management WBEM Providers supply system management data through the Windows Management Instrumentation framework for HP ProLiant server platforms and options. The Insight Providers offer industry standard DMTF SMASH profile and SNIA SMI-S profile compliance.

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new systems in this release as well as cooridnate dual rotor fan support reporting with iLO.

Prerequisites:

The HP Insight Management WBEM Providers version 9.1.0.0 require storage, network, system management controller, and Lights-Out interface drivers from PSP 9.10.

In addition, the System Management Homepage (SMH) component is required for a single server web-based user interface.

 


To ensure the integrity of your download, HP recommends verifying your results with this MD5 Checksum value:

d6a396629cac180d3cb49b021b35661a cp015350.exe

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Place the Smart Component in a temporary directory, then double-click it to run.

Select "Install" to start extracting to a temporary location on the hard drive.

Click the "Install" button to perform the installation.

 


End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Version:10.75.0.0 (2 Apr 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the incorrect System Management Homepage red icon status of Smart Array controllers, if the controller has logical drive(s) created with HPE Smart Storage Administrator version later than 3.10.3.0.


Version:10.71.0.0 (27 Nov 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Implemented a workaround to fix errors seen with Hyper-V commands after WBEM Providers are installed under Microsoft Windows Server 2012 R2 and Microsoft Windows Server 2016. 

Refer to the following Customer Advisory for more info on the issue and workaround: https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00053606en_us

  • Fixed an application error seen upon querying data from HPE Network WBEM Providers, on systems with Broadcom NIC devices using bmapia.dll. 

 


Version:10.70.0.0 (5 Feb 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed a handle leak caused by Storage provider (hpwmisa.dll).


Version:10.65.0.0 (12 Jul 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


none

Enhancements

  • Applied a SHA-256 digital signature to the WBEM Providers MSI file as well as all the binary files contained in it.
  • Allowed installation to proceed on systems with the Windows Remote Registry service disabled.

Version:10.61.0.0 (21 Apr 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


None

Enhancements

  • Applied a SHA-256 digital signature to the WBEM Providers MSI file as well as all the binary files contained in it.
  • Allowed installation to proceed on systems with the Windows Remote Registry service disabled.

Version:10.60.0.0 (24 Oct 2016)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Fixed the issue with Insight Management WBEM override root\interop namespace for Hyper-V.
  • 50% slow performance/backup issue with HP Ultrium/LTO polling issues.

  • Tape backup fails randomly (irrespective of any server or controller/backup software) when HPE Insight Management WBEM Providers is upgraded to version 10.X.

  •  Providers are causing spare drives to be spun up every few minutes.

Enhancements

Added support for Microsoft Windows Server 2016 and other new ProLiant servers and options.


Version:10.40.0.0 (1 Apr 2016)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2016.03.0.

Version:10.30.0.0 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2015.10.0.

Version:10.20.0.0 (15 Jun 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2015.06.

Version:10.10.0.0 (30 Mar 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2015.03.
  • Added support for HP SUM Version 7.2.
  • Added verbose logging in Windows.

Version:10.0.0.0 (9 Sep 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Enable option to include/exclude Fiber Channel Port status
  • Host Bus Adapter mode reporting for Smart Array Controllers

Version:9.5.0.0 (18 Feb 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Support for Unified Extensible Firware Interface Platforms
  • Encryption status reporting for Smart Array controllers

 


Version:9.4.0.0 (10 Sep 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Ipv6 for iLo
  • iSCSI

 


Version:9.3.0.0 (19 Feb 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


 

Enhancements

  •  To report Rank,Techonology,Operating and minimum voltage for DIMM's

Version:9.2.5.0 (26 Oct 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Support for HP Smart Memory and new memory related properties.

Version:9.2.0.0 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Provider License related information for certain Smart Array cards.
  • Report Smart Array Controller,Cache Module and Capacitor Temperature information.
  • WBEM Indications to differentiate memory board errors and DIMM errors.

Version:9.1.0.0 (4 Jun 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new systems in this release as well as cooridnate dual rotor fan support reporting with iLO.


Version:9.0.0.0 (27 Mar 2012)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


 

 

Enhancements

The HP Insight Management WBEM Providers version 9.0.0.0 contain the following new features: Matrix Identification support and BIOS Auditing. 

 


Version:2.8.0.0 (11 Mar 2011)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Logical disk table is added for SAS disp page
  • Status Icon issue for SA controller page is fixed
  • CPU Threshold Indication issue is fixed
  • Improper use of ThresholdIdentifier property issue is fixed

 

Enhancements

  • SATA hotswap is feature is implemented
  • Common library syncup is done
  • ILO reset Indiaction provider is implemented
  • Enhancements to Spinner for 2.8.0
  • New server and options supported by SS8.70

Version:2.7.0.0 (5 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Restarting SNMP Agents no longer causes switching Data source to WBEM from SNMP
  • WebApp SMH is now displaying complete name for SAS HBA
Enhancements

The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers). The HP Insight Management WBEM Providers do not work in a virtualized guest environment.

Enhancements to Spinner for 2.7.0

New server and options supported by SS8.60

Addition of McSysProvider support for Integrity

Addition of entry for marketing name for FCoE


Version:2.6.1.0 (21 Jun 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


HP Insight WBEM Providers 2.6.1.0 addresses the following problems:

  • Latent issues found in the 2.6.0.0 providers support for the HP ProLiant DL580 G7 and the HP ProLiant DL980 G7 servers.
  • An issue where network providers failed to communicate with some network adapters in systems running  Microsoft® Windows® 2008.
    Note: Customer may still experience an issue where firmware information is not being provided for all network adapters on systems running Microsoft® Windows® 2008 R2 Server Core.
Enhancements

The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers).

The HP Insight Management WBEM Providers do not work in a virtualized guest environment. 


Version:2.6.0.0 (27 May 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers).

The HP Insight Management WBEM Providers do not work in a virtualized guest environment.

Adding Simple Host Attached Storage Provider [new SATA provider]

Isis/Electra FW version reporting

 


Version:2.5.0.0 (29 Mar 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers). The HP Insight Management WBEM Providers do not work in a virtualized guest environment. Adding Simple Host Attached Storage Provider [new SATA provider]


Version:2.4.0.0 (14 Sep 2009)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Enhanced component-level logging has been implemented in the smart component installer. The generated log file will be located on the target system in %SYSTEMROOT%\cpqsystem\log directory under the name CPQSETUP.LOG. The HP Insight Management WBEM Providers do not work in a virtualized guest environment


Version:2.3.2.0 (23 Jun 2009)
Fixes

Fixes the update status for firmware showing Not Required when queried from Microsoft SCCM even though the update is applicable on clients with the HP Insight Management WBEM Providers version 2.3.0.0 installed.


Version:2.3.0.0 (30 Mar 2009)
Fixes

HP_PCISlot updated to include PCI Express slot types

Updated to translate SMBIOS enumerations for memory and CPU due to changes introduced in DMTF SMBIOS spec 2.6.1 for G6 servers

Fixed the SMH WebApp to properly set Disk and CPU threshold values

Fixed issue where mulitiple CPU and Disk Threshold indications were getting logged for the same state

Fixed Wrong health status reported in class HP_WinComputerSystem

Changed to use worst of DIMM status for the memory collection to match SNMP

Fixed issue: Event Time not diplayed on POST indication

Fixed issue: Cannot use the HP_RealizesPowerSupply antecedent to getInstance on HP_WinPowerSupply

Fixed issue: Cannot use the HP_RealizesFan antecedent to getInstance on HP_WinFan

Fixed issue: Cannot use the HP_FanInSlot and HP_PowerSupplyInSlot antecedent to getInstance on HP_FanSlot or HP_PowerSupplySlot

 

Enhancements

Added support for Fibre Channel Controller information and indications

All storage providers now support native x64 operation. Previous versions of the Insight Providers included only 32-bit storage providers.

Added support for SMI-S defined Host Discovered Resource (HDR) profile which provides OS volume information

Added support for nearline tape devices

IPv6 level 4 compliance

SMH v3.x support, including setting SMH data source (WBEM)

SMH data source (WBEM vs SNMP) is now settable via HP SIM "Replicate Agent Settings"

iLO reset capability via SMH WebApp

Support for OS Status profile

Support for Platform Watchdog profile

State propogation filtering added for power supplies, in addition to previous implementation for NICs and management processor NICs

Added support for SmartArray dual domain and multi-path cabling configuration

 


Version:2.2.1.0 (15 Sep 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated hardware support.


Version:2.2.0.0 (2 Jul 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated hardware support.


Version:2.1.1.0 (2 Apr 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Initial release.


Version:2.1.0.0 (25 Feb 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Initial release.


Type: Software - System Management
Version: 9.1.0.0(4 Jun 2012)
Operating System(s):
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2008 R2 Foundation Edition
Microsoft Windows Server 2008 x64
Microsoft Windows Server 2012

Description

The HP Insight Management WBEM Providers supply system management data through the Windows Management Instrumentation framework for HP ProLiant server platforms and options. The Insight Providers offer industry standard DMTF SMASH profile and SNIA SMI-S profile compliance.

Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new systems in this release as well as cooridnate dual rotor fan support reporting with iLO.

Installation Instructions

Prerequisites:

The HP Insight Management WBEM Providers version 9.1.0.0 require storage, network, system management controller, and Lights-Out interface drivers from PSP 9.10.

In addition, the System Management Homepage (SMH) component is required for a single server web-based user interface.

 


To ensure the integrity of your download, HP recommends verifying your results with this MD5 Checksum value:

d6a396629cac180d3cb49b021b35661a cp015350.exe

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Place the Smart Component in a temporary directory, then double-click it to run.

Select "Install" to start extracting to a temporary location on the hard drive.

Click the "Install" button to perform the installation.

 


Release Notes

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Revision History

Version:10.75.0.0 (2 Apr 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the incorrect System Management Homepage red icon status of Smart Array controllers, if the controller has logical drive(s) created with HPE Smart Storage Administrator version later than 3.10.3.0.


Version:10.71.0.0 (27 Nov 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Implemented a workaround to fix errors seen with Hyper-V commands after WBEM Providers are installed under Microsoft Windows Server 2012 R2 and Microsoft Windows Server 2016. 

Refer to the following Customer Advisory for more info on the issue and workaround: https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00053606en_us

  • Fixed an application error seen upon querying data from HPE Network WBEM Providers, on systems with Broadcom NIC devices using bmapia.dll. 

 


Version:10.70.0.0 (5 Feb 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed a handle leak caused by Storage provider (hpwmisa.dll).


Version:10.65.0.0 (12 Jul 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


none

Enhancements

  • Applied a SHA-256 digital signature to the WBEM Providers MSI file as well as all the binary files contained in it.
  • Allowed installation to proceed on systems with the Windows Remote Registry service disabled.

Version:10.61.0.0 (21 Apr 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


None

Enhancements

  • Applied a SHA-256 digital signature to the WBEM Providers MSI file as well as all the binary files contained in it.
  • Allowed installation to proceed on systems with the Windows Remote Registry service disabled.

Version:10.60.0.0 (24 Oct 2016)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Fixed the issue with Insight Management WBEM override root\interop namespace for Hyper-V.
  • 50% slow performance/backup issue with HP Ultrium/LTO polling issues.

  • Tape backup fails randomly (irrespective of any server or controller/backup software) when HPE Insight Management WBEM Providers is upgraded to version 10.X.

  •  Providers are causing spare drives to be spun up every few minutes.

Enhancements

Added support for Microsoft Windows Server 2016 and other new ProLiant servers and options.


Version:10.40.0.0 (1 Apr 2016)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2016.03.0.

Version:10.30.0.0 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2015.10.0.

Version:10.20.0.0 (15 Jun 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2015.06.

Version:10.10.0.0 (30 Mar 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Added support for new ProLiant servers and options that are supported by HP Service Pack for ProLiant version 2015.03.
  • Added support for HP SUM Version 7.2.
  • Added verbose logging in Windows.

Version:10.0.0.0 (9 Sep 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Enable option to include/exclude Fiber Channel Port status
  • Host Bus Adapter mode reporting for Smart Array Controllers

Version:9.5.0.0 (18 Feb 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Support for Unified Extensible Firware Interface Platforms
  • Encryption status reporting for Smart Array controllers

 


Version:9.4.0.0 (10 Sep 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Ipv6 for iLo
  • iSCSI

 


Version:9.3.0.0 (19 Feb 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


 

Enhancements

  •  To report Rank,Techonology,Operating and minimum voltage for DIMM's

Version:9.2.5.0 (26 Oct 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Support for HP Smart Memory and new memory related properties.

Version:9.2.0.0 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Provider License related information for certain Smart Array cards.
  • Report Smart Array Controller,Cache Module and Capacitor Temperature information.
  • WBEM Indications to differentiate memory board errors and DIMM errors.

Version:9.1.0.0 (4 Jun 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new systems in this release as well as cooridnate dual rotor fan support reporting with iLO.


Version:9.0.0.0 (27 Mar 2012)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


 

 

Enhancements

The HP Insight Management WBEM Providers version 9.0.0.0 contain the following new features: Matrix Identification support and BIOS Auditing. 

 


Version:2.8.0.0 (11 Mar 2011)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Logical disk table is added for SAS disp page
  • Status Icon issue for SA controller page is fixed
  • CPU Threshold Indication issue is fixed
  • Improper use of ThresholdIdentifier property issue is fixed

 

Enhancements

  • SATA hotswap is feature is implemented
  • Common library syncup is done
  • ILO reset Indiaction provider is implemented
  • Enhancements to Spinner for 2.8.0
  • New server and options supported by SS8.70

Version:2.7.0.0 (5 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • Restarting SNMP Agents no longer causes switching Data source to WBEM from SNMP
  • WebApp SMH is now displaying complete name for SAS HBA
Enhancements

The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers). The HP Insight Management WBEM Providers do not work in a virtualized guest environment.

Enhancements to Spinner for 2.7.0

New server and options supported by SS8.60

Addition of McSysProvider support for Integrity

Addition of entry for marketing name for FCoE


Version:2.6.1.0 (21 Jun 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


HP Insight WBEM Providers 2.6.1.0 addresses the following problems:

  • Latent issues found in the 2.6.0.0 providers support for the HP ProLiant DL580 G7 and the HP ProLiant DL980 G7 servers.
  • An issue where network providers failed to communicate with some network adapters in systems running  Microsoft® Windows® 2008.
    Note: Customer may still experience an issue where firmware information is not being provided for all network adapters on systems running Microsoft® Windows® 2008 R2 Server Core.
Enhancements

The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers).

The HP Insight Management WBEM Providers do not work in a virtualized guest environment. 


Version:2.6.0.0 (27 May 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers).

The HP Insight Management WBEM Providers do not work in a virtualized guest environment.

Adding Simple Host Attached Storage Provider [new SATA provider]

Isis/Electra FW version reporting

 


Version:2.5.0.0 (29 Mar 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The component installer has been updated to recognize if it is running within a virtualized guest environment (as of version 2.3.0.0 of the HP Insight Management WBEM Providers). The HP Insight Management WBEM Providers do not work in a virtualized guest environment. Adding Simple Host Attached Storage Provider [new SATA provider]


Version:2.4.0.0 (14 Sep 2009)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Enhanced component-level logging has been implemented in the smart component installer. The generated log file will be located on the target system in %SYSTEMROOT%\cpqsystem\log directory under the name CPQSETUP.LOG. The HP Insight Management WBEM Providers do not work in a virtualized guest environment


Version:2.3.2.0 (23 Jun 2009)
Fixes

Fixes the update status for firmware showing Not Required when queried from Microsoft SCCM even though the update is applicable on clients with the HP Insight Management WBEM Providers version 2.3.0.0 installed.


Version:2.3.0.0 (30 Mar 2009)
Fixes

HP_PCISlot updated to include PCI Express slot types

Updated to translate SMBIOS enumerations for memory and CPU due to changes introduced in DMTF SMBIOS spec 2.6.1 for G6 servers

Fixed the SMH WebApp to properly set Disk and CPU threshold values

Fixed issue where mulitiple CPU and Disk Threshold indications were getting logged for the same state

Fixed Wrong health status reported in class HP_WinComputerSystem

Changed to use worst of DIMM status for the memory collection to match SNMP

Fixed issue: Event Time not diplayed on POST indication

Fixed issue: Cannot use the HP_RealizesPowerSupply antecedent to getInstance on HP_WinPowerSupply

Fixed issue: Cannot use the HP_RealizesFan antecedent to getInstance on HP_WinFan

Fixed issue: Cannot use the HP_FanInSlot and HP_PowerSupplyInSlot antecedent to getInstance on HP_FanSlot or HP_PowerSupplySlot

 

Enhancements

Added support for Fibre Channel Controller information and indications

All storage providers now support native x64 operation. Previous versions of the Insight Providers included only 32-bit storage providers.

Added support for SMI-S defined Host Discovered Resource (HDR) profile which provides OS volume information

Added support for nearline tape devices

IPv6 level 4 compliance

SMH v3.x support, including setting SMH data source (WBEM)

SMH data source (WBEM vs SNMP) is now settable via HP SIM "Replicate Agent Settings"

iLO reset capability via SMH WebApp

Support for OS Status profile

Support for Platform Watchdog profile

State propogation filtering added for power supplies, in addition to previous implementation for NICs and management processor NICs

Added support for SmartArray dual domain and multi-path cabling configuration

 


Version:2.2.1.0 (15 Sep 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated hardware support.


Version:2.2.0.0 (2 Jul 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated hardware support.


Version:2.1.1.0 (2 Apr 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Initial release.


Version:2.1.0.0 (25 Feb 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Initial release.


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.