Printable version

Drivers & software

HP NMI Sourcing Driver for VMware ESXi 5.x

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Software - System Management
Version: 2.1(4 Sep 2012)
Operating System(s): VMware ESXi 5.0
VMware vSphere 5.1
File name: hp-nmi-esxi5.0-bundle-2.1-2.zip (15 KB)
VMware ESXi 5.x supports the capability to register for NMI events. HP is providing the HP NMI module (hpnmi) that will work with the ESXi 5.x kernel to log NMI info to the HP Integrated Management Log (IML).

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This is the initial version of this product. It does not support HP ProLiant Gen8 servers.

Note: After an NMI event is received by the server, the VMware ESXi 5.x kernel halts the server with Purple Screen of Death (PSoD) - “Panic requested by one or more 3rd party NMI handlers” to capture a kernel crash dump* on panic. If the HP NMI driver is not installed on VMware ESXi 5.x and a hardware fault event occurs, the NMI event information will not be logged to HP Integrated Management Log (IML) on HP ProLiant systems.
*Refer to VMware documentation at http://www.vmware.com/support/pubs/  for capturing crash dump files on VMware ESXi 5.x.

ja

To ensure the integrity of your download, HP recommends verifying your results with this MD5 Checksum value:

hp-nmi-esxi5.0-bundle-2.1-2.zip 8ec450c837febd191613dd9c8a99b043

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Installing Offline Bundles on an ESXi 5.x Host Using vSphere CLI 5.x esxcli Utility

You can use the esxcli utility in conjunction with offline bundles or with a depot. This topic describes the procedure using offline bundles.

Prerequisites

Before you can update or patch an ESXi 5.x host from the command line, you must have access to a machine on which you can run the VMware vSphere Command-Line Interface 5.x (vSphere CLI). You can install the vSphere CLI on your Microsoft Windows or Linux system. For information about importing or installing the vSphereCLI 5.x, see the VMware vSphere Command-Line Interface Guides at the folloiwng urls:

Procedure

  1. Power off any virtual machines that are running on the host and place the host into maintenance mode.
  2. Transfer the offline bundle onto the ESXi host local path, or extract it onto an online depot.
  3. Install the bundle on the ESXi host.  
  • Install remotely from client, with offline bundle contents on a online depot:  esxcli -s <server> -u root -p mypassword software vib install -d <depotURL/bundle-index.xml>
  • Install remotely from client, with offline bundle on ESXi host:  esxcli -s <server> -u root -p mypassword software vib install -d <ESXi local path><bundle.zip>
  • Install from ESXi host, with offline bundle on ESXi host:  esxcli software vib install -d <ESXi local path><bundle.zip>
  1. After the bundle is installed, reboot the ESXi host for the updates to take effect.
  2. (Optional) Verify that the vibs on the bundle are installed on your ESXi host: esxcli -s <server> -u root -p mypassword software vib list
  3. (Optional) Remove individual vibs. <vib name> can be identified by listing the vibs as shown in #5: esxcli -s <server> -u root -p mypassword software vib remove -n <vib name>

Installing Offline Bundles on an ESXi 5.x Host Using VMware vCenter Update Manager

The offline bundle can also be installed from VMware vCenter Update Manager as a patch. For more information and detailed instructions, see the VMware vCenter Update Manager Administration Guide located at http://pubs.vmware.com/vsphere-50/topic/com.vmware.vsphere.update_manager.doc_50/GUID-F7191592-048B-40C7-A610-CFEE6A790AB0.html.



End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Important:

  • Not intended for VMware ESX/ESXi 4.x
  • Does not support HP ProLiant Gen8 Servers

Supported Devices and Features:
VMware ESXi OS version support:

  • VMware ESXi 5.0
  • VMware ESXi 5.0  U1
  • VMware vSphere 5.1

 


  • Not intended for VMware ESX/ESXi 4.x
  • Does not support HP ProLiant Gen8 Servers
Version:2.3 (18 Feb 2014)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Fix metadata for custom ISO to successfully install on HP OEM Servers.

Version:2.1 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This is the initial version of this product. It does not support HP ProLiant Gen8 servers.

Note: After an NMI event is received by the server, the VMware ESXi 5.x kernel halts the server with Purple Screen of Death (PSoD) - “Panic requested by one or more 3rd party NMI handlers” to capture a kernel crash dump* on panic. If the HP NMI driver is not installed on VMware ESXi 5.x and a hardware fault event occurs, the NMI event information will not be logged to HP Integrated Management Log (IML) on HP ProLiant systems.
*Refer to VMware documentation at http://www.vmware.com/support/pubs/  for capturing crash dump files on VMware ESXi 5.x.

ja

Version:2.0 (24 Aug 2011)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

This package is supported for installation on the following versions of VMware OS:

  • VMware ESXi 5.0.0
  • VMware ESXi 5.0.0 Update 1

This is the initial version of this product. It does not support HP ProLiant Gen8

Note: After an NMI event is received by the server, the VMware ESXi 5.0 kernel halts the server with Purple Screen of Death (PSoD) - “Panic requested by one or more 3rd party NMI handlers” to capture a kernel crash dump* on panic. If the HP NMI driver is not installed on VMware ESXi 5.0 and a hardware fault event occurs, the NMI event information will not be logged to HP Integrated Management Log (IML) on HP ProLiant systems.
*Refer to VMware documentation at http://www.vmware.com/support/pubs/  for capturing crash dump files on VMware ESXi 5.0.

ja

Type: Software - System Management
Version: 2.1(4 Sep 2012)
Operating System(s):
VMware ESXi 5.0
VMware vSphere 5.1

Description

VMware ESXi 5.x supports the capability to register for NMI events. HP is providing the HP NMI module (hpnmi) that will work with the ESXi 5.x kernel to log NMI info to the HP Integrated Management Log (IML).

Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This is the initial version of this product. It does not support HP ProLiant Gen8 servers.

Note: After an NMI event is received by the server, the VMware ESXi 5.x kernel halts the server with Purple Screen of Death (PSoD) - “Panic requested by one or more 3rd party NMI handlers” to capture a kernel crash dump* on panic. If the HP NMI driver is not installed on VMware ESXi 5.x and a hardware fault event occurs, the NMI event information will not be logged to HP Integrated Management Log (IML) on HP ProLiant systems.
*Refer to VMware documentation at http://www.vmware.com/support/pubs/  for capturing crash dump files on VMware ESXi 5.x.

ja

Installation Instructions

To ensure the integrity of your download, HP recommends verifying your results with this MD5 Checksum value:

hp-nmi-esxi5.0-bundle-2.1-2.zip 8ec450c837febd191613dd9c8a99b043

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Installing Offline Bundles on an ESXi 5.x Host Using vSphere CLI 5.x esxcli Utility

You can use the esxcli utility in conjunction with offline bundles or with a depot. This topic describes the procedure using offline bundles.

Prerequisites

Before you can update or patch an ESXi 5.x host from the command line, you must have access to a machine on which you can run the VMware vSphere Command-Line Interface 5.x (vSphere CLI). You can install the vSphere CLI on your Microsoft Windows or Linux system. For information about importing or installing the vSphereCLI 5.x, see the VMware vSphere Command-Line Interface Guides at the folloiwng urls:

Procedure

  1. Power off any virtual machines that are running on the host and place the host into maintenance mode.
  2. Transfer the offline bundle onto the ESXi host local path, or extract it onto an online depot.
  3. Install the bundle on the ESXi host.  
  • Install remotely from client, with offline bundle contents on a online depot:  esxcli -s <server> -u root -p mypassword software vib install -d <depotURL/bundle-index.xml>
  • Install remotely from client, with offline bundle on ESXi host:  esxcli -s <server> -u root -p mypassword software vib install -d <ESXi local path><bundle.zip>
  • Install from ESXi host, with offline bundle on ESXi host:  esxcli software vib install -d <ESXi local path><bundle.zip>
  1. After the bundle is installed, reboot the ESXi host for the updates to take effect.
  2. (Optional) Verify that the vibs on the bundle are installed on your ESXi host: esxcli -s <server> -u root -p mypassword software vib list
  3. (Optional) Remove individual vibs. <vib name> can be identified by listing the vibs as shown in #5: esxcli -s <server> -u root -p mypassword software vib remove -n <vib name>

Installing Offline Bundles on an ESXi 5.x Host Using VMware vCenter Update Manager

The offline bundle can also be installed from VMware vCenter Update Manager as a patch. For more information and detailed instructions, see the VMware vCenter Update Manager Administration Guide located at http://pubs.vmware.com/vsphere-50/topic/com.vmware.vsphere.update_manager.doc_50/GUID-F7191592-048B-40C7-A610-CFEE6A790AB0.html.



Release Notes

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Important:

  • Not intended for VMware ESX/ESXi 4.x
  • Does not support HP ProLiant Gen8 Servers

Supported Devices and Features:
VMware ESXi OS version support:

  • VMware ESXi 5.0
  • VMware ESXi 5.0  U1
  • VMware vSphere 5.1

 


Important

  • Not intended for VMware ESX/ESXi 4.x
  • Does not support HP ProLiant Gen8 Servers

Revision History

Version:2.3 (18 Feb 2014)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Fix metadata for custom ISO to successfully install on HP OEM Servers.

Version:2.1 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This is the initial version of this product. It does not support HP ProLiant Gen8 servers.

Note: After an NMI event is received by the server, the VMware ESXi 5.x kernel halts the server with Purple Screen of Death (PSoD) - “Panic requested by one or more 3rd party NMI handlers” to capture a kernel crash dump* on panic. If the HP NMI driver is not installed on VMware ESXi 5.x and a hardware fault event occurs, the NMI event information will not be logged to HP Integrated Management Log (IML) on HP ProLiant systems.
*Refer to VMware documentation at http://www.vmware.com/support/pubs/  for capturing crash dump files on VMware ESXi 5.x.

ja

Version:2.0 (24 Aug 2011)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

This package is supported for installation on the following versions of VMware OS:

  • VMware ESXi 5.0.0
  • VMware ESXi 5.0.0 Update 1

This is the initial version of this product. It does not support HP ProLiant Gen8

Note: After an NMI event is received by the server, the VMware ESXi 5.0 kernel halts the server with Purple Screen of Death (PSoD) - “Panic requested by one or more 3rd party NMI handlers” to capture a kernel crash dump* on panic. If the HP NMI driver is not installed on VMware ESXi 5.0 and a hardware fault event occurs, the NMI event information will not be logged to HP Integrated Management Log (IML) on HP ProLiant systems.
*Refer to VMware documentation at http://www.vmware.com/support/pubs/  for capturing crash dump files on VMware ESXi 5.0.

ja

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.