Printable version

Drivers & software

HP Lights-Out Drivers and Agents for SUSE LINUX Enterprise Server 8 (x86)

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Driver - Lights-Out Management
Version: 7.5.0-169.sles8(13 Apr 2006)
Operating System(s): SUSE Linux Enterprise Server 8
File name: hprsm-7.5.0-169.sles8.i386.rpm (605 KB)
This RPM is used to provide Lights-Out management capabilities for SUSE LINUX Enterprise Server 8 (x86) installed on supported server systems.

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Maintenance release for SmartStart 7.50.

Prerequisites:
hpasm package dependency file
You must install the corresponding hpasm package version before you can install hprsm package. The corresponding hpasm package is available here: HP System Health Application and Insight Management Agents for SUSE LINUX Enterprise Server 8 (x86).


To ensure the integrity of your download, HPE recommends verifying your results with this SHA-256 Checksum value:

8d2b2d1b587d0342f4e3fbd6de4d8ea4d058ac48a6e8b280d9c41a260ebbd955 hprsm-7.5.0-169.sles8.i386.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:
Login as the system administrator (root), download the RPM to a directory on your hard drive and change to that directory.

If a previous version of the Remote Insight Driver, iLO Management Interface Driver, Rack Infrastructure Interface Server, or Insight Management agents have been installed, they must be removed before this package can be installed. To remove the previous version and any packages dependent on it, type the following, in order:

    rpm -e cmanic
    rpm -e hprsm
To install the package, type:
    rpm -ivh hprsm-.rpm
The drivers and agents will be inserted immediately. The NIC Agents must be downloaded and installed separately.

To check whether the package is loaded properly, type:

    /etc/init.d/hprsm status
You should see entries for the following:
    cpqrid - Remote Insight Driver (if a Remote Insight Lights-Out Edition Card is present)
    cpqci - iLO Management Interface Driver (if an iLO Management Card is present)
    cpqriisd - Rack Infrastructure Interface Server (if the server is a BL p-Class server blade)
    cmasm2d - Remote Insight Board Agent
    cmarackd - Rack Agent
If you attempt to install the RPM on an unsupported system, you will get an error message. The driver will not be operational and it is advisable to uninstall the driver at your earliest convenience.

Running the Remote Insight Driver or the iLO Management Interface Driver:
Once installed, the appropriate driver will be automatically loaded every time the server boots.

Additional information and help is available by typing either of the following:

    man cpqrid (Remote Insight Driver)
    man cpqci (iLO Management Interface Driver)

Running the Rack Infrastructure Interface Service

Once installed, the Rack Infrastructure Interface Service will be automatically loaded every time the server boots.

Additional information and help is available by typing:

    man cpqriisd
The Rack Upgrade Utility is packaged with the Rack Infrastructure Interface Service. It allows the user to upgrade the Server Blade and Power Management Module Firmware on ProLiant BL p-Class systems. This firmware is available here: https://www.hpe.com/global/swpublishing/MTX-UNITY-I15620. More information is available by typing:
    man cpqblru
Running the agents:
The agents require an SNMP stack to be available. If SNMP support is not installed on the system, the agents will not load. The UCD-SNMP agent is available on the Linux OS CD. If the agents are not loaded, the Remote Insight Driver, iLO Management Interface Driver, and Rack Infrastructure Interface Service will still function normally.

Previous versions of the drivers and agents
Previous versions of the drivers and agents are available on ftp.compaq.com. To ensure the latest technology and bug fixes, HP recommends the use of this package over previous versions of the driver and agents.

MD5 CHECKSUM:

61ec1b84215943c7c7588eef0af4f051hprsm-.ul10.i386.rpm

Additional information about features, installation, use, and troubleshooting the HP Server Management Drivers and Agents is available in the HOWTO documents available here: http://h18000.www1.hp.com/products/servers/linux/documentation.html.

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Notes:
For the DL740 and DL760 systems, the cmhp driver needs to be recompiled in order to load on a non-default (or errata) Linux kernel. In order to utilize the cmhp functionality on a non-default kernel, you must also install the kernel sources for your compiled kernel. In addition, the development packages required for rebuilding a kernel need to be present. Otherwise, for systems other than the DL740 and DL760, the original hpasm package should install and load correctly on a non-default kernel without the kernel sources or development packages.


Version:7.5.0-169.sles8 (13 Apr 2006)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Maintenance release for SmartStart 7.50.


Version:7.4.0-50.sles8 (9 Sep 2005)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Corrected the following:

  • Assigned dynamic node for Remote Insight Driver (cpqrid)
  • Faulty logic to detect a custom RPM after a rebuild
  • Rack Infrastructure Interface Server (cpqriisd) and Rack Agent (cmarackd) now exit if they are not detected on a rack
Enhancements

Added support for SUSE LINUX Enterprise Server 8 SP4.


Version:7.3.0-58 (5 May 2005)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Compound traps in cmarackd have been modified to display the correct oid for multiple objects.

Enhancements

Added support for new HP ProLiant Hardware.

Included support for Red Hat Enterprise Linux 4 (original support released with hprsm version 7.2.1).


Version:7.2.0b-204 (25 Feb 2005)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Resolved an issue when a ProLiant server configured with the 2MB cache Pentium 4 processors and in the RBSU feature "No Execute Memory Protection was set to "Enabled", some health Agents failed to start.


Version:7.2.0-198 (14 Feb 2005)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new HP ProLiant Hardware.


Version:7.1.1-87 (1 Aug 2004)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Resolved an issue that did not allow the rebuild script to work properly.

Enhancements

Added support for X86_64 bit Linux Operating systems.

  • Intel EM64T

  • AMD64
Added functionality in the hpasm installer not to install and/or load the hprsm driver.

Added support for the 2.6 kernel.


Version:7.1.0-155 (18 Jun 2004)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Resolved a memory allocation issue.

Enhancements

Added enclosure information for the rack agent.

The activate scheme is now the same as hpasm.


Version:7.0.0-19 (17 Dec 2003)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Modified to enhance memory allocation.

Enhancements

Added the display of enclosure information.

Modified the activate scheme to be the same as HPASM.


Version:6.40.0-16 (1 Jul 2003)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new ProLiant server models.


Version:6.30.0-9 (23 Apr 2003)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Enhanced functionality.


Version:6.20.0-13 (3 Feb 2003)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The HP Lights-Out Drivers and Agents contain the following drivers and agents:

  • Remote Insight Driver

  • iLO Management Interface Driver

  • Rack Infrastructure Interface Service

  • Remote Insight Board Agent (formerly in the Server Agents package)

  • Rack Agent (formerly in the Server Agents package)

The drivers can be recompiled on a non-default (or errata) Linux Kernel. If you would like to install or create the RPM for a non-default kernel, you must also install the kernel sources for your compiled kernel. In addition, the development packages required for rebuilding a kernel need to be present.


Type: Driver - Lights-Out Management
Version: 7.5.0-169.sles8(13 Apr 2006)
Operating System(s):
SUSE Linux Enterprise Server 8

Description

This RPM is used to provide Lights-Out management capabilities for SUSE LINUX Enterprise Server 8 (x86) installed on supported server systems.

Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Maintenance release for SmartStart 7.50.

Installation Instructions

Prerequisites:
hpasm package dependency file
You must install the corresponding hpasm package version before you can install hprsm package. The corresponding hpasm package is available here: HP System Health Application and Insight Management Agents for SUSE LINUX Enterprise Server 8 (x86).


To ensure the integrity of your download, HPE recommends verifying your results with this SHA-256 Checksum value:

8d2b2d1b587d0342f4e3fbd6de4d8ea4d058ac48a6e8b280d9c41a260ebbd955 hprsm-7.5.0-169.sles8.i386.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:
Login as the system administrator (root), download the RPM to a directory on your hard drive and change to that directory.

If a previous version of the Remote Insight Driver, iLO Management Interface Driver, Rack Infrastructure Interface Server, or Insight Management agents have been installed, they must be removed before this package can be installed. To remove the previous version and any packages dependent on it, type the following, in order:

    rpm -e cmanic
    rpm -e hprsm
To install the package, type:
    rpm -ivh hprsm-.rpm
The drivers and agents will be inserted immediately. The NIC Agents must be downloaded and installed separately.

To check whether the package is loaded properly, type:

    /etc/init.d/hprsm status
You should see entries for the following:
    cpqrid - Remote Insight Driver (if a Remote Insight Lights-Out Edition Card is present)
    cpqci - iLO Management Interface Driver (if an iLO Management Card is present)
    cpqriisd - Rack Infrastructure Interface Server (if the server is a BL p-Class server blade)
    cmasm2d - Remote Insight Board Agent
    cmarackd - Rack Agent
If you attempt to install the RPM on an unsupported system, you will get an error message. The driver will not be operational and it is advisable to uninstall the driver at your earliest convenience.

Running the Remote Insight Driver or the iLO Management Interface Driver:
Once installed, the appropriate driver will be automatically loaded every time the server boots.

Additional information and help is available by typing either of the following:

    man cpqrid (Remote Insight Driver)
    man cpqci (iLO Management Interface Driver)

Running the Rack Infrastructure Interface Service

Once installed, the Rack Infrastructure Interface Service will be automatically loaded every time the server boots.

Additional information and help is available by typing:

    man cpqriisd
The Rack Upgrade Utility is packaged with the Rack Infrastructure Interface Service. It allows the user to upgrade the Server Blade and Power Management Module Firmware on ProLiant BL p-Class systems. This firmware is available here: https://www.hpe.com/global/swpublishing/MTX-UNITY-I15620. More information is available by typing:
    man cpqblru
Running the agents:
The agents require an SNMP stack to be available. If SNMP support is not installed on the system, the agents will not load. The UCD-SNMP agent is available on the Linux OS CD. If the agents are not loaded, the Remote Insight Driver, iLO Management Interface Driver, and Rack Infrastructure Interface Service will still function normally.

Previous versions of the drivers and agents
Previous versions of the drivers and agents are available on ftp.compaq.com. To ensure the latest technology and bug fixes, HP recommends the use of this package over previous versions of the driver and agents.

MD5 CHECKSUM:

61ec1b84215943c7c7588eef0af4f051hprsm-.ul10.i386.rpm

Additional information about features, installation, use, and troubleshooting the HP Server Management Drivers and Agents is available in the HOWTO documents available here: http://h18000.www1.hp.com/products/servers/linux/documentation.html.

Release Notes

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Notes:
For the DL740 and DL760 systems, the cmhp driver needs to be recompiled in order to load on a non-default (or errata) Linux kernel. In order to utilize the cmhp functionality on a non-default kernel, you must also install the kernel sources for your compiled kernel. In addition, the development packages required for rebuilding a kernel need to be present. Otherwise, for systems other than the DL740 and DL760, the original hpasm package should install and load correctly on a non-default kernel without the kernel sources or development packages.


Revision History

Version:7.5.0-169.sles8 (13 Apr 2006)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Maintenance release for SmartStart 7.50.


Version:7.4.0-50.sles8 (9 Sep 2005)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Corrected the following:

  • Assigned dynamic node for Remote Insight Driver (cpqrid)
  • Faulty logic to detect a custom RPM after a rebuild
  • Rack Infrastructure Interface Server (cpqriisd) and Rack Agent (cmarackd) now exit if they are not detected on a rack
Enhancements

Added support for SUSE LINUX Enterprise Server 8 SP4.


Version:7.3.0-58 (5 May 2005)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Compound traps in cmarackd have been modified to display the correct oid for multiple objects.

Enhancements

Added support for new HP ProLiant Hardware.

Included support for Red Hat Enterprise Linux 4 (original support released with hprsm version 7.2.1).


Version:7.2.0b-204 (25 Feb 2005)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Resolved an issue when a ProLiant server configured with the 2MB cache Pentium 4 processors and in the RBSU feature "No Execute Memory Protection was set to "Enabled", some health Agents failed to start.


Version:7.2.0-198 (14 Feb 2005)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new HP ProLiant Hardware.


Version:7.1.1-87 (1 Aug 2004)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Resolved an issue that did not allow the rebuild script to work properly.

Enhancements

Added support for X86_64 bit Linux Operating systems.

  • Intel EM64T

  • AMD64
Added functionality in the hpasm installer not to install and/or load the hprsm driver.

Added support for the 2.6 kernel.


Version:7.1.0-155 (18 Jun 2004)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Resolved a memory allocation issue.

Enhancements

Added enclosure information for the rack agent.

The activate scheme is now the same as hpasm.


Version:7.0.0-19 (17 Dec 2003)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Modified to enhance memory allocation.

Enhancements

Added the display of enclosure information.

Modified the activate scheme to be the same as HPASM.


Version:6.40.0-16 (1 Jul 2003)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Added support for new ProLiant server models.


Version:6.30.0-9 (23 Apr 2003)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Enhanced functionality.


Version:6.20.0-13 (3 Feb 2003)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The HP Lights-Out Drivers and Agents contain the following drivers and agents:

  • Remote Insight Driver

  • iLO Management Interface Driver

  • Rack Infrastructure Interface Service

  • Remote Insight Board Agent (formerly in the Server Agents package)

  • Rack Agent (formerly in the Server Agents package)

The drivers can be recompiled on a non-default (or errata) Linux Kernel. If you would like to install or create the RPM for a non-default kernel, you must also install the kernel sources for your compiled kernel. In addition, the development packages required for rebuilding a kernel need to be present.