Printable version

Drivers & software

* RECOMMENDED * Agentless Management Service (iLO 5) for Red Hat Enterprise Linux 7 Server

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Software - System Management
Version: 2.1.1(30 Apr 2020)
Operating System(s): Red Hat Enterprise Linux 7 Server
Multi-part download
File name: amsd-2.1.1-1412.2.rhel7.x86_64.compsig (2.0 KB)
File name: amsd-2.1.1-1412.2.rhel7.x86_64.rpm (2.7 MB)
Agentless Management Service (AMSD) provides support for HPE Integrated Lights-Out 5 (HPE iLO 5) Embedded Health and Alerting.

  • Supported added for Red Hat Enterprise Linux Server  7.8

Prerequisites:

  • amsd only supported on HPE Gen10 Servers.

  • amsd provides information to the iLO 5 service providing SNMP support.

  • Requirements:

    • Minimum iLO 5 Firmware Version = 1.1

    • Minimum supported OS Versions = Red Hat Enterprise Linux 7.3 Errata 3.10.0.514.6.1


To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

d45382eabf3a7fc2fb670217031a17b633cf469e98db7b7587ad31dd3f214eaa amsd-2.1.1-1412.2.rhel7.x86_64.compsig
0dba2ab04b9d3f11a8cd2014724693766d692f55710aa145c07af48c867c0e32 amsd-2.1.1-1412.2.rhel7.x86_64.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Login as the system administrator (root), download the RPM to a directory on your hard drive and change to that directory.

  1. To install the package type:
    •       rpm -Uvh amsd-<version>.rpm
  2. To check whether the package is loaded properly type:
    •       systemctl status amsd
    •       systemctl status smad
  3. Additional help is available by typing:
    •       man amsd

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixed the following items:

  • The ahslog service in the HPE Agentless Management Service (iLO 5)(amsd) for Linux may segfault during system startup. While this occurs, the user can see the "Failed to start Active Health Service Logger" message from the systemctl. Review Customer Advisory a00099165en_us for additional details.

  • Adresses the stability of the communication of iLo. Customers may experience the failure of inquiry in some conditions like heavy loading in the iLo, and heavy traffic between the iLo and OS.

Version:2.1.1 (30 Apr 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixed the following items:

  • The ahslog service in the HPE Agentless Management Service (iLO 5)(amsd) for Linux may segfault during system startup. While this occurs, the user can see the "Failed to start Active Health Service Logger" message from the systemctl. Review Customer Advisory a00099165en_us for additional details.

  • Adresses the stability of the communication of iLo. Customers may experience the failure of inquiry in some conditions like heavy loading in the iLo, and heavy traffic between the iLo and OS.

Enhancements

  • Supported added for Red Hat Enterprise Linux Server  7.8

Version:2.1.0 (20 Dec 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Addressed memory leaks
  • Corrected segfaults reported in ahslog
  • Improved synchronization between iLO and amsd
Enhancements

New features enabled with this release:

  • All storage sub-agents are now independent services
  • Added support for new network controllers

Version:1.4.3 (31 Jan 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixed the following items:

  • The sub-agent for the p824i, mr_cpqScsi, is now event driven.  This issue is documented in a Customer Advisory available from:  https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00095313en_us
  • Improved synchronization of amsd and other sub-agents with the iLO when re-establishing communication after an iLO or sub-agent reset.
  • A couple of inifinite loop conditions were fixed in smad and smad_rev.  These would cause 100% CPU usage on the host.
  • The amsd sub-agent fixed a memory leak that occurred when IPV6 was disabled on the Linux kernel command line.

Version:1.4.2 (9 Sep 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • addressed segfaults seen in the ahslog
  • amsd no longer segfaults when a NIC virtual function is created
  • addressed an occasional segfault/system hang/NMI with amsd
  • added support for the HPE Smart Array P824i-p storage controller in MRSA and Storcli
  • Corrected the cpqFcaHostCntlrFirmwareVersion for the HPE Synergy 5830C 32Gb FC Host Bus Adapter
Enhancements

Enhancements:

  • Support for Red Hat Enterprise Linux 7.7

Version:1.4.0 (2 Apr 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • All disks are opened RDONLY to send ioctl()’s to get drive information.
  • Improved SATA channel determination for SATA drives.
  • Corrected errors for lost memory allocations.
Enhancements

Stability improvements when running Red Hat Enterprise Linux 7


Version:1.3.2 (27 Nov 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Traps for Fibre Channel and Events are now correctly logged to the iLO IML
  • ahslog does not segfault when logging storage volume utilization

Version:1.3.1 (27 Sep 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Fix memory leaks
  • Use /etc/os-release as authoritative when present
  • Handle VLAN interfaces before regular interfaces
  • Fix some instances where ‘signed char’ should have been ‘unsigned char’
  • Changed syslog() level of debug messages in smad from LOG_ERR to LOG_INFORM

 


Version:1.3.0 (26 Jun 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Fix libpci dependencies for amsd installation on Red Hat Enterprise Linux 7.2
  • Better LSB conformance for startup/shutdown scripts
  • Improve support for multiple SNMP AgentX sub-agents
  • Improved detection of LogMapSpeedMbps for drivers that do not support NIC speeds in sysfs
  • Improved support for HPE Smart Array P824i-p MegaRAID SAS controller including support for logical drives
  • Added checks to ahslog to prevent it from sending too large requests to the iLO
  • Fixed incorrect cpqNicIfLogMapAdapterOKCount for simple NIC logical devices
Enhancements

New features of amsd version 1.3.0:

  • iSCSI support in the cpqiScsi MIB handler
  • Add volume usage to ahslog
  • Add NIC link monitoring to ahslog

Version:1.2.0 (5 Feb 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Added support for the following new hardware options:
    • HPE XL1x0r Ethernet 10Gb 2-port 568FLR-MMT Adapter
    • HPE SGI Performance Dual Plane CX5 InfiniBand EDR with 2x1-port HCA Mezzanine Card (Ethernet Only)
    • HPE Ethernet 10Gb 2-port 522FLR-T Converged Network Adapter
    • HPE Smart Array P824i-p Controller
  • amsd no longer stops when PCI and NIC Data Structures dynamically appear and disappear
  • Application Time Stamps are correctly logged in AHS
  • POLLERR and POLLHUP handling support to smad
  • Slot determination for add-in PCIe cards which sit behind an on-card PCIe bridge device
  • Save status on a change and a trap is now sent if the status is not FC_HBA_STATUS_OTHER in cpqFca
  • AHS logging issues with RHEL 7.4
  • Fixed endless loop when reading a bad PCI value
  • New fan speed thermal values added for iLO5

Version:1.1.0 (25 Sep 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Improved handling of IPV6 addresses

  • Updated for RHEL 7.4 support

  • Improved handling of SATA drive temperatures


Version:1.0.0 (12 Jul 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Initial release to support Gen10 Servers

Type: Software - System Management
Version: 2.1.1(30 Apr 2020)
Operating System(s):
Red Hat Enterprise Linux 7 Server

Description

Agentless Management Service (AMSD) provides support for HPE Integrated Lights-Out 5 (HPE iLO 5) Embedded Health and Alerting.

Enhancements

  • Supported added for Red Hat Enterprise Linux Server  7.8

Installation Instructions

Prerequisites:

  • amsd only supported on HPE Gen10 Servers.

  • amsd provides information to the iLO 5 service providing SNMP support.

  • Requirements:

    • Minimum iLO 5 Firmware Version = 1.1

    • Minimum supported OS Versions = Red Hat Enterprise Linux 7.3 Errata 3.10.0.514.6.1


To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

d45382eabf3a7fc2fb670217031a17b633cf469e98db7b7587ad31dd3f214eaa amsd-2.1.1-1412.2.rhel7.x86_64.compsig
0dba2ab04b9d3f11a8cd2014724693766d692f55710aa145c07af48c867c0e32 amsd-2.1.1-1412.2.rhel7.x86_64.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Login as the system administrator (root), download the RPM to a directory on your hard drive and change to that directory.

  1. To install the package type:
    •       rpm -Uvh amsd-<version>.rpm
  2. To check whether the package is loaded properly type:
    •       systemctl status amsd
    •       systemctl status smad
  3. Additional help is available by typing:
    •       man amsd

Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixed the following items:

  • The ahslog service in the HPE Agentless Management Service (iLO 5)(amsd) for Linux may segfault during system startup. While this occurs, the user can see the "Failed to start Active Health Service Logger" message from the systemctl. Review Customer Advisory a00099165en_us for additional details.

  • Adresses the stability of the communication of iLo. Customers may experience the failure of inquiry in some conditions like heavy loading in the iLo, and heavy traffic between the iLo and OS.

Revision History

Version:2.1.1 (30 Apr 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixed the following items:

  • The ahslog service in the HPE Agentless Management Service (iLO 5)(amsd) for Linux may segfault during system startup. While this occurs, the user can see the "Failed to start Active Health Service Logger" message from the systemctl. Review Customer Advisory a00099165en_us for additional details.

  • Adresses the stability of the communication of iLo. Customers may experience the failure of inquiry in some conditions like heavy loading in the iLo, and heavy traffic between the iLo and OS.

Enhancements

  • Supported added for Red Hat Enterprise Linux Server  7.8

Version:2.1.0 (20 Dec 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Addressed memory leaks
  • Corrected segfaults reported in ahslog
  • Improved synchronization between iLO and amsd
Enhancements

New features enabled with this release:

  • All storage sub-agents are now independent services
  • Added support for new network controllers

Version:1.4.3 (31 Jan 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixed the following items:

  • The sub-agent for the p824i, mr_cpqScsi, is now event driven.  This issue is documented in a Customer Advisory available from:  https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00095313en_us
  • Improved synchronization of amsd and other sub-agents with the iLO when re-establishing communication after an iLO or sub-agent reset.
  • A couple of inifinite loop conditions were fixed in smad and smad_rev.  These would cause 100% CPU usage on the host.
  • The amsd sub-agent fixed a memory leak that occurred when IPV6 was disabled on the Linux kernel command line.

Version:1.4.2 (9 Sep 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • addressed segfaults seen in the ahslog
  • amsd no longer segfaults when a NIC virtual function is created
  • addressed an occasional segfault/system hang/NMI with amsd
  • added support for the HPE Smart Array P824i-p storage controller in MRSA and Storcli
  • Corrected the cpqFcaHostCntlrFirmwareVersion for the HPE Synergy 5830C 32Gb FC Host Bus Adapter
Enhancements

Enhancements:

  • Support for Red Hat Enterprise Linux 7.7

Version:1.4.0 (2 Apr 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • All disks are opened RDONLY to send ioctl()’s to get drive information.
  • Improved SATA channel determination for SATA drives.
  • Corrected errors for lost memory allocations.
Enhancements

Stability improvements when running Red Hat Enterprise Linux 7


Version:1.3.2 (27 Nov 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Traps for Fibre Channel and Events are now correctly logged to the iLO IML
  • ahslog does not segfault when logging storage volume utilization

Version:1.3.1 (27 Sep 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Fix memory leaks
  • Use /etc/os-release as authoritative when present
  • Handle VLAN interfaces before regular interfaces
  • Fix some instances where ‘signed char’ should have been ‘unsigned char’
  • Changed syslog() level of debug messages in smad from LOG_ERR to LOG_INFORM

 


Version:1.3.0 (26 Jun 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Fix libpci dependencies for amsd installation on Red Hat Enterprise Linux 7.2
  • Better LSB conformance for startup/shutdown scripts
  • Improve support for multiple SNMP AgentX sub-agents
  • Improved detection of LogMapSpeedMbps for drivers that do not support NIC speeds in sysfs
  • Improved support for HPE Smart Array P824i-p MegaRAID SAS controller including support for logical drives
  • Added checks to ahslog to prevent it from sending too large requests to the iLO
  • Fixed incorrect cpqNicIfLogMapAdapterOKCount for simple NIC logical devices
Enhancements

New features of amsd version 1.3.0:

  • iSCSI support in the cpqiScsi MIB handler
  • Add volume usage to ahslog
  • Add NIC link monitoring to ahslog

Version:1.2.0 (5 Feb 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Added support for the following new hardware options:
    • HPE XL1x0r Ethernet 10Gb 2-port 568FLR-MMT Adapter
    • HPE SGI Performance Dual Plane CX5 InfiniBand EDR with 2x1-port HCA Mezzanine Card (Ethernet Only)
    • HPE Ethernet 10Gb 2-port 522FLR-T Converged Network Adapter
    • HPE Smart Array P824i-p Controller
  • amsd no longer stops when PCI and NIC Data Structures dynamically appear and disappear
  • Application Time Stamps are correctly logged in AHS
  • POLLERR and POLLHUP handling support to smad
  • Slot determination for add-in PCIe cards which sit behind an on-card PCIe bridge device
  • Save status on a change and a trap is now sent if the status is not FC_HBA_STATUS_OTHER in cpqFca
  • AHS logging issues with RHEL 7.4
  • Fixed endless loop when reading a bad PCI value
  • New fan speed thermal values added for iLO5

Version:1.1.0 (25 Sep 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Fixed the following items:

  • Improved handling of IPV6 addresses

  • Updated for RHEL 7.4 support

  • Improved handling of SATA drive temperatures


Version:1.0.0 (12 Jul 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Initial release to support Gen10 Servers

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.