Printable version

Drivers & software

HP Broadcom Online Firmware Upgrade Utility for Linux x86_64

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Firmware - Network
Version: 2.10.15(B)(2 May 2014)
Operating System(s): Red Hat Enterprise Linux 5 Server (x86-64)
Red Hat Enterprise Linux 6 Server (x86-64)
SUSE Linux Enterprise Server 11 (AMD64/EM64T)
Multi-part download
File name: CP023219.scexe (4.3 MB)
File name: CP023219.txt (6.0 KB)
This package contains the utilities and binaries for upgrading HP ProLiant Broadcom Gigabit Ethernet NICs Boot code, PXE, IPMI, UMP, NCSI, CLP, iSCSI, FCoE and CCM code running under Linux x86_64 platform.

Prerequisites:
This package requires the appropriate driver for your adapter be installed before firmware can be updated.


To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

d42bfd7852f601f1316e60bf57cbc5e3a0c515dcfd06afb307ca465f16ed7ef1 CP023219.scexe
b838d80a1301e361db227b27861a5d3c4bf6b92d8fb91ebad3a5a3e7fe5b9cab CP023219.txt

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Network connectivity may stop during the upgrade process and may need to be restarted after completion.


End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Notes:
This software package contains the following firmware versions:

NIC Boot Code Version PXE Version CLP Version iSCSI Version IPMI Version UMP Version NCSI Version FCoE Version UEFI Version CCM Version L2 Version
HP NC105i PCIe Gigabit Server Adapter 3.09 n/a n/a n/a 8.02 n/a n/a n/a n/a n/a n/a
HP NC107i PCIe Gigabit Server Adapter 3.35 n/a n/a n/a 8.07 n/a n/a n/a n/a n/a n/a
HP NC325m PCIe Quad Port Gigabit Server Adapter
HP NC326m PCIe Dual Port Adapter
3.28 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC326i PCIe Dual Port Gigabit Server Adapter (1678) 3.28 n/a n/a n/a n/a 1.23 n/a n/a n/a n/a n/a
HP NC326i PCIe Dual Port Gigabit Server Adapter (1679) 3.29 n/a n/a n/a n/a n/a n/a n/a n/a n/a n/a
HP Ethernet 1Gb 2-port 330i Adapter 1.59 16.4.1 n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 4-port 331FLR Adapter 1.37 16.4.1 n/a n/a n/a n/a 1.2.37 n/a 16.4.7 7.8.21 n/a
HP Ethernet 1Gb 4-port 331i Adapter 1.37 16.4.1 n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 4-port 331i-SPI Adapter 1.37

16.4.1

n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 4-port 331T Adapter 1.37 16.4.1 n/a n/a n/a n/a 1.2.37 n/a 16.4.7 7.8.21 n/a
HP Ethernet 1Gb 2-port 332i Adapter 1.33 16.4.1 n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 2-port 332T Adapter 1.33 16.4.1 n/a n/a n/a n/a 1.2.37 n/a 16.4.7 7.8.21 n/a
HP NC370i Multifunction Gigabit Server Adapter 1.9.6 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC371i Multifunction Gigabit Server Adapter 1.9.6 n/a n/a n/a n/a 1.1.8 n/a n/a n/a n/a n/a
HP NC373i Multifunction Gigabit Server Adapter (16AC) 4.4.1 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC373i Multifunction Gigabit Server Adapter (164C) 1.9.6 n/a n/a n/a n/a 1.1.8 n/a n/a n/a n/a n/a
HP NC373F PCIe Multifunction Gigabit Server Adapter
HP NC373T PCIe Multifunction Gigabit Server Adapter
1.9.6 2.8.5 n/a n/a n/a n/a n/a n/a n/a n/a n/a
HP NC373m Multifunction Gigabit Server Adapter 4.4.1 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC380T PCIe DP Multifunction Gigabit Server Adapter 1.9.6 2.8.5 n/a n/a n/a n/a n/a n/a n/a n/a n/a
HP NC382i DP Multifunction Gigabit Server Adapter (1639) 5.2.3 n/a n/a 7.4.2 n/a n/a 2.0.12 n/a n/a n/a n/a
HP NC382i DP Multifunction Gigabit Server Adapter (163A) 5.2.3 n/a n/a 3.0.6 n/a n/a 2.0.6 n/a n/a n/a n/a
HP NC382m DP 1GbE Multifunction BL-c Adapter 5.2.3 4.6.10 n/a 3.1.7 n/a n/a n/a n/a n/a n/a n/a
HP NC382T PCIe DP Multifunction Gigabit Server Adapter 5.2.3 5.2.4 n/a 4.2.10 n/a n/a n/a n/a n/a n/a n/a
HP Flex-10 10Gb 2-port 530FLB Adapter
HP Ethernet 10Gb 2-port 530FLR-SFP+ Adapter
HP Flex-10 10Gb 2-port 530M Adapter
HP Ethernet 10Gb 2-port 530SFP+ Adapter
HP Ethernet 10Gb 2-port 530T Adapter
7.8.79 7.8.78 n/a n/a n/a n/a n/a n/a 7.8.84 7.8.21 7.8.5
HP NC532i Dual Port 10GbE Multifunction BL-c Adapter (3654) 6.2.27 n/a n/a 3.1.5 n/a n/a n/a n/a n/a n/a n/a
HP NC532i Dual Port 10GbE Multifunction BL-c Adapter (7058) 6.2.27 n/a n/a 4.2.10 n/a n/a n/a n/a n/a n/a n/a
HP NC532m Dual Port 10GbE Multifunction BL-c Adapter 6.2.27 7.0.53 n/a 7.4.2 n/a n/a n/a n/a n/a n/a n/a
HP Ethernet 10Gb 2-port 533FLR-T Adapter 7.8.79 7.8.78 n/a n/a n/a n/a n/a n/a 7.8.84 7.8.21 7.8.5
HP FlexFabric 10Gb 2-port 534FLB Adapter
HP FlexFabric 10Gb 2-port 534FLR-SFP+ Adapter
HP FlexFabric 10Gb 2-port 534M Adapter
HP StoreFabric CN1100R Dual Port Converged Network Adapter
7.8.79 7.8.78 n/a 7.8.78 n/a n/a n/a 7.8.76 7.8.84 7.8.21 7.8.5

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


CCM:

  • This component addresses an issue where certain adapters may become non-functional when they are updated with the Comprehensive Configuration Management (CCM) firmware using this firmware update utility. This component now prevents landing of the CCM firmware on adapters that do not support CCM.

FCoE/iSCSI:

  • A system hang seen during the early phase of storage ROM initialization on some platforms has been addressed.
  • The firmware has been updated to use indirect accesses to address a boot failure seen when large Base Address Register (BAR) is enabled in the system BIOS.

Bootcode: 

  • This image addresses an issue where a 5719 chipset device reports “no firmware running” when an inbox driver is used.

NCSI:

  • This image addresses an issue where a Keyboard, Video and Mouse (KVM) session times out when a power cycle loop is performed for a long duration on a system with a Broadcom 5717/5719 chipset device.
Version:2.26.1 (17 Jul 2020)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product corrects the wrong spare number while it was originally not the same as what was written on the label of package.


Version:2.25.1 (9 Mar 2020)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where Legacy Boot Protocol(System Utilities -> System Configuration -> NIC HII menu -> BA Configuration Menu) changes from None to PXE.
This product addresses an issue where it would be forced to exit System Utilities when select Port 2 & Port 3(System Utilities -> System Configuration -> NIC HII menu).


Version:2.24.2 (20 Dec 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product corrects an issue where random PXE boot installation failures occur when booting in UEFI mode.

Enhancements

This product no longer supports the following ProLiant Blade servers:

  •   HPE ProLiant BL660c Gen9 Server   
  •   HPE ProLiant BL460c Gen10 Server   
  •   HPE ProLiant BL460c Gen9 Server  
  •   HPE Synergy 680 Gen9 Compute Module   
  •   HPE Synergy 660 Gen10 Compute Module   
  •   HPE Synergy 660 Gen9 Compute Module   
  •   HPE Synergy 620 Gen9 Compute Module   
  •   HPE Synergy 480 Gen10 Compute Module   
  •   HPE Synergy 480 Gen9 Compute Module

Version:2.23.10 (2 Apr 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product corrects an issue where the component fails to update adapter firmware when running on ESXi 6.7.  
This product corrects an issue where an incorrect device (Network Controller) name is displayed in the RBSU.


Version:2.22.3 (27 Nov 2018)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports Red Hat Enterprise Linux 6 Update 10.


Version:2.21.58 (27 Sep 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


N/A

Enhancements

This product now supports SUSE Linux Enterprise Server 15.


Version:2.21.3 (26 Jun 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where the NIC Serial Number for the HPE Ethernet 1Gb 4-port 331FLR Adapter is not displayed in AHS.

The firmware in this product  addresses an issue where the "Reboot Required" icon is not highlighted after a NIC firmware update (via System Utilities->Embedded Application->Firmware Update) completes.


Version:2.20.7 (5 Feb 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • This product corrects an issue where an adapter’s configuration menu doesn't prompt for reboot after changes are made that require a reboot.
  • This firmware now correctly displays a progress bar information when updating the firmware via the ‘Firmware Update’ feature (under ‘System Utilities->Embedded Applications’). 

Version:2.19.6 (25 Sep 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where negative temperatures on the adapter are incorrectly displayed in Integrated Lights Out (iLO).
This product addresses an issue where an incorrect firmware image is landed on an adapter.
This product addresses an issue where an adapter's configuration menu doesn't correctly prompt for reboot after changes are made that require a reboot.

Enhancements

This product now supports Red Hat Enterprise Linux 7 Update 4.
This product now supports SUSE Linux Enterprise Server 12 SP3.


Version:2.18.15 (12 Jul 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where an adapter disappears when the system configuration settings are restored to defaults.

This product addresses an issue where iLO displays erroneous 11020 SNMP Trap messages.  The false trap messages register in iLO every 15 to 60 minutes.


Version:2.17.6 (26 Sep 2016)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where the server makes high speed fan noise after the PXE firmware on the adapter is updated to version 17.0.2.

This product addresses an issue where an incorrect firmware version is reported when updating firmware on the HP Ethernet 1Gb 2-port 332i Adapter.

This product addresses an issue where older smart components report an incorrect Bootcode version after the firmware on the adapter was originally updated using the component version 2.16.4 or later.

This product addresses an issue where an error code 7 is reported when updating firmware on the HP Ethernet 1Gb 4-port 331i-SPI Adapter.


Version:2.16.6 (1 Apr 2016)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an Uncorrectable Machine Check Exception error reported in the Integrated Management Log in the iLO.

This product addresses an issue where the IPv6 PXE boot entry may not show up in the 'One-Time Boot Menu' under the 'System Utilities' (F9 during POST).

This product addresses an issue where the existing firmware present on the adapter is incorrectly reported.

This product addresses an issue where the reported bootcode version is incorrect after the combo image is landed on the adapter.


Version:2.16.4(B) (1 Oct 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where Gen8 systems with a HP Ethernet 1Gb 4-port 331i Adapter LOM can no longer PXE boot after a firmware update.


Version:2.16.4 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports the HP Ethernet 1 Gb 2-port 332i Adapter (22E8).

This product now supports Red Hat Enterprise Linux 6 Update 7.

This product now supports SUSE LINUX Enterprise Server 11 SP4.


Version:2.15.10 (15 Jun 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where the sideband traffic on the second port stops after a system warm reboot when both ports are enabled for transmit and the first port is linked down.

This product addresses an issue where the firmware update on a device fails when PXE is up to date but the UEFI driver needs an update.

Enhancements

This product now supports only Broadcom NX1 devices. NX2 devices are now supported by “HP QLogic NX2 Online Firmware Upgrade Utility for Linux x86_64.”

This product now supports Red Hat Enterprise Linux 7 Update 1.


Version:2.14.17 (30 Mar 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports Red Hat Enterprise Linux 6 Update 6.

This product now supports SUSE LINUX Enterprise Server 12.

This product contains updated NCSI firmware (v1.3.5) that increases the number of multicast MAC address filters that can be supported from 2 to 8.


Version:2.13.5 (9 Sep 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The NX2 Unified Extensible Firmware Interface (UEFI) driver in this product no longer hangs when an invalid bandwidth value is entered in the NIC configuration menu under "System Configuration" on Gen 9 platforms.

The NX2 UEFI driver in this product no longer displays an unnecessary pop-up message regarding saving the settings when exiting the NIC configuration menu on Gen 9 platforms when no settings are changed.

The NX2 UEFI driver in this product no longer displays an unnecessary pop-up warning message when the user enters the NIC configuration menu under "System Configuration" on Gen 9 platforms with the HP Ethernet 10Gb 2-port 530T Adapter.

The bootcode in this product for 578xx devices now correctly reports thermal data.

This product addresses an issue where iSCSI boot fails when VLAN ID is enabled via Virtual Connect Manager's "iSCSI Boot Configuration" parameters.

This product addresses an issue where iSCSI boot fails when an adapter is configured to use the Dynamic Host Configuration Protocol (DHCP) Vendor ID via Virtual Connect Manager's "iSCSI Boot Configuration" parameters.

The updated iSCSI firmware addresses an issue where the iSCSI interface fails to acquire a Dynamic Host Configuration Protocol (DHCP) IP address from a server with a host name and root path longer than 32 characters.


Version:2.12.22 (9 Sep 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component contains updated boot code for Broadcom 5719 chipset based adapters to correct an issue which results in the device disappearing from the list of PCIe devices after system boot.

Enhancements

This product now supports the following network adapters:

  • HP Ethernet 1Gb 2-port 330i Adapter (22BD)
  • HP Ethernet 1Gb 4-port 331i Adapter (22BE)
  • HP FlexFabric 10Gb 2-port 536FLB Adapter

Version:2.11.20 (26 Apr 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports the following network adapters:

  • HP FlexFabric 20Gb 2-port 630FLB Adapter
  • HP FlexFabric 20Gb 2-port 630M Adapter

Version:2.10.15(B) (2 May 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


CCM:

  • This component addresses an issue where certain adapters may become non-functional when they are updated with the Comprehensive Configuration Management (CCM) firmware using this firmware update utility. This component now prevents landing of the CCM firmware on adapters that do not support CCM.

FCoE/iSCSI:

  • A system hang seen during the early phase of storage ROM initialization on some platforms has been addressed.
  • The firmware has been updated to use indirect accesses to address a boot failure seen when large Base Address Register (BAR) is enabled in the system BIOS.

Bootcode: 

  • This image addresses an issue where a 5719 chipset device reports “no firmware running” when an inbox driver is used.

NCSI:

  • This image addresses an issue where a Keyboard, Video and Mouse (KVM) session times out when a power cycle loop is performed for a long duration on a system with a Broadcom 5717/5719 chipset device.

Version:2.9.26 (10 Sep 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This FCoE firmware version addresses an FCoE ROM boot failure to establish connection with FCoE fabric in a certain configuration seen with version 7.8.17.

This FCoE firmware prevents a slowdown in boot time (~8 secs) and a VLAN discovery failure caused by the discovery logic of the FCoE ROM.

This iSCSI firmware addresses an iSCSI ROM Challenge Handshake Authentication Protocol (CHAP) failure seen with version 7.8.24.


Version:2.9.24 (10 Sep 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component resolves an issue where the OS may fail to boot or hang during iSCSI boot when using multipath.

This component resolves an issue where the iSCSI Boot Firmware Table was not initialized correctly for the secondary interface if a cable was not attached.


Version:2.9.21 (10 Sep 2013)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports the following network adapters:

  • HP Ethernet 10Gb 2-port 533FLR-T Adapter
  • HP FlexFabric 10Gb 2-port 534FLB Adapter
  • HP FlexFabric 10Gb 2-port 534FLR-SFP+ Adapter
  • HP FlexFabric 10Gb 2-port 534M Adapter
  • HP StoreFabric CN1100R Dual Port Converged Network Adapter

Version:2.7.20(C) (12 Apr 2013)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.


This component contains updated firmware for the following adapters:

  • HP Ethernet 1Gb 2-port 330i Adapter
  • HP Ethernet 1Gb 4-port 331FLR Adapter
  • HP Ethernet 1Gb 4-port 331i Adapter
  • HP Ethernet 1Gb 4-port 331i-SPI Adapter
  • HP Ethernet 1Gb 4-port 331T Adapter
  • HP Ethernet 1Gb 2-port 332i Adapter
  • HP Ethernet 1Gb 2-port 332T Adapter

This firmware corrects a potential NMI which can occur under heavy network stress.


This component contains an updated Managed Boot Agent (MBA) for the HP NC532m Dual Port 10GbE Multifunction BL-c Adapter which addresses an issue where the Media Access Control (MAC) address for port 1 incorrectly shows all zeroes.

Version:2.7.20 (19 Feb 2013)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component now supports the HP Ethernet 10Gb 2-port 530T Adapter.


Version:2.6.14 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports the HP Ethernet 1Gb 4-port 331i-SPI Adapter.

This package now supports Red Hat Enterprise Linux 6 Update 3.


Version:2.5.14 (4 Jun 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software package now supports the following network adapters:

  • HP Ethernet 1Gb 2-port 330i Adapter
  • HP Ethernet 1Gb 2-port 332T Adapter
  • HP Ethernet 10Gb 2-port 530SFP+ Adapter

This package now supports SUSE LINUX Enterprise Server 11 SP2.

Version:2.4.25 (B) (12 Mar 2012)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Updated PXE/MBA firmware for the 530FLB, 530M, and 530FLR to address a potential hang during PXE boot on a heavily loaded network.


Version:2.4.25 (27 Mar 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports firmware updates for the following network adapters:

  • HP Ethernet 1Gb 4-port 331FLR Adapter
  • HP Ethernet 1Gb 4-port 331i Adapter
  • HP Ethernet 1Gb 4-port 331T Adapter
  • HP Flex-10 10Gb 2-port 530FLB Adapter
  • HP Ethernet 10Gb 2-port 530FLR-SFP+ Adapter
  • HP Flex-10 10Gb 2-port 530M Adapter

Version:2.3.0 (24 Feb 2011)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The correct informational messages are now displayed when discovering the NIC firmware versions installed on the system.

Enhancements

This software now supports Red Hat Enterprise Linux 6.


Version:2.2.9 (15 Dec 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool no longer fails when flashing the UMP on NC326i adapters.


Version:2.2.8 (26 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool now correctly detects network devices when executed by HPSUM.


Version:2.2.7 (6 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool now loads/unloads the bnx2x driver, which fixes an upgrade issue.

Enhancements

This component contains updated bootcode for the NC382i/T/m.

This component includes new management firmware the NC326i.

This tool can now downgrade the firmware in silent mode when the "force" switch is used.


Version:2.2.6 (B) (28 May 2010)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


This component no longer triggers an event that causes the DL100 series servers to hang on POST.


Version:2.2.6 (5 Feb 2010)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes:
Update Requirements:
      Recommended: HP recommends that users should update to this firmware version at their earliest convenience.

Problems Fixed:
     • This component contains updated NCSI firmware for the NC382i to resolve an issue where VLAN tagged packets were being dropped when run with latest OEM router. This component also contains updated bootcode for the NC382i, NC382m, and NC382T. This bootcode is require for the new NCSI code.
     • This component contains updated bootcode for the NC532m and NC532i. This firmware will resolve an issue where some NC532 devices may not enumerate correctly.


Version:2.2.4 (10 Nov 2009)
Fixes

This component contains updated IPMI firmware for the NC107i network adapter to resolve OS installation issues using PXE.

This component contains updated firmware that resolves an issue on the NC532m where PXE boot would fail when connected to certain switches using the priority field in the VLAN ID.


Version:2.2.3 (19 Aug 2009)
Enhancements
This component contains updated bootcode for the NC532i and NC532m network adapters. The updated bootcode includes Dynamic Control Channel (DCC) for Virtual Connect.

Version:2.2.2 (31 Jul 2009)
Fixes
This component contains updated bootcode for the NC382T network adapter to resolve a boot issue on the DL785 server.

Version:2.2.1 (B) (16 Sep 2009)
Fixes
This component resolves an issue with updating firmware when using HPSUM.

Version:2.2.1 (28 May 2009)
Fixes
This component contains updated firmware images for the NC325m, NC326m and NC373m network adapters. The updated firmware images resolve an issue with enabling PXE.

Version:2.1.8 (28 Apr 2009)
Fixes
This software no longer produces a segmentation fault while executing in HPSUM mode.

Version:2.1.7 (27 Mar 2009)
Enhancements

This software now supports firmware updates for the following network adapters:

  • HP NC105i Integrated PCI Express Gigabit Server Adapter
  • HP NC107i Integrated PCI Express Gigabit Server Adapter
  • HP NC382i Integrated Dual Port Multifunction Gigabit Server Adapter
  • HP NC382m Dual Port 1GbE Multifunction BL-c Adapter
  • HP NC382T PCI Express Dual Port Gigabit Server Adapter
  • HP NC532i Dual Port 10GbE Multifunction BL-c Adapter
  • HP NC532m Dual Port 10GbE Multifunction BL-c Adapter

Version:2.1.6 (7 Oct 2008)
Enhancements

This software now enables 2.5Gb support on c-class LOMs and mezzanine network adapters.


Version:2.1.4 (7 Aug 2008)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component contains the latest available firmware for the supported NICs.


Version:2.1.2 (29 Apr 2008)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software contains the latest available firmware for the supported NICs.

This software now has the latest CLP and iSCSI images so the user has the capibility to perform Linux or Windows 2003 iSCSI installs.


Version:2.1.0 (31 Mar 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This utility no longer causes HPSUM to inaccurately write "Bad device status" in the OPMAN trace log so the user should not expect to see this message during a successful upgrade.


Version:2.0.9 (3 Oct 2007)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated the installation of the option ROM on C-Class adapters so the option ROM executes correctly after being updated.

Updated UMP firmware for HP NC373i Multifunction Adapters. With this firmware, UMP traffic no longer ceases when system is powered up from Vaux, eliminating the need to use the dedicated iLO port.


Version:2.0.7 (31 Aug 2007)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software provides the latest available firmware for the supported NICs.


Version:2.0.4 (13 Jul 2007)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Updated UMP firmware for HP NC371i Multifunction Adapters. With this firmware, UMP traffic no longer ceases when system is powered up from Vaux, eliminating the need to use the dedicated iLO port.


Type: Firmware - Network
Version: 2.10.15(B)(2 May 2014)
Operating System(s):
Red Hat Enterprise Linux 5 Server (x86-64)
Red Hat Enterprise Linux 6 Server (x86-64)
SUSE Linux Enterprise Server 11 (AMD64/EM64T)

Description

This package contains the utilities and binaries for upgrading HP ProLiant Broadcom Gigabit Ethernet NICs Boot code, PXE, IPMI, UMP, NCSI, CLP, iSCSI, FCoE and CCM code running under Linux x86_64 platform.

Installation Instructions

Prerequisites:
This package requires the appropriate driver for your adapter be installed before firmware can be updated.


To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

d42bfd7852f601f1316e60bf57cbc5e3a0c515dcfd06afb307ca465f16ed7ef1 CP023219.scexe
b838d80a1301e361db227b27861a5d3c4bf6b92d8fb91ebad3a5a3e7fe5b9cab CP023219.txt

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Network connectivity may stop during the upgrade process and may need to be restarted after completion.


Release Notes

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Notes:
This software package contains the following firmware versions:

NIC Boot Code Version PXE Version CLP Version iSCSI Version IPMI Version UMP Version NCSI Version FCoE Version UEFI Version CCM Version L2 Version
HP NC105i PCIe Gigabit Server Adapter 3.09 n/a n/a n/a 8.02 n/a n/a n/a n/a n/a n/a
HP NC107i PCIe Gigabit Server Adapter 3.35 n/a n/a n/a 8.07 n/a n/a n/a n/a n/a n/a
HP NC325m PCIe Quad Port Gigabit Server Adapter
HP NC326m PCIe Dual Port Adapter
3.28 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC326i PCIe Dual Port Gigabit Server Adapter (1678) 3.28 n/a n/a n/a n/a 1.23 n/a n/a n/a n/a n/a
HP NC326i PCIe Dual Port Gigabit Server Adapter (1679) 3.29 n/a n/a n/a n/a n/a n/a n/a n/a n/a n/a
HP Ethernet 1Gb 2-port 330i Adapter 1.59 16.4.1 n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 4-port 331FLR Adapter 1.37 16.4.1 n/a n/a n/a n/a 1.2.37 n/a 16.4.7 7.8.21 n/a
HP Ethernet 1Gb 4-port 331i Adapter 1.37 16.4.1 n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 4-port 331i-SPI Adapter 1.37

16.4.1

n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 4-port 331T Adapter 1.37 16.4.1 n/a n/a n/a n/a 1.2.37 n/a 16.4.7 7.8.21 n/a
HP Ethernet 1Gb 2-port 332i Adapter 1.33 16.4.1 n/a n/a n/a n/a 1.2.37 n/a n/a 7.8.21 n/a
HP Ethernet 1Gb 2-port 332T Adapter 1.33 16.4.1 n/a n/a n/a n/a 1.2.37 n/a 16.4.7 7.8.21 n/a
HP NC370i Multifunction Gigabit Server Adapter 1.9.6 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC371i Multifunction Gigabit Server Adapter 1.9.6 n/a n/a n/a n/a 1.1.8 n/a n/a n/a n/a n/a
HP NC373i Multifunction Gigabit Server Adapter (16AC) 4.4.1 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC373i Multifunction Gigabit Server Adapter (164C) 1.9.6 n/a n/a n/a n/a 1.1.8 n/a n/a n/a n/a n/a
HP NC373F PCIe Multifunction Gigabit Server Adapter
HP NC373T PCIe Multifunction Gigabit Server Adapter
1.9.6 2.8.5 n/a n/a n/a n/a n/a n/a n/a n/a n/a
HP NC373m Multifunction Gigabit Server Adapter 4.4.1 n/a 1.3.6 n/a n/a n/a n/a n/a n/a n/a n/a
HP NC380T PCIe DP Multifunction Gigabit Server Adapter 1.9.6 2.8.5 n/a n/a n/a n/a n/a n/a n/a n/a n/a
HP NC382i DP Multifunction Gigabit Server Adapter (1639) 5.2.3 n/a n/a 7.4.2 n/a n/a 2.0.12 n/a n/a n/a n/a
HP NC382i DP Multifunction Gigabit Server Adapter (163A) 5.2.3 n/a n/a 3.0.6 n/a n/a 2.0.6 n/a n/a n/a n/a
HP NC382m DP 1GbE Multifunction BL-c Adapter 5.2.3 4.6.10 n/a 3.1.7 n/a n/a n/a n/a n/a n/a n/a
HP NC382T PCIe DP Multifunction Gigabit Server Adapter 5.2.3 5.2.4 n/a 4.2.10 n/a n/a n/a n/a n/a n/a n/a
HP Flex-10 10Gb 2-port 530FLB Adapter
HP Ethernet 10Gb 2-port 530FLR-SFP+ Adapter
HP Flex-10 10Gb 2-port 530M Adapter
HP Ethernet 10Gb 2-port 530SFP+ Adapter
HP Ethernet 10Gb 2-port 530T Adapter
7.8.79 7.8.78 n/a n/a n/a n/a n/a n/a 7.8.84 7.8.21 7.8.5
HP NC532i Dual Port 10GbE Multifunction BL-c Adapter (3654) 6.2.27 n/a n/a 3.1.5 n/a n/a n/a n/a n/a n/a n/a
HP NC532i Dual Port 10GbE Multifunction BL-c Adapter (7058) 6.2.27 n/a n/a 4.2.10 n/a n/a n/a n/a n/a n/a n/a
HP NC532m Dual Port 10GbE Multifunction BL-c Adapter 6.2.27 7.0.53 n/a 7.4.2 n/a n/a n/a n/a n/a n/a n/a
HP Ethernet 10Gb 2-port 533FLR-T Adapter 7.8.79 7.8.78 n/a n/a n/a n/a n/a n/a 7.8.84 7.8.21 7.8.5
HP FlexFabric 10Gb 2-port 534FLB Adapter
HP FlexFabric 10Gb 2-port 534FLR-SFP+ Adapter
HP FlexFabric 10Gb 2-port 534M Adapter
HP StoreFabric CN1100R Dual Port Converged Network Adapter
7.8.79 7.8.78 n/a 7.8.78 n/a n/a n/a 7.8.76 7.8.84 7.8.21 7.8.5

Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


CCM:

  • This component addresses an issue where certain adapters may become non-functional when they are updated with the Comprehensive Configuration Management (CCM) firmware using this firmware update utility. This component now prevents landing of the CCM firmware on adapters that do not support CCM.

FCoE/iSCSI:

  • A system hang seen during the early phase of storage ROM initialization on some platforms has been addressed.
  • The firmware has been updated to use indirect accesses to address a boot failure seen when large Base Address Register (BAR) is enabled in the system BIOS.

Bootcode: 

  • This image addresses an issue where a 5719 chipset device reports “no firmware running” when an inbox driver is used.

NCSI:

  • This image addresses an issue where a Keyboard, Video and Mouse (KVM) session times out when a power cycle loop is performed for a long duration on a system with a Broadcom 5717/5719 chipset device.

Revision History

Version:2.26.1 (17 Jul 2020)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product corrects the wrong spare number while it was originally not the same as what was written on the label of package.


Version:2.25.1 (9 Mar 2020)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where Legacy Boot Protocol(System Utilities -> System Configuration -> NIC HII menu -> BA Configuration Menu) changes from None to PXE.
This product addresses an issue where it would be forced to exit System Utilities when select Port 2 & Port 3(System Utilities -> System Configuration -> NIC HII menu).


Version:2.24.2 (20 Dec 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product corrects an issue where random PXE boot installation failures occur when booting in UEFI mode.

Enhancements

This product no longer supports the following ProLiant Blade servers:

  •   HPE ProLiant BL660c Gen9 Server   
  •   HPE ProLiant BL460c Gen10 Server   
  •   HPE ProLiant BL460c Gen9 Server  
  •   HPE Synergy 680 Gen9 Compute Module   
  •   HPE Synergy 660 Gen10 Compute Module   
  •   HPE Synergy 660 Gen9 Compute Module   
  •   HPE Synergy 620 Gen9 Compute Module   
  •   HPE Synergy 480 Gen10 Compute Module   
  •   HPE Synergy 480 Gen9 Compute Module

Version:2.23.10 (2 Apr 2019)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product corrects an issue where the component fails to update adapter firmware when running on ESXi 6.7.  
This product corrects an issue where an incorrect device (Network Controller) name is displayed in the RBSU.


Version:2.22.3 (27 Nov 2018)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports Red Hat Enterprise Linux 6 Update 10.


Version:2.21.58 (27 Sep 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


N/A

Enhancements

This product now supports SUSE Linux Enterprise Server 15.


Version:2.21.3 (26 Jun 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where the NIC Serial Number for the HPE Ethernet 1Gb 4-port 331FLR Adapter is not displayed in AHS.

The firmware in this product  addresses an issue where the "Reboot Required" icon is not highlighted after a NIC firmware update (via System Utilities->Embedded Application->Firmware Update) completes.


Version:2.20.7 (5 Feb 2018)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • This product corrects an issue where an adapter’s configuration menu doesn't prompt for reboot after changes are made that require a reboot.
  • This firmware now correctly displays a progress bar information when updating the firmware via the ‘Firmware Update’ feature (under ‘System Utilities->Embedded Applications’). 

Version:2.19.6 (25 Sep 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where negative temperatures on the adapter are incorrectly displayed in Integrated Lights Out (iLO).
This product addresses an issue where an incorrect firmware image is landed on an adapter.
This product addresses an issue where an adapter's configuration menu doesn't correctly prompt for reboot after changes are made that require a reboot.

Enhancements

This product now supports Red Hat Enterprise Linux 7 Update 4.
This product now supports SUSE Linux Enterprise Server 12 SP3.


Version:2.18.15 (12 Jul 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where an adapter disappears when the system configuration settings are restored to defaults.

This product addresses an issue where iLO displays erroneous 11020 SNMP Trap messages.  The false trap messages register in iLO every 15 to 60 minutes.


Version:2.17.6 (26 Sep 2016)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where the server makes high speed fan noise after the PXE firmware on the adapter is updated to version 17.0.2.

This product addresses an issue where an incorrect firmware version is reported when updating firmware on the HP Ethernet 1Gb 2-port 332i Adapter.

This product addresses an issue where older smart components report an incorrect Bootcode version after the firmware on the adapter was originally updated using the component version 2.16.4 or later.

This product addresses an issue where an error code 7 is reported when updating firmware on the HP Ethernet 1Gb 4-port 331i-SPI Adapter.


Version:2.16.6 (1 Apr 2016)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an Uncorrectable Machine Check Exception error reported in the Integrated Management Log in the iLO.

This product addresses an issue where the IPv6 PXE boot entry may not show up in the 'One-Time Boot Menu' under the 'System Utilities' (F9 during POST).

This product addresses an issue where the existing firmware present on the adapter is incorrectly reported.

This product addresses an issue where the reported bootcode version is incorrect after the combo image is landed on the adapter.


Version:2.16.4(B) (1 Oct 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where Gen8 systems with a HP Ethernet 1Gb 4-port 331i Adapter LOM can no longer PXE boot after a firmware update.


Version:2.16.4 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports the HP Ethernet 1 Gb 2-port 332i Adapter (22E8).

This product now supports Red Hat Enterprise Linux 6 Update 7.

This product now supports SUSE LINUX Enterprise Server 11 SP4.


Version:2.15.10 (15 Jun 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses an issue where the sideband traffic on the second port stops after a system warm reboot when both ports are enabled for transmit and the first port is linked down.

This product addresses an issue where the firmware update on a device fails when PXE is up to date but the UEFI driver needs an update.

Enhancements

This product now supports only Broadcom NX1 devices. NX2 devices are now supported by “HP QLogic NX2 Online Firmware Upgrade Utility for Linux x86_64.”

This product now supports Red Hat Enterprise Linux 7 Update 1.


Version:2.14.17 (30 Mar 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports Red Hat Enterprise Linux 6 Update 6.

This product now supports SUSE LINUX Enterprise Server 12.

This product contains updated NCSI firmware (v1.3.5) that increases the number of multicast MAC address filters that can be supported from 2 to 8.


Version:2.13.5 (9 Sep 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The NX2 Unified Extensible Firmware Interface (UEFI) driver in this product no longer hangs when an invalid bandwidth value is entered in the NIC configuration menu under "System Configuration" on Gen 9 platforms.

The NX2 UEFI driver in this product no longer displays an unnecessary pop-up message regarding saving the settings when exiting the NIC configuration menu on Gen 9 platforms when no settings are changed.

The NX2 UEFI driver in this product no longer displays an unnecessary pop-up warning message when the user enters the NIC configuration menu under "System Configuration" on Gen 9 platforms with the HP Ethernet 10Gb 2-port 530T Adapter.

The bootcode in this product for 578xx devices now correctly reports thermal data.

This product addresses an issue where iSCSI boot fails when VLAN ID is enabled via Virtual Connect Manager's "iSCSI Boot Configuration" parameters.

This product addresses an issue where iSCSI boot fails when an adapter is configured to use the Dynamic Host Configuration Protocol (DHCP) Vendor ID via Virtual Connect Manager's "iSCSI Boot Configuration" parameters.

The updated iSCSI firmware addresses an issue where the iSCSI interface fails to acquire a Dynamic Host Configuration Protocol (DHCP) IP address from a server with a host name and root path longer than 32 characters.


Version:2.12.22 (9 Sep 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component contains updated boot code for Broadcom 5719 chipset based adapters to correct an issue which results in the device disappearing from the list of PCIe devices after system boot.

Enhancements

This product now supports the following network adapters:

  • HP Ethernet 1Gb 2-port 330i Adapter (22BD)
  • HP Ethernet 1Gb 4-port 331i Adapter (22BE)
  • HP FlexFabric 10Gb 2-port 536FLB Adapter

Version:2.11.20 (26 Apr 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports the following network adapters:

  • HP FlexFabric 20Gb 2-port 630FLB Adapter
  • HP FlexFabric 20Gb 2-port 630M Adapter

Version:2.10.15(B) (2 May 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


CCM:

  • This component addresses an issue where certain adapters may become non-functional when they are updated with the Comprehensive Configuration Management (CCM) firmware using this firmware update utility. This component now prevents landing of the CCM firmware on adapters that do not support CCM.

FCoE/iSCSI:

  • A system hang seen during the early phase of storage ROM initialization on some platforms has been addressed.
  • The firmware has been updated to use indirect accesses to address a boot failure seen when large Base Address Register (BAR) is enabled in the system BIOS.

Bootcode: 

  • This image addresses an issue where a 5719 chipset device reports “no firmware running” when an inbox driver is used.

NCSI:

  • This image addresses an issue where a Keyboard, Video and Mouse (KVM) session times out when a power cycle loop is performed for a long duration on a system with a Broadcom 5717/5719 chipset device.

Version:2.9.26 (10 Sep 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This FCoE firmware version addresses an FCoE ROM boot failure to establish connection with FCoE fabric in a certain configuration seen with version 7.8.17.

This FCoE firmware prevents a slowdown in boot time (~8 secs) and a VLAN discovery failure caused by the discovery logic of the FCoE ROM.

This iSCSI firmware addresses an iSCSI ROM Challenge Handshake Authentication Protocol (CHAP) failure seen with version 7.8.24.


Version:2.9.24 (10 Sep 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component resolves an issue where the OS may fail to boot or hang during iSCSI boot when using multipath.

This component resolves an issue where the iSCSI Boot Firmware Table was not initialized correctly for the secondary interface if a cable was not attached.


Version:2.9.21 (10 Sep 2013)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports the following network adapters:

  • HP Ethernet 10Gb 2-port 533FLR-T Adapter
  • HP FlexFabric 10Gb 2-port 534FLB Adapter
  • HP FlexFabric 10Gb 2-port 534FLR-SFP+ Adapter
  • HP FlexFabric 10Gb 2-port 534M Adapter
  • HP StoreFabric CN1100R Dual Port Converged Network Adapter

Version:2.7.20(C) (12 Apr 2013)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.


This component contains updated firmware for the following adapters:

  • HP Ethernet 1Gb 2-port 330i Adapter
  • HP Ethernet 1Gb 4-port 331FLR Adapter
  • HP Ethernet 1Gb 4-port 331i Adapter
  • HP Ethernet 1Gb 4-port 331i-SPI Adapter
  • HP Ethernet 1Gb 4-port 331T Adapter
  • HP Ethernet 1Gb 2-port 332i Adapter
  • HP Ethernet 1Gb 2-port 332T Adapter

This firmware corrects a potential NMI which can occur under heavy network stress.


This component contains an updated Managed Boot Agent (MBA) for the HP NC532m Dual Port 10GbE Multifunction BL-c Adapter which addresses an issue where the Media Access Control (MAC) address for port 1 incorrectly shows all zeroes.

Version:2.7.20 (19 Feb 2013)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component now supports the HP Ethernet 10Gb 2-port 530T Adapter.


Version:2.6.14 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports the HP Ethernet 1Gb 4-port 331i-SPI Adapter.

This package now supports Red Hat Enterprise Linux 6 Update 3.


Version:2.5.14 (4 Jun 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software package now supports the following network adapters:

  • HP Ethernet 1Gb 2-port 330i Adapter
  • HP Ethernet 1Gb 2-port 332T Adapter
  • HP Ethernet 10Gb 2-port 530SFP+ Adapter

This package now supports SUSE LINUX Enterprise Server 11 SP2.

Version:2.4.25 (B) (12 Mar 2012)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Updated PXE/MBA firmware for the 530FLB, 530M, and 530FLR to address a potential hang during PXE boot on a heavily loaded network.


Version:2.4.25 (27 Mar 2012)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports firmware updates for the following network adapters:

  • HP Ethernet 1Gb 4-port 331FLR Adapter
  • HP Ethernet 1Gb 4-port 331i Adapter
  • HP Ethernet 1Gb 4-port 331T Adapter
  • HP Flex-10 10Gb 2-port 530FLB Adapter
  • HP Ethernet 10Gb 2-port 530FLR-SFP+ Adapter
  • HP Flex-10 10Gb 2-port 530M Adapter

Version:2.3.0 (24 Feb 2011)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The correct informational messages are now displayed when discovering the NIC firmware versions installed on the system.

Enhancements

This software now supports Red Hat Enterprise Linux 6.


Version:2.2.9 (15 Dec 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool no longer fails when flashing the UMP on NC326i adapters.


Version:2.2.8 (26 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool now correctly detects network devices when executed by HPSUM.


Version:2.2.7 (6 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool now loads/unloads the bnx2x driver, which fixes an upgrade issue.

Enhancements

This component contains updated bootcode for the NC382i/T/m.

This component includes new management firmware the NC326i.

This tool can now downgrade the firmware in silent mode when the "force" switch is used.


Version:2.2.6 (B) (28 May 2010)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


This component no longer triggers an event that causes the DL100 series servers to hang on POST.


Version:2.2.6 (5 Feb 2010)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes:
Update Requirements:
      Recommended: HP recommends that users should update to this firmware version at their earliest convenience.

Problems Fixed:
     • This component contains updated NCSI firmware for the NC382i to resolve an issue where VLAN tagged packets were being dropped when run with latest OEM router. This component also contains updated bootcode for the NC382i, NC382m, and NC382T. This bootcode is require for the new NCSI code.
     • This component contains updated bootcode for the NC532m and NC532i. This firmware will resolve an issue where some NC532 devices may not enumerate correctly.


Version:2.2.4 (10 Nov 2009)
Fixes

This component contains updated IPMI firmware for the NC107i network adapter to resolve OS installation issues using PXE.

This component contains updated firmware that resolves an issue on the NC532m where PXE boot would fail when connected to certain switches using the priority field in the VLAN ID.


Version:2.2.3 (19 Aug 2009)
Enhancements
This component contains updated bootcode for the NC532i and NC532m network adapters. The updated bootcode includes Dynamic Control Channel (DCC) for Virtual Connect.

Version:2.2.2 (31 Jul 2009)
Fixes
This component contains updated bootcode for the NC382T network adapter to resolve a boot issue on the DL785 server.

Version:2.2.1 (B) (16 Sep 2009)
Fixes
This component resolves an issue with updating firmware when using HPSUM.

Version:2.2.1 (28 May 2009)
Fixes
This component contains updated firmware images for the NC325m, NC326m and NC373m network adapters. The updated firmware images resolve an issue with enabling PXE.

Version:2.1.8 (28 Apr 2009)
Fixes
This software no longer produces a segmentation fault while executing in HPSUM mode.

Version:2.1.7 (27 Mar 2009)
Enhancements

This software now supports firmware updates for the following network adapters:

  • HP NC105i Integrated PCI Express Gigabit Server Adapter
  • HP NC107i Integrated PCI Express Gigabit Server Adapter
  • HP NC382i Integrated Dual Port Multifunction Gigabit Server Adapter
  • HP NC382m Dual Port 1GbE Multifunction BL-c Adapter
  • HP NC382T PCI Express Dual Port Gigabit Server Adapter
  • HP NC532i Dual Port 10GbE Multifunction BL-c Adapter
  • HP NC532m Dual Port 10GbE Multifunction BL-c Adapter

Version:2.1.6 (7 Oct 2008)
Enhancements

This software now enables 2.5Gb support on c-class LOMs and mezzanine network adapters.


Version:2.1.4 (7 Aug 2008)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component contains the latest available firmware for the supported NICs.


Version:2.1.2 (29 Apr 2008)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software contains the latest available firmware for the supported NICs.

This software now has the latest CLP and iSCSI images so the user has the capibility to perform Linux or Windows 2003 iSCSI installs.


Version:2.1.0 (31 Mar 2008)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This utility no longer causes HPSUM to inaccurately write "Bad device status" in the OPMAN trace log so the user should not expect to see this message during a successful upgrade.


Version:2.0.9 (3 Oct 2007)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated the installation of the option ROM on C-Class adapters so the option ROM executes correctly after being updated.

Updated UMP firmware for HP NC373i Multifunction Adapters. With this firmware, UMP traffic no longer ceases when system is powered up from Vaux, eliminating the need to use the dedicated iLO port.


Version:2.0.7 (31 Aug 2007)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software provides the latest available firmware for the supported NICs.


Version:2.0.4 (13 Jul 2007)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Updated UMP firmware for HP NC371i Multifunction Adapters. With this firmware, UMP traffic no longer ceases when system is powered up from Vaux, eliminating the need to use the dedicated iLO port.


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.