Printable version

Drivers & software

HPE Library and Tape Tools

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Application
Version: 4.28 (2)(25 Jun 2019)
Operating System(s): OS Independent
Multi-part download
File name: hpe_ltt428_hpux_1123.tar (351 MB)
File name: hpe_ltt428_hpux_1131.tar (353 MB)
File name: hpe_ltt428_linux_x86.tar (73 MB)
File name: hpe_ltt428_linux_x86_64.tar (72 MB)
File name: hpe_ltt428_mac.dmg (65 MB)
File name: hpe_ltt428_solaris_amd64.tar (194 MB)
File name: hpe_ltt428_solaris_sparc.tar (177 MB)
File name: hpe_ltt428_win.exe (73 MB)
File name: HP-I64VMS-LTT-V0428--1.ZIPEXE (146 MB)
HPE Library and Tape Tools is a collection of storage hardware management and diagnostic tools for tape mechanisms and tape automation products. HPE Library and Tape Tools assembles these tools into a single, convenient program.

End User License Agreements:
HPE Software License Agreement v1


HPE Library and Tape Tools 4.28 Release Notes

 

Part Number: P11450-002a

Published: February 2019

Edition: 2

© Copyright 2019 Hewlett Packard Enterprise Development LP

Notices

The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein.

Confidential computer software. Valid license from Hewlett Packard Enterprise required for possession, use, or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Links to third-party websites take you outside the Hewlett Packard Enterprise website. Hewlett Packard Enterprise has no control over and is not responsible for information outside the Hewlett Packard Enterprise website.

Description

This release includes an updated version of HPE Library and Tape Tools (L&TT).

Version

4.28

Update recommendation

Recommended.

Supersedes

All earlier versions of L&TT for the supported Operating Systems.

Devices supported

  • Tape drives - same as L&TT 4.27.

  • Tape libraries - same as L&TT 4.27.

For more information on a full list of supported devices, see the L&TT User Guide.

Languages

English

Operating systems

 

L&TT operating system support

Operating system

OS variant

Supported version of L&TT

Windows

Windows 2012 and 2012 R2 x64

L&TT 4.28

Windows 8 and 8.1 (x86, x86_64)

L&TT 4.28

Windows 7 SP1 (x86, x86_64)

L&TT 4.28

Windows 2008 SP2 (x86, x86_64)

Windows 2008 R2 SP1 (x86_64)

Windows 10 (x64)

Windows 2016

L&TT 4.28

HP-UX

HP-UX 11i v3 (PA-RISC, IPF)

L&TT 4.28

HP-UX 11i v2 (PA-RISC, IPF)

L&TT 4.28

HP-UX 11i (PA-RISC)

L&TT 4.26

Linux

RedHat EL 6.x

L&TT 4.28

RedHat EL 7.x

L&TT 4.28

SuSE SLES 11 SP1, SP2, SP3 (X86, X86_64)

L&TT 4.28

Solaris

Oracle Solaris 10 Update 9 (x86, SPARC, AMD64)

L&TT 4.28

Mac

Mac 10.7 through 10.14 (x86) — Standalone drives, L&TT CSI only

L&TT 4.28

OpenVMS OpenVMS 8.4 (IPF)

L&TT 4.28

Enhancements and fixes in L&TT 4.28

Enhancements:

  • Addtional HPE library logs in MSL3040 and 6480 support tickets.

Maintenance:

  • New URL for firmware image downloads.

Fixes:

  • Support for 10 character media barcodes for LTO-7 & 8.

  • Other minor bug fixes.

Known issues and workarounds in L&TT 4.28

Webhelp not accessible

Symptom

You must enable javascript in order to view this page error is received when clicking on the Help.

Action

  1. To access the webhelp you must allow active content on your local drive. Open Internet Browser.
  2. Click Tools > Internet Options.
  3. Click Advance tab and select Allow active content to run in files on my Computer option.
  4. Click Apply.
  5. Click the Help on L&TT application to access the webhelp content.

Problem launching L&TT or Opening Support Tickets on Windows 10 / Windows Server 2016

Symptom

Double clicking on an L&TT ticket file does not completely open it.

Action

  1. Set L&TT to run as Administrator by default.
    • Right click on the L&TT shortcut and select properties.
    • Click on the 'Compatibility' tab to set L&TT to run as Administrator by default.

  2. Double clicking on an L&TT ticket file should now open it properly.

Prerequisites

  • Windows

    • Device drivers for the connected tape devices/libraries or default device driver must be present.

  • Linux

    • proc/SCSI subsystem must recognize the device .

    • The device driver for connected tape drives and libraries or the default device driver must be present.

Installation instructions

Download L&TT from HPE Library Tape and Tools.

For installation instructions for all supported Operating Systems, see L&TT User Guide.

Windows

The Windows version of L&TT uses the InstallShield application.

Reboot requirements

  • A reboot is required only if your system requires ASPI or an upgrade to the currently installed version. On systems that require ASPI, if the Installer detects a previously installed version of ASPI older than v4.57, it will install a more recent version of ASPI, which will require a reboot.

  • Issues may arise, however, when using the Miniport I/O mode with devices that use nonstandard OS drivers, or are “claimed” by other applications or the OS. When using the Miniport I/O mode when a device is claimed, it may be necessary to close any running backup/storage application services to make the device accessible to L&TT. Alternatively, using the ASPI I/O mode may make the device accessible without requiring any action.

Known issues

  • When downloading the L&TT application from the Web to your local system, name the download folder to something other than HPE Library and Tape Tools or the installation will fail if you attempt to install from that folder. The failure error will indicate that a different instance of the Installer is already running.

  • Also, do not rename the L&TT installation file. Renaming the file may create a conflict that prevents L&TT from installing.

To install the current Windows version of L&TT:

Procedure

  1. Download or copy the self-extracting executable file to a temporary location.
    IMPORTANT:
    Do not rename this file. Renaming the file may create a conflict that prevents L&TT from installing.
     
  2. Double-click the self-extracting executable file for launching the Installer. The InstallShield Wizard screen is displayed.
  3. Click Next. Read the program license agreement and click Yes if you agree to and accept the terms of the license agreement.
  4. Read the readme file for any last-minute changes to the documentation, then click Next. The Select Features screen is displayed.
  5. Select the desired components for installing, and then click Next.
  6. Select a destination location for installing the program. You can accept the default location or click Browse to install to a different location. After choosing the destination location, click Next.
  7. Indicate the program directory in which you want the setup program to create program icons and click Next. The program directory is created in the Programs directory of the Start menu.
  8. On the Ready to start installation process screen, click Next. To review or change installation settings, click Back.
  9. When installation is complete, the InstallShield wizard displays its final screen. Select Start HPE L&TT or Run LTT InstallCheck if you would like the wizard to start L&TT or the installation check. Click Finish for closing the InstallShield wizard.

Linux

Uninstalling previous versions

Before installing L&TT on Linux, you must first uninstall any previous versions.

To determine if L&TT is already installed, use the following command:

rpm -qa | grep ltt

To remove a previous version of L&TT, use the following command:

rpm -e hpeltt<xx> (where <xx> is the version number)

Installing the latest version

  1. Log in as root.

  2. Navigate to the temporary directory:

    cd /tmp

  3. Download or copy the L&TT tar file, hpe_ltt<xx>.tar ( where <xx> is the version number) to this directory. If you are copying the file from a different location, enter the following (substitute the directory in which the file currently resides for <directory name>):

    cp /<directory name>/hpe_ltt<xx>.tar /tmp

  4. Un-tar the L&TT tar file:

    tar -xvf hpe_ltt<xx>.tar

  5. Run the install script in the /tmp directory:

    ./install_hpeltt
    NOTE:
    For Linux, the L&TT Installer verifies that the operating system you are installing on is supported. If the Linux distribution or release is unsupported, the install script displays a message indicating an installation failure and lists the supported operating systems.
  6. After the software is successfully installed, enter the following commands to remove the /tmp/ltt directory and its contents:

    cd /tmp

    rm -rf ltt

    rm -rf install_hpeltt

    rm -rf hpe_ltt<xx>.tar (where <xx> is the version number)


Version:4.30 (25 Nov 2019)
Version:4.29 (3 Jun 2019)
Version:4.28 (2) (25 Jun 2019)
Version:4.27 (1 Oct 2018)
Version:4.26(1) (1 Jun 2018)
Type: Application
Version: 4.28 (2)(25 Jun 2019)
Operating System(s):
OS Independent

Description

HPE Library and Tape Tools is a collection of storage hardware management and diagnostic tools for tape mechanisms and tape automation products. HPE Library and Tape Tools assembles these tools into a single, convenient program.

Release Notes

End User License Agreements:
HPE Software License Agreement v1


HPE Library and Tape Tools 4.28 Release Notes

 

Part Number: P11450-002a

Published: February 2019

Edition: 2

© Copyright 2019 Hewlett Packard Enterprise Development LP

Notices

The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein.

Confidential computer software. Valid license from Hewlett Packard Enterprise required for possession, use, or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Links to third-party websites take you outside the Hewlett Packard Enterprise website. Hewlett Packard Enterprise has no control over and is not responsible for information outside the Hewlett Packard Enterprise website.

Description

This release includes an updated version of HPE Library and Tape Tools (L&TT).

Version

4.28

Update recommendation

Recommended.

Supersedes

All earlier versions of L&TT for the supported Operating Systems.

Devices supported

  • Tape drives - same as L&TT 4.27.

  • Tape libraries - same as L&TT 4.27.

For more information on a full list of supported devices, see the L&TT User Guide.

Languages

English

Operating systems

 

L&TT operating system support

Operating system

OS variant

Supported version of L&TT

Windows

Windows 2012 and 2012 R2 x64

L&TT 4.28

Windows 8 and 8.1 (x86, x86_64)

L&TT 4.28

Windows 7 SP1 (x86, x86_64)

L&TT 4.28

Windows 2008 SP2 (x86, x86_64)

Windows 2008 R2 SP1 (x86_64)

Windows 10 (x64)

Windows 2016

L&TT 4.28

HP-UX

HP-UX 11i v3 (PA-RISC, IPF)

L&TT 4.28

HP-UX 11i v2 (PA-RISC, IPF)

L&TT 4.28

HP-UX 11i (PA-RISC)

L&TT 4.26

Linux

RedHat EL 6.x

L&TT 4.28

RedHat EL 7.x

L&TT 4.28

SuSE SLES 11 SP1, SP2, SP3 (X86, X86_64)

L&TT 4.28

Solaris

Oracle Solaris 10 Update 9 (x86, SPARC, AMD64)

L&TT 4.28

Mac

Mac 10.7 through 10.14 (x86) — Standalone drives, L&TT CSI only

L&TT 4.28

OpenVMS OpenVMS 8.4 (IPF)

L&TT 4.28

Enhancements and fixes in L&TT 4.28

Enhancements:

  • Addtional HPE library logs in MSL3040 and 6480 support tickets.

Maintenance:

  • New URL for firmware image downloads.

Fixes:

  • Support for 10 character media barcodes for LTO-7 & 8.

  • Other minor bug fixes.

Known issues and workarounds in L&TT 4.28

Webhelp not accessible

Symptom

You must enable javascript in order to view this page error is received when clicking on the Help.

Action

  1. To access the webhelp you must allow active content on your local drive. Open Internet Browser.
  2. Click Tools > Internet Options.
  3. Click Advance tab and select Allow active content to run in files on my Computer option.
  4. Click Apply.
  5. Click the Help on L&TT application to access the webhelp content.

Problem launching L&TT or Opening Support Tickets on Windows 10 / Windows Server 2016

Symptom

Double clicking on an L&TT ticket file does not completely open it.

Action

  1. Set L&TT to run as Administrator by default.
    • Right click on the L&TT shortcut and select properties.
    • Click on the 'Compatibility' tab to set L&TT to run as Administrator by default.

  2. Double clicking on an L&TT ticket file should now open it properly.

Prerequisites

  • Windows

    • Device drivers for the connected tape devices/libraries or default device driver must be present.

  • Linux

    • proc/SCSI subsystem must recognize the device .

    • The device driver for connected tape drives and libraries or the default device driver must be present.

Installation instructions

Download L&TT from HPE Library Tape and Tools.

For installation instructions for all supported Operating Systems, see L&TT User Guide.

Windows

The Windows version of L&TT uses the InstallShield application.

Reboot requirements

  • A reboot is required only if your system requires ASPI or an upgrade to the currently installed version. On systems that require ASPI, if the Installer detects a previously installed version of ASPI older than v4.57, it will install a more recent version of ASPI, which will require a reboot.

  • Issues may arise, however, when using the Miniport I/O mode with devices that use nonstandard OS drivers, or are “claimed” by other applications or the OS. When using the Miniport I/O mode when a device is claimed, it may be necessary to close any running backup/storage application services to make the device accessible to L&TT. Alternatively, using the ASPI I/O mode may make the device accessible without requiring any action.

Known issues

  • When downloading the L&TT application from the Web to your local system, name the download folder to something other than HPE Library and Tape Tools or the installation will fail if you attempt to install from that folder. The failure error will indicate that a different instance of the Installer is already running.

  • Also, do not rename the L&TT installation file. Renaming the file may create a conflict that prevents L&TT from installing.

To install the current Windows version of L&TT:

Procedure

  1. Download or copy the self-extracting executable file to a temporary location.
    IMPORTANT:
    Do not rename this file. Renaming the file may create a conflict that prevents L&TT from installing.
     
  2. Double-click the self-extracting executable file for launching the Installer. The InstallShield Wizard screen is displayed.
  3. Click Next. Read the program license agreement and click Yes if you agree to and accept the terms of the license agreement.
  4. Read the readme file for any last-minute changes to the documentation, then click Next. The Select Features screen is displayed.
  5. Select the desired components for installing, and then click Next.
  6. Select a destination location for installing the program. You can accept the default location or click Browse to install to a different location. After choosing the destination location, click Next.
  7. Indicate the program directory in which you want the setup program to create program icons and click Next. The program directory is created in the Programs directory of the Start menu.
  8. On the Ready to start installation process screen, click Next. To review or change installation settings, click Back.
  9. When installation is complete, the InstallShield wizard displays its final screen. Select Start HPE L&TT or Run LTT InstallCheck if you would like the wizard to start L&TT or the installation check. Click Finish for closing the InstallShield wizard.

Linux

Uninstalling previous versions

Before installing L&TT on Linux, you must first uninstall any previous versions.

To determine if L&TT is already installed, use the following command:

rpm -qa | grep ltt

To remove a previous version of L&TT, use the following command:

rpm -e hpeltt<xx> (where <xx> is the version number)

Installing the latest version

  1. Log in as root.

  2. Navigate to the temporary directory:

    cd /tmp

  3. Download or copy the L&TT tar file, hpe_ltt<xx>.tar ( where <xx> is the version number) to this directory. If you are copying the file from a different location, enter the following (substitute the directory in which the file currently resides for <directory name>):

    cp /<directory name>/hpe_ltt<xx>.tar /tmp

  4. Un-tar the L&TT tar file:

    tar -xvf hpe_ltt<xx>.tar

  5. Run the install script in the /tmp directory:

    ./install_hpeltt
    NOTE:
    For Linux, the L&TT Installer verifies that the operating system you are installing on is supported. If the Linux distribution or release is unsupported, the install script displays a message indicating an installation failure and lists the supported operating systems.
  6. After the software is successfully installed, enter the following commands to remove the /tmp/ltt directory and its contents:

    cd /tmp

    rm -rf ltt

    rm -rf install_hpeltt

    rm -rf hpe_ltt<xx>.tar (where <xx> is the version number)


Revision History

Version:4.30 (25 Nov 2019)
Version:4.29 (3 Jun 2019)
Version:4.28 (2) (25 Jun 2019)
Version:4.27 (1 Oct 2018)
Version:4.26(1) (1 Jun 2018)

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.