Printable version

Drivers & software

* RECOMMENDED * HP BladeSystem c-Class Virtual Connect Support Utility for Linux

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Utility - Tools
Version: 1.10.1(28 Aug 2014)
Operating System(s): Red Hat Enterprise Linux 5 Server (x86)
Red Hat Enterprise Linux 5 Server (x86-64)
Red Hat Enterprise Linux 6 Server (x86)
Red Hat Enterprise Linux 6 Server (x86-64)
SUSE Linux Enterprise Server 10 (AMD64/EM64T)
SUSE Linux Enterprise Server 10 (x86)
SUSE Linux Enterprise Server 11 (AMD64/EM64T)
SUSE Linux Enterprise Server 11 (x86)
File name: vcsu-1.10.1-i686.rpm (3.1 MB)
This utility allows users to remotely upgrade the HP BladeSystem c-Class Virtual Connect module firmware.

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.
 

To ensure the integrity of your download, HP recommends verifying your results with this MD5 Checksum value:

4d1089c57201d227277cbfbc7a3f986c vcsu-1.10.1-i686.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

  • Use the 'rpm' command to install. Example: "rpm -ivh vcsu-1.9.0-i686.rpm"

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Important:
 The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.


Notes:

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.
 


Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "Resolved issues" section of the release notes.
 

 The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.
Version:1.15.0 (17 Dec 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.15.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.15.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.14.0(a) (20 May 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.14.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.14.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.13.1 (8 Oct 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.13.1 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.13.1 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.13.0 (7 Jul 2017)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.13.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.13.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.12.0 (15 May 2016)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The latest version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The latest version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.11.1 (3 Aug 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Support Utility Release Notes can be found under this URL.  Please refer to the "Fixes" section of the release notes.
 

Enhancements

The latest version of HP Virtual Connect Support Utility Release Notes can be found under this URL.  Please refer to the "Enhancements" section of the release notes.
 


Version:1.11.0 (9 Feb 2015)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


REMOVED: Virtual Connect Support Utility version 1.11.0 is no longer available for use due to issues found when updating to Virtual Connect Firmware version 4.30 that may cause some or all networks to be unavailable which could result in all uplink ports showing as Linked-Standy.  For details about this issue, refer to HP Customer Advisory c04422904.  To install new or upgrade existing firmware, use VirtualConnect Support Utility 1.11.1, which is available at link.

Enhancements

REMOVED: Virtual Connect Support Utility version 1.11.0 is no longer available for use due to issues found when updating to Virtual Connect Firmware version 4.30 that may cause some or all networks to be unavailable which could result in all uplink ports showing as Linked-Standy.  For details about this issue, refer to HP Customer Advisory c04422904.  To install new or upgrade existing firmware, use VirtualConnect Support Utility 1.11.1, which is available at link.


Version:1.10.1 (28 Aug 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "Resolved issues" section of the release notes.
 

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.
 


Version:1.9.1 (21 Apr 2014)
Fixes

Upgrade Requirement:
Critical - HP requires users update to this version immediately.


Corrected OpenSSL security vulnerability communicated in Security Bulletin HPSBMU02998 for CVE-2014-0160 known as “Heartbleed”.

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under
this URL.  Please refer to the "Resolved issues" section of the release notes.

 

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.
 


Version:1.8.1 (10 Jun 2013)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "Resolved issues" section of the release notes.

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.



Version:1.7.1 (10 Dec 2012)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.

Users are required to use VCSU 1.7.1 or higher if updating to Virtual Connect 3.70 or higher


For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "Resolved Issues" section.

Enhancements

For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "New features" section.


Version:1.7.0 (5 Sep 2012)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

Users are required to use VCSU 1.7.0 or higher if updating to Virtual Connect 3.70 or higher.


For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "Resolved Issues" section.

Enhancements

For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "New features" section.


Version:1.6.0 (21 Jul 2011)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Problems Fixed:
     • At the final stage of a firmware update, VCSU waits a fixed amount of time for a primary VC module to become active. VCSU exits when this timer has expired, which results in a FAILURE status. VCSU has increased the amount of wait time to ensure that VCSU does not exit before VC Manager has completed its activation process. 
     • The VCSU library function to support HPSUM now reports proper failure status when at least one module has failed its firmware update. 
     • VCSU now sets tty settings properly so that it works under any type of terminal emulation. 
     • When in VCSU interactive mode, VCSU now recognizes the space character as part of a pathname for a VC package. 
     • VCSU now accepts the "\" character as part of the user name used to access Onboard Administrator. 
     • The "@" symbol is now accepted in Packageinfo for FTP package locations. 
     • Previously, VCSU terminated when encountering an upgrade failure. Now VCSU skips any failed modules and continues to upgrade the remaining modules. 
     • Previously, VCSU aborted in interactive mode when the "Force Update" prompt was left blank, and Enter was pressed. 
     • Resolved an issue where VCSU exited with an error when in VCSU interactive mode if a firmware pathname provided contained quotes. 
     • Resolved an issue where VCSU did not perform a firmware update when there was no VC domain defined. 
     • Resolved an issue where activation would fail with the message, "VCM configuration not in sync." 
     • Resolved an issue where the firmware update would fail in a multi-enclosure environment using the maximum configuration. 
     • Resolved an issue where users would receive a segmentation fault error when running VCSU in a multi-enclosure environment. 
     • Resolved an issue where an update would fail in an unimported enclosure. 
     • Resolved upgrade failures when using certain newer versions of Onboard Administrator and Virtual Connect Manager. 
     • If a disruption to the network connection occurs during a firmware update, VCSU now gracefully exits the update session. 
     • Previously, VCSU would terminate abnormally when processing an IP address in IPv6 format. VCSU now gracefully exits the update session. 
     • Resolved an issue where VCSU would terminate abnormally while updating certain large configurations.
     • Resolved an issue where the firmware update for FC modules would fail due to an interrupted previous firmware update. 
     • Resolved an issue where a firmware update would fail with an error message "Unable to create SSH session." 
     • In some cases where VCM was in NO_COMM with the primary module, the VCSU healthcheck command incorrectly reported modules IN SYNC.

Enhancements

Enhancements/New Features:
     • A VCSU update operation can be performed from a server blade in the same enclosure that is being updated. However, this feature is only supported when using a redundant network configuration on the server blade running the VCSU client.
     • If the enclosure is in VCM mode, a support dump is downloaded before an update operation begins.


Version:1.5.2 (11 Jan 2011)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.


Important Notes:
     Read the latest version of HP BladeSystem c•Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL: 
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3552695

Problems Fixed:
     •Updated VC-FC module firmware upgrade for VC 4Gb FC, VC 8Gb 20-Port FC, and VC 8Gb 24-Port FC modules to allow firewalls in the environment as long as both Primary and Backup VC-Enet modules are healthy. 
     •Resolved an issue where VCSU -oe serial enet activation option does not force failover. 
     •Resolved an issue where VCSU does not accept '\' in LDAP user credential.
     •Resolved an issue where Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations.

Known Issues:
     •When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the "-l" command-line parameter.

Enhancements

None


Version:1.5.1 (17 Sep 2010)
Fixes

Upgrade Requirement:
Critical - HP requires users update to this version immediately.


Important Notes:
     Read the latest version of HP BladeSystem c•Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL: http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3552695


Problems Fixed:
     •Resolved an issue were the Virtual Connect Manager (VCM) domain suffered corruptions with a firmware update when being used with the serial activation method. The corruption would result in the domain getting deleted and when a user would log in, it would prompt the user to import your domain (or restore from backup).
     •Resolved an issue were when the serial activation method was used, it may have the primary Virtual Connect (VC) module comes up with an old configuration.
     •Resolved an issue with Virtual Connect Support Utility (VCSU) not allowing "/" or "@" as part of the LDAP user authentication credentials.
     •Resolved an issue with the default method of activation were VCSU may activate primary VC modules while it is reconfiguring other VC-Enet modules that were just activated.

Known Issues:
     •When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the "-l" command-line parameter.
     •Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations. Temporary work around is to temporarily remove or power off some of the VC-FC modules and try the update again. If successful, then reinsert or power on remaining VC-FC modules and run VCSU again to complete upgrade operation.

Enhancements

None


Version:1.5.0 (17 May 2010)
Fixes

Upgrade Requirement:
Critical - HP requires users update to this version immediately.


Important Notes:
     Read the latest version of HP BladeSystem c-Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL: http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3552695


Problems Fixed:
     1. Resolved an issue where VCM domain suffered corruptions with a firmware update when being used with the parallel activation method. The corruption would result in the domain getting deleted and when you log in, it would prompt you to import your domain (or restore from backup).
     
     2. Resolved an issue with the use of  the parallel activation method, that may cause the primary to come up with an old configuration.
     

Known Issues:
     1. Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations. Temporary work around is to temporarily remove or power off some of the VC-FC modules and try the update again. If successful, then reinsert or power on remaining VC-FC modules and run VCSU again to complete upgrade operation.
     2. When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the “-l” command-line parameter.

Enhancements

Enhancements/New Features:
     1. Improved progress reporting.
     2. Support Primary Bay Independence.
     3. Enhanced platform support
     • HP-UX for Integrity
     • Linux (RedHat 4, RedHat 5, SLES 10, SLES 11) for x86.


Type: Utility - Tools
Version: 1.10.1(28 Aug 2014)
Operating System(s):
Red Hat Enterprise Linux 5 Server (x86)
Red Hat Enterprise Linux 5 Server (x86-64)
Red Hat Enterprise Linux 6 Server (x86)
Red Hat Enterprise Linux 6 Server (x86-64)
SUSE Linux Enterprise Server 10 (AMD64/EM64T)
SUSE Linux Enterprise Server 10 (x86)
SUSE Linux Enterprise Server 11 (AMD64/EM64T)
SUSE Linux Enterprise Server 11 (x86)

Description

This utility allows users to remotely upgrade the HP BladeSystem c-Class Virtual Connect module firmware.

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.
 

Installation Instructions

To ensure the integrity of your download, HP recommends verifying your results with this MD5 Checksum value:

4d1089c57201d227277cbfbc7a3f986c vcsu-1.10.1-i686.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

  • Use the 'rpm' command to install. Example: "rpm -ivh vcsu-1.9.0-i686.rpm"

Release Notes

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Important:
 The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.


Notes:

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.
 


Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "Resolved issues" section of the release notes.
 

Important

 The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.

Revision History

Version:1.15.0 (17 Dec 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.15.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.15.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.14.0(a) (20 May 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.14.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.14.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.13.1 (8 Oct 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.13.1 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.13.1 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.13.0 (7 Jul 2017)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The 1.13.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The 1.13.0 version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.12.0 (15 May 2016)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The latest version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Fixes" section of the release notes.

Enhancements

The latest version of HPE Virtual Connect Support Utility Release Notes can be found at http://www.hpe.com/info/vc/manuals.  Please refer to the "Enhancements" section of the release notes.


Version:1.11.1 (3 Aug 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Support Utility Release Notes can be found under this URL.  Please refer to the "Fixes" section of the release notes.
 

Enhancements

The latest version of HP Virtual Connect Support Utility Release Notes can be found under this URL.  Please refer to the "Enhancements" section of the release notes.
 


Version:1.11.0 (9 Feb 2015)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


REMOVED: Virtual Connect Support Utility version 1.11.0 is no longer available for use due to issues found when updating to Virtual Connect Firmware version 4.30 that may cause some or all networks to be unavailable which could result in all uplink ports showing as Linked-Standy.  For details about this issue, refer to HP Customer Advisory c04422904.  To install new or upgrade existing firmware, use VirtualConnect Support Utility 1.11.1, which is available at link.

Enhancements

REMOVED: Virtual Connect Support Utility version 1.11.0 is no longer available for use due to issues found when updating to Virtual Connect Firmware version 4.30 that may cause some or all networks to be unavailable which could result in all uplink ports showing as Linked-Standy.  For details about this issue, refer to HP Customer Advisory c04422904.  To install new or upgrade existing firmware, use VirtualConnect Support Utility 1.11.1, which is available at link.


Version:1.10.1 (28 Aug 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "Resolved issues" section of the release notes.
 

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.
 


Version:1.9.1 (21 Apr 2014)
Fixes

Upgrade Requirement:
Critical - HP requires users update to this version immediately.


Corrected OpenSSL security vulnerability communicated in Security Bulletin HPSBMU02998 for CVE-2014-0160 known as “Heartbleed”.

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under
this URL.  Please refer to the "Resolved issues" section of the release notes.

 

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.
 


Version:1.8.1 (10 Jun 2013)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "Resolved issues" section of the release notes.

Enhancements

The latest version of HP Virtual Connect Release Notes can be found in the "User guide" section under this URL.  Please refer to the "New features" section of the release notes.



Version:1.7.1 (10 Dec 2012)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.

Users are required to use VCSU 1.7.1 or higher if updating to Virtual Connect 3.70 or higher


For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "Resolved Issues" section.

Enhancements

For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "New features" section.


Version:1.7.0 (5 Sep 2012)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

Users are required to use VCSU 1.7.0 or higher if updating to Virtual Connect 3.70 or higher.


For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "Resolved Issues" section.

Enhancements

For more information about VCSU, see the HP BladeSystem c-Class Virtual Connect Support Utility release notes on the Installing tab of the HP BladeSystem Technical Resources website (http://www.hp.com/go/bladesystem/documentation).  Please refer to the release notes, "New features" section.


Version:1.6.0 (21 Jul 2011)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Problems Fixed:
     • At the final stage of a firmware update, VCSU waits a fixed amount of time for a primary VC module to become active. VCSU exits when this timer has expired, which results in a FAILURE status. VCSU has increased the amount of wait time to ensure that VCSU does not exit before VC Manager has completed its activation process. 
     • The VCSU library function to support HPSUM now reports proper failure status when at least one module has failed its firmware update. 
     • VCSU now sets tty settings properly so that it works under any type of terminal emulation. 
     • When in VCSU interactive mode, VCSU now recognizes the space character as part of a pathname for a VC package. 
     • VCSU now accepts the "\" character as part of the user name used to access Onboard Administrator. 
     • The "@" symbol is now accepted in Packageinfo for FTP package locations. 
     • Previously, VCSU terminated when encountering an upgrade failure. Now VCSU skips any failed modules and continues to upgrade the remaining modules. 
     • Previously, VCSU aborted in interactive mode when the "Force Update" prompt was left blank, and Enter was pressed. 
     • Resolved an issue where VCSU exited with an error when in VCSU interactive mode if a firmware pathname provided contained quotes. 
     • Resolved an issue where VCSU did not perform a firmware update when there was no VC domain defined. 
     • Resolved an issue where activation would fail with the message, "VCM configuration not in sync." 
     • Resolved an issue where the firmware update would fail in a multi-enclosure environment using the maximum configuration. 
     • Resolved an issue where users would receive a segmentation fault error when running VCSU in a multi-enclosure environment. 
     • Resolved an issue where an update would fail in an unimported enclosure. 
     • Resolved upgrade failures when using certain newer versions of Onboard Administrator and Virtual Connect Manager. 
     • If a disruption to the network connection occurs during a firmware update, VCSU now gracefully exits the update session. 
     • Previously, VCSU would terminate abnormally when processing an IP address in IPv6 format. VCSU now gracefully exits the update session. 
     • Resolved an issue where VCSU would terminate abnormally while updating certain large configurations.
     • Resolved an issue where the firmware update for FC modules would fail due to an interrupted previous firmware update. 
     • Resolved an issue where a firmware update would fail with an error message "Unable to create SSH session." 
     • In some cases where VCM was in NO_COMM with the primary module, the VCSU healthcheck command incorrectly reported modules IN SYNC.

Enhancements

Enhancements/New Features:
     • A VCSU update operation can be performed from a server blade in the same enclosure that is being updated. However, this feature is only supported when using a redundant network configuration on the server blade running the VCSU client.
     • If the enclosure is in VCM mode, a support dump is downloaded before an update operation begins.


Version:1.5.2 (11 Jan 2011)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.


Important Notes:
     Read the latest version of HP BladeSystem c•Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL: 
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3552695

Problems Fixed:
     •Updated VC-FC module firmware upgrade for VC 4Gb FC, VC 8Gb 20-Port FC, and VC 8Gb 24-Port FC modules to allow firewalls in the environment as long as both Primary and Backup VC-Enet modules are healthy. 
     •Resolved an issue where VCSU -oe serial enet activation option does not force failover. 
     •Resolved an issue where VCSU does not accept '\' in LDAP user credential.
     •Resolved an issue where Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations.

Known Issues:
     •When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the "-l" command-line parameter.

Enhancements

None


Version:1.5.1 (17 Sep 2010)
Fixes

Upgrade Requirement:
Critical - HP requires users update to this version immediately.


Important Notes:
     Read the latest version of HP BladeSystem c•Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL: http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3552695


Problems Fixed:
     •Resolved an issue were the Virtual Connect Manager (VCM) domain suffered corruptions with a firmware update when being used with the serial activation method. The corruption would result in the domain getting deleted and when a user would log in, it would prompt the user to import your domain (or restore from backup).
     •Resolved an issue were when the serial activation method was used, it may have the primary Virtual Connect (VC) module comes up with an old configuration.
     •Resolved an issue with Virtual Connect Support Utility (VCSU) not allowing "/" or "@" as part of the LDAP user authentication credentials.
     •Resolved an issue with the default method of activation were VCSU may activate primary VC modules while it is reconfiguring other VC-Enet modules that were just activated.

Known Issues:
     •When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the "-l" command-line parameter.
     •Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations. Temporary work around is to temporarily remove or power off some of the VC-FC modules and try the update again. If successful, then reinsert or power on remaining VC-FC modules and run VCSU again to complete upgrade operation.

Enhancements

None


Version:1.5.0 (17 May 2010)
Fixes

Upgrade Requirement:
Critical - HP requires users update to this version immediately.


Important Notes:
     Read the latest version of HP BladeSystem c-Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL: http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3552695


Problems Fixed:
     1. Resolved an issue where VCM domain suffered corruptions with a firmware update when being used with the parallel activation method. The corruption would result in the domain getting deleted and when you log in, it would prompt you to import your domain (or restore from backup).
     
     2. Resolved an issue with the use of  the parallel activation method, that may cause the primary to come up with an old configuration.
     

Known Issues:
     1. Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations. Temporary work around is to temporarily remove or power off some of the VC-FC modules and try the update again. If successful, then reinsert or power on remaining VC-FC modules and run VCSU again to complete upgrade operation.
     2. When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the “-l” command-line parameter.

Enhancements

Enhancements/New Features:
     1. Improved progress reporting.
     2. Support Primary Bay Independence.
     3. Enhanced platform support
     • HP-UX for Integrity
     • Linux (RedHat 4, RedHat 5, SLES 10, SLES 11) for x86.


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.