Printable version

Drivers & software

* RECOMMENDED * HPE Foundation Software ISO Image for HPE Superdome Flex Server

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Software (Entitlement Required)
Version: 1.01(16 Mar 2018)
Operating System(s): OS Independent
Red Hat Enterprise Linux 7 Server
SUSE Linux Enterprise Server 12
Multi-part download
File name: hpe-foundation-1.1-cd1-media-rhel73-x86_64.iso (6.9 MB)
File name: hpe-foundation-1.1-cd1-media-rhel74-x86_64.iso (7.0 MB)
File name: hpe-foundation-1.1-cd1-media-sles12sp2-x86_64.iso (5.2 MB)
File name: hpe-foundation-1.1-cd1-media-sles12sp3-x86_64.iso (5.2 MB)
This bundle contains a package with the HFS (HPE Foundation Software) ISO image version 1.1 to be installed on HPE Superdome Flex Server running with RHEL, SLES or Oracle Linux. HFS includes DCD (Data Collection Daemon).

  • Support of systems up to 32 sockets and 24 TB memory
  • The uvstats library and its applications, linkstat and hubstats, are now supported on Superdome Flex

Prerequisites:

Please note the following pre-requisites prior to installing the Foundation Software update:

  • A supported version of the operating system is installed.
  • You have access to the HPE Foundation Software update file.
  • You have access to the operating system repositories. These may be online repositories provided by the operating system vendors or local repositories managed by the site.
  • You have root access to the system.
    Note: The installation instructions assume that systems are configured so that package dependencies can be resolved by installing additional packages from the operating systems.

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

3c0b771994330f3a82f6419d501333db610589a5a2b46786227193e95640915e hpe-foundation-1.1-cd1-media-rhel74-x86_64.iso
79fb58e5ea620abd11791d14957e252a6792900ba580eb38672fbf8abf64ec4e hpe-foundation-1.1-cd1-media-sles12sp3-x86_64.iso
b17d51291d52228817430bbec0c5692462b1899e4ae4e022126d091bf6dc276a hpe-foundation-1.1-cd1-media-sles12sp2-x86_64.iso
1a925438cddd5156353ff5064e4bd4657b275258f7ef6112887f9f2cf23981e1 hpe-foundation-1.1-cd1-media-rhel73-x86_64.iso

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Please review all instructions and the "Hewlett Packard Enterprise Support Tool License Terms" or your Hewlett Packard Enterprise support terms and conditions for precautions, scope of license, restrictions, and limitation of liability and warranties, before installing this package. It is important that you read and understand these instructions completely before you begin. This can determine your success in completing the software update.

  1. PREPARATION
    1. You must login to the system as root user.
       
    2. In order to install the Foundation Software ISO image Version 1.1, you must first copy the hpe-foundation-1.1-cd1-media-<OS>-x86_64.iso file corresponding to your OS to the Superdome Flex system, where <OS> is rhel73, rhel74, sles12sp2 or sles12sp3
               Note: For Oracle Linux UEK, use the ISO image for rhel74

         Example with /tmp/ as destination directory:
                 scp hpe-foundation-1.1-cd1-media-sles12sp3-x86_64.iso root@<system-name>:/tmp/
         
  2. INSTALLATION
    1. Installation/update for SLES:
      1.  Create a repo file /etc/zypp/repos.d/Foundation.repo that looks like this:  
          -  Replace <OS> with sles12sp2 or sles12sp3
          - /tmp/ is the directory where you copied the file earlier

        [Foundation]
             name=Foundation
             enabled=1
             autorefresh=0
             baseurl=iso:///?iso=hpe-foundation-1.1-cd1-media-<OS>-x86_64.iso&url=dir:///tmp/
             path=/
             type=yast2
             keeppackages=0
         
      2. Refresh zypper:
               zypper clean ; zypper refresh
         
      3.  Install/update the Foundation Software:
               For a fresh install, run: zypper install -t pattern HPE-Foundation
               For an update, run: zypper update -t pattern HPE-Foundation
         
      4.  Install/update DCD (Data Collection Daemon) for Remote Support:
         - For a new instalation: DCD and its dependencies get automatically installed as part of step 'c' above.
         - For an update: use the following commands to update DCD:
               zypper update storelib
               zypper install hpe-dcd-1.1-1.x86_64 
         
      5.  Reboot the system:
               reboot
         After the system reaches the EFI shell, in the RMC command window, enter:
                power reset npar pnum=0
         
    2.  Installation/update for RHEL or Oracle Linux:
      1. Create a mount point for the ISO:
           #mkdir /mnt/Foundation
         
      2. Mount the ISO
         Note: /tmp/ matches the location of the ISO and <OS> is rhel73 or rhel74
          Note: For Oracle Linux, select rhel74
               # mount -o loop /tmp/hpe-foundation-1.1-cd1-media-<OS>-x86_64.iso /mnt/Foundation
         
      3. Create a repo file (ie /etc/yum.repos.d/HPE-Foundation.repo) that looks like this:
          [hpe-foundation]
              name=HPE-Foundation
               baseurl=file:///mnt/Foundation/RPMS
               enabled=1
               gpgkey=file:///mnt/Foundation/RPM-GPG-KEY-hpe
                             file:///mnt/Foundation/RPM-GPG-KEY-sgi
               gpgcheck=1
         
      4. Refresh yum
        # yum clean all
         
      5.  Install/update HPE Foundation Software:
         - For RHEL 7.3 or 7.4, use:
              # yum groupinstall "HPE Foundation Software"
         - For Oracle Linux, use:
              # yum groupinstall -y "HPE Foundation Software for Oracle Linux"
        Note: To see the list of groups to install, use: yum grouplist
         
      6. install/update DCD:
         - For a new installation,
        DCD and its dependencies get automatically installed as part of step 'e' above
         - For an update, use the following commands to update DCD:
              # yum update storelib
              # yum update hpe-dcd
        Note: You can check the installed version by running:
           # rpm -qi hpe-dcd | grep -i version
         
      7. Reboot the system to activate the change:
           reboot
        After the system reaches the EFI shell, in the RMC command window, enter:
           power reset npar pnum=0

Note: Refer to your operating system documentation for details on adding directories of RPM packages as available software sources/repositories for use by zipper and yum.


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

HPE recommends running with the latest available version.


Important:

TITLE: HPE Foundation Software ISO Image for HPE Superdome Flex Server

VERSION: 1.1

DESCRIPTION:

This bundle contains a package with the HFS (HPE Foundation Software) ISO image version 1.1 to be installed on HPE Superdome Flex Server running with RHEL, SLES or Oracle Linux. HFS includes DCD (Data Collection Daemon).

HFS (HPE Foundation Software) 1.1 consists of software packages specifically designed to ensure the smooth operation of the HPE Superdome Flex server. It includes DCD, an agentless service that proactively monitors the health of hardware components on the HPE Superdome Flex server. For more details on DCD, refer to the Readme installed under /opt/hpe/dcd/data/ as well as the full DCD Release notes posted here

Prior to installation, customers are strongly encouraged to familiarize themselves with the documentation provided by the operating system vendors:

For more specific software installation details, you may also refer to the HPE Superdome Flex Server Software Installation and Configuration Guide available under  https://support.hpe.com/hpesc/public/home/documentHome?sp4ts.oid=1010323142.

SUPERSEDES:
Version: 1.0

PRODUCT MODEL(S):
HPE Superdome Flex server

OPERATING SYSTEMS:

  • Red Hat Enterprise Linux 7.3, 7.4
  • SUSE Linux Enterprise Server 12 SP2, 12 SP3
  • Oracle Linux UEK (Unbreakable Enterprise Kernel) 4 update 5

LANGUAGES:
International English

COMPATIBILITY/INTEROPERABILITY:
HPE recommends running with the latest HFS and firmware available versions.

KNOWN ISSUES:

  • DCD does not provide the Serial Number of the Intel C600/X79 SATA RAID Controller (Base IO) in its system inventory data. This is a known behavior.
  • Systems with a large number of I/O cards may experience out of memory or interrupt enablement issues during kdump. See advisory at this link for details.

DISCLAIMER:
The information in this document is subject to change without notice.

Hewlett Packard Enterprise makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Hewlett Packard Enterprise shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

This document contains proprietary information that is protected by copyright. All rights are reserved. No part of this document may be reproduced, photocopied, or translated to another language without the prior written consent of Hewlett Packard Enterprise Company.

(C) Copyright 2017-2018 Hewlett Packard Enterprise Development Company, L.P.

FEEDBACK
As we are continuing to improve the firmware management process we welcome your feedback on this document and on the firmware update process.
TEAM-FWupdateFeedback@groups.ext.hpe.com


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

HPE recommends running with the latest available version.


  • Fix for unloading the ipmi_si kernel module
  • Update-PCI-Ids reports missing devices instead of trying to access the network to find them
  • Fixed issues with hpe-auto-config

TITLE: HPE Foundation Software ISO Image for HPE Superdome Flex Server

VERSION: 1.1

DESCRIPTION:

This bundle contains a package with the HFS (HPE Foundation Software) ISO image version 1.1 to be installed on HPE Superdome Flex Server running with RHEL, SLES or Oracle Linux. HFS includes DCD (Data Collection Daemon).

HFS (HPE Foundation Software) 1.1 consists of software packages specifically designed to ensure the smooth operation of the HPE Superdome Flex server. It includes DCD, an agentless service that proactively monitors the health of hardware components on the HPE Superdome Flex server. For more details on DCD, refer to the Readme installed under /opt/hpe/dcd/data/ as well as the full DCD Release notes posted here

Prior to installation, customers are strongly encouraged to familiarize themselves with the documentation provided by the operating system vendors:

For more specific software installation details, you may also refer to the HPE Superdome Flex Server Software Installation and Configuration Guide available under  https://support.hpe.com/hpesc/public/home/documentHome?sp4ts.oid=1010323142.

SUPERSEDES:
Version: 1.0

PRODUCT MODEL(S):
HPE Superdome Flex server

OPERATING SYSTEMS:

  • Red Hat Enterprise Linux 7.3, 7.4
  • SUSE Linux Enterprise Server 12 SP2, 12 SP3
  • Oracle Linux UEK (Unbreakable Enterprise Kernel) 4 update 5

LANGUAGES:
International English

COMPATIBILITY/INTEROPERABILITY:
HPE recommends running with the latest HFS and firmware available versions.

KNOWN ISSUES:

  • DCD does not provide the Serial Number of the Intel C600/X79 SATA RAID Controller (Base IO) in its system inventory data. This is a known behavior.
  • Systems with a large number of I/O cards may experience out of memory or interrupt enablement issues during kdump. See advisory at this link for details.

DISCLAIMER:
The information in this document is subject to change without notice.

Hewlett Packard Enterprise makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Hewlett Packard Enterprise shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

This document contains proprietary information that is protected by copyright. All rights are reserved. No part of this document may be reproduced, photocopied, or translated to another language without the prior written consent of Hewlett Packard Enterprise Company.

(C) Copyright 2017-2018 Hewlett Packard Enterprise Development Company, L.P.

FEEDBACK
As we are continuing to improve the firmware management process we welcome your feedback on this document and on the firmware update process.
TEAM-FWupdateFeedback@groups.ext.hpe.com

Version:2.4 (1 Dec 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.4:

  • Fix cache_topology_info on hubless
    • Properly handle caching of topology information on hubless systems.

DCD 3.1-2.0

  • Fixed an issue where the CapacityBytes attribute was being reported incorrectly for NVMe controllers in the system inventory data.

  • Fixed an issue where the CapacityBytesDetected attribute for NVMe controllers was being reported in blocks instead of bytes in the system inventory data.

  • Fixed an issue where the VolumeType attribute for a RAID 10 logical drive (managed by MegaRAID 9361-4i controller) was being reported as empty string (instead of "RAID10").

  • Fixed handling of RAID volume consistency check related events for MegaRAID 9361-4i controller so that they are reported correctly to RMC.

Enhancements

HFS 2.4:

  • Added support for HPE Superdome Flex 280 systems (Intel Xeon® Scalable processors 83XX/63XX/53XX)
  • Add CPU_FREQ_DRIVER
    • Add new sysconfig variable CPU_FREQ_DRIVER and associated scriplet 14_cpufreq.sh.  Users can select a CPU frequency driver to use, and hpe-auto-config will disable/blacklist any other CPU frequency drivers.
      Currently, the choices are intel_pstate and acpi_cpufreq. 
      CPU_FREQ_DRIVER defaults to "" and results in no configuration.
       
  • Add geoid nic names for hubless systems
    • The format of "topology --networks --noheader" output changes from 5-column to 3-column on hubless systems.
    • This, and the assumption that a nic port would be determined by its PCI function, causes non-working geoid nic names on HPE Superdome Flex 280 servers.
    • Re-implement geoid based on the assumption that a nic port is determined by its order of appearance.
    • Add option UV_GEOID_NIC_SHORT_NAMES with comment on the changed hardware geoid naming scheme.
       
  • Update hwperf build for UEK6
    • Update hwperf to build with with UEK6.
       
  • Add support for RHEL 8.3.
  • December 2020 update:
    • Added Intel microcode issue under "Known Issues"

DCD 3.1-2.0:

  • Added support for HPE Superdome Flex 280 servers

  • Added support to report the Manufacturer attribute for all resource types in the system inventory data.

  • Added support to inventory the following GPU:

    1) HPE NVIDIA Tesla V100S PCIe 32GB

  • Added support to report RAID battery related events in CAE for MegaRAID SAS 9361-4i controller.

  • Updated part number table for new SSD drives.

  • Updated StorageCore API to version 4.20.11.0 (SR 2.5.2.2 release).


Version:2.3.2(a) (3 Dec 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers  
Enhancements

HFS 2.3.2(a):

  • Added support for RHEL 8.3 on systems with Intel Xeon® Scalable processors 82XX/62XX
  • December 2020 update:
    • Added Intel microcode issue under "Known Issues"

HFS 2.3.2:

  • Added support for RHEL 7.9
  • Added support for RHEL 8.2 and OL 8.1 on systems with Intel Xeon® Scalable processors 81XX/61XX

Version:2.3.2 (26 Oct 2020)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers  
Enhancements

HFS 2.3.2:

  • Added support for RHEL 7.9
  • Added support for RHEL 8.2 and OL 8.1 on systems with Intel Xeon® Scalable processors 81XX/61XX

Version:2.3.1(a) (25 Sep 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3.1:

  • On systems running with RHEL 8.x (8.0, 8.1, 8.2), if BLS is disabled via setting GRUB_ENABLE_BLSCFG=false in /etc/default/grub, and grub2-mkconfig  rebuilds /boot/efi/EFI/redhat/grub.cfg, the kernel command line in the new grub.cfg is now recognized by HFS as HFS now accepts commands that start with either linux or linuxefi.
  • Restarting rsyslog no longer re-runs hpe-auto-config 
  • HFS now remove numa=off from the bootline if it had been added during an OS installation

DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers
Enhancements

HFS 2.3.1(a):

  • September 2020 update:
    • Added support for SPES 15 SP2

DCD 2.3-0-3:

  • Added support to detect and generate an event on state change for Microchip SmartRAID 3162-8i /e storage controllers, physical drives and RAID volumes

Version:2.3.1 (29 Jun 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3.1:

  • On systems running with RHEL 8.x (8.0, 8.1, 8.2), if BLS is disabled via setting GRUB_ENABLE_BLSCFG=false in /etc/default/grub, and grub2-mkconfig  rebuilds /boot/efi/EFI/redhat/grub.cfg, the kernel command line in the new grub.cfg is now recognized by HFS as HFS now accepts commands that start with either linux or linuxefi.
  • Restarting rsyslog no longer re-runs hpe-auto-config 
  • HFS now remove numa=off from the bootline if it had been added during an OS installation

DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers
Enhancements

DCD 2.3-0-3:

  • Added support to detect and generate an event on state change for Microchip SmartRAID 3162-8i /e storage controllers, physical drives and RAID volumes

Version:2.3(a) (11 Jun 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3:

  • kdump:
    • Addressed errors such as "crashkernel reservation failed - memory in use" by choosing the appropriate crashkernel= method for the running kernel.
  • Memlog:
    • Addressed memlog errors such as “ERROR SEGV detected. Obtained 8 stack frames” seen with RHEL 7.3.
  • Hwperf:
    • Fixed an issue where topology command would abort stating that it encountered unknown devices. The command now prints the error without aborting. 
       

DCD 2.3-0.1:

  • No changes
Enhancements

HFS 2.3:

  • Added support for RHEL 7.8
  • June 2020 update:
    • Added support for RHEL 8.2; RHEL 8.2 bits were added to bundle 2.3(A)
    • Added support for OL 7.8, 8.1 and for OL 7.8 & OL 8.1 with UEK6 on systems with 62xx/82xx processors

DCD 2.3-0.1:

  • Pre-enabled support for new Samsung PM1733/1735 NVMe cards:
    • HPE 1.6TB PCIe x8 MU HH DS Card (1.6 TB)
    • HPE 3.2TB PCIe x8 MU HH DS Card (3.2 TB)
    • HPE 6.4TB PCIe x8 MU HH DS Card (6.4 TB)
  • Updated part number table for new SSD drives

Version:2.3 (12 May 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3:

  • kdump:
    • Addressed errors such as "crashkernel reservation failed - memory in use" by choosing the appropriate crashkernel= method for the running kernel.
  • Memlog:
    • Addressed memlog errors such as “ERROR SEGV detected. Obtained 8 stack frames” seen with RHEL 7.3.
  • Hwperf:
    • Fixed an issue where topology command would abort stating that it encountered unknown devices. The command now prints the error without aborting. 
       

DCD 2.3-0.1:

  • No changes
Enhancements

HFS 2.3:

  • Added support for RHEL 7.8
     

DCD 2.3-0.1:

  • Pre-enabled support for new Samsung PM1733/1735 NVMe cards:
    • HPE 1.6TB PCIe x8 MU HH DS Card (1.6 TB)
    • HPE 3.2TB PCIe x8 MU HH DS Card (3.2 TB)
    • HPE 6.4TB PCIe x8 MU HH DS Card (6.4 TB)
  • Updated part number table for new SSD drives

Version:2.2 (4 Dec 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes in HFS 2.2:

  • Fixed an issue where the system would stop writing to memlog after switching to a new log file due to memlog file being full

Fixes in DCD 2.2-0.5:

  • Fixed issue with hpe-dcd rpm package incorrectly owning directory /opt/hpe.
  • Fixed a memory leak in Ethernet events handling support that occurs when there is sudden burst of Ethernet events
  • Fixed an issue in the Ethernet support functionality which was rarely causing DCD service stop process to take time (order of few minutes)
  • Fixed an issue where Intel SATA RAID controller’s Protocol was being reported as "SAS/SATA" instead of "SATA" in system inventory data
Enhancements

January 2020: Added a Known Issue for a panic occurring with SLES 15 SP1 update (4.12.14-197.29.1)

Enhancements in HFS 2.2:

  • Added support for RHEL 8.1, SLES 12 SP5

Enhancements in DCD 2.2-0.5:

  • Added support to inventory the following GPU cards:

1) NVIDIA Quadro RTX 8000

  • "Oem.Slot" JSON attribute type has been changed from an integer to a string for all physical drives attached to SAS/SATA storage controllers.
  • Added support to provide PartNumber values for the Infiniband cards which are represented as Ethernet cards in the Inventory.

Version:2.1 (3 Sep 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.1:

- hpe-auto-config:

  • i40iw driver is blacklisted due to RDMA/iWARP being unsupported on the LOM device 

- hwperf:

  • An explicit dependency for pciutils was added at install time (needed by the topology command for lspci)

DCD 2.1-1:

  • Fixed the issue of DCD IPv4Addresses field not being Redfish-compliant when no IPv4 address is configured on the managed server.
  • Fixed the issue of Protocol being shown as “ATA” (instead of “SATA”) for physical drives attached to Intel SATA RAID controller in the drive online (DCD_DRIVE_OK) event.
  • Fixed the issue of “request sense failed” message being repeated logged in Linux syslog (/var/log/messages) on SLES 12 SP3, when the DCD-requested Device Statistics log page is not supported by the physical drive attached to Intel SATA RAID controller.
  • Fixed issue of RAID10 logical volume (configured on LSI MegaRAID 9361-4i) incorrectly showing volume type as “RAID01” in the inventory string.
  • Fixed issues in DCD service configuration file that was causing systemd (version 232 or higher) to report error messages related to service start rate limiting parameters.
Enhancements

HFS 2.1:

- hpe-auto-config:

  • Do not overwrite the elevator boot parameter value on the kernel cmdline if it is already set in the hpe-auto-config file.
  • Changed CPU idle governor default setting from ‘ladder’ to ‘menu’ to prevent health_check to report a failure

- gr_stats:

  • Fixed an issue where gr_systat would not get an accurate count of traffic volume.

- memlog: 

  • Addressed an issue where memlog output would be garbled  

DCD 2.1-1:

  • Added support to inventory and monitor the following Samsung PM1725B NVMe cards:
    • HPE 6.4TB NVMe x8 MU HH DS Card
    • HPE 3.2TB NVMe x8 MU HH DS Card
    • HPE 1.6TB NVMe x8 MU HH DS Card
  • Added support to inventory the following GPU cards:
    • NVIDIA Quadro RTX 6000
    • AMD Radeon Instinct MI60
  • Added support to inventory Microchip SmartRAID 3154-8e and 3162-8i /e storage controllers.
  • Added PartNumber field for LSI MegaRAID 9361-4i, Intel SATA RAID, and NVIDIA GPU controllers in DCD Inventory JSON.
  • Modified PartNumber field in DCD Inventory JSON for physical disk drives and Fibre Channel controllers to use the Spare Part Number.
  • Updated part number information reported for specific models of HPE Ethernet adapters.

Version:1.6 (14 Jun 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

Note: This is the initial release for systems with with Intel Xeon® Scalable processors 82XX / 62XX.


Hpe-auto-config:

  • i40iw driver is blacklisted due to RDMA/iWARP being unsupported on the LOM device 

Hwperf:

  • An explicit dependency for pciutils was added at install time (needed by the topology command for lspci)
Enhancements

Hpe-auto-config:

  • Newer kernel versions support the newer EFI mapping.  hpe-auto-config looks to see if the kernel supports newer EFI mapping and removes efi=old_map if it does.
  • sap-hana: If HPE_CONFIG_PROFILE=HANA, TCP tunings defined in the following files will be applied by hpe-auto-config :
    • /etc/saptune/extra/HPE-Recommended_OS_settings.conf (SUSE)
    • /etc/tuned/sap-hpe-hana/tuned.conf (RHEL)
  • Added verbose and dry-run functionality to hpe-auto-config:
    • –n (--dry-run): performs all processing but does not edit bootloader_config
    • –v (--verbose): includes additional output in /var/log/hpe-auto-config.log  

Version:1.5 (25 Mar 2019)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.


Critical:

  • Fixed an issue where hpe_irqbalance would stop running due to some recent IO driver versions returning an unexpected error when trying to set/change an IRQ CPU affinity. As a result, IRQ affinity is not being set on subsequent devices.

Memlog:

  • Fixed an issue where memlogd would return a message like "NOTICE error obtaining Dram DDR4 code, row 12 col a width 4" due to missing a rank address map for 128G DIMMs.
  • Fixed an issue where memlogd would sometimes point to the wrong DIMM in case of DIMM failures.

Hwperf:

  • Fixed an issue with Oracle Linux 7.6 UEK5 kernel 4.14.35-1906 where "rmmod hwperf" would get stuck on spinlock
  • Fixed an issue with Oracle Linux 7.6 UEK5 kernel 4.14.35-1844.2.5 where hwperf would display "unknown symbol uv_hwperf_exit"
  • Fixed a spinlock issue where hwperf would go to sleep after taking the spinlock
  • Made changes so the Time Stamp Counter (TSC), important for database apps, works correctly with Oracle Linux 7.6 UEK5 update2 (4.14.35-1844.2.5.el7uek)

Hpe-auto-config:

  • Correctly locate grub.cfg with CentOS

Sdstats:

  • Changed the channel utilization computation to (Avg MiB/s) / (Max Channel MiB/s) and display label as MiB  

Version:1.4 (4 Feb 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Addressed a startup message similar to “SL_GetDimmConfig: Unable to mmap pci space for socket 0 chan 0”, causing memlog to incorreclty decode DIMM information
  • Addressed a startup error message "mmap smbios: Resource temporarily unavailable"
  • Fixed an issue during shutdown where /boot would be unmounted before hpe-auto-config completes, leading to this error being displayed: “sgiconfig: /boot/efi is not mounted as vfat. Grub2 config cannot be updated”
  • DMI (Desktop Management Interface) device locator string is now correctly recognized with newer BIOS versions
  • Ensure that hpe-auto-config uses the proper grub.cfg file on SLES with EFI
  • Compensate for computation time in hubstats interval so interval is as expected
Enhancements

  • Added support for RHEL 7.6 and SLES 12 SP4.

Note: RHEL 7.3 and SLES 12 SP2 are not supported by HFS version 1.4; please use a prior HFS version to run with older OS’es.

 


Version:1.3(A) (27 Nov 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS Bundle 1.3:

  • Addresses an issue seen with SLES15 and RHEL 7.5, where the system would hang during shutdown with an “NMI watchdog: BUG: soft lockup” error.  
  • Starting with HFS version 1.3, it is supported to run Linux on a system with Secure Boot enabled.
  • On all SUSE versions as well as RHEL 7.3 and lower, added nohz=off on the Linux boot line to avoid holdoffs in tickless code, which may cause unpredictable behavior. Also because nohz=off, skew_tick=1 is added to avoid timer tick contention.

HFS Bundle 1.3(A):

  • Addresses an issue seen with HFS version 1.3 where memlog would incorreclty decode DIMM information, potentially resulting in higher CPU usage at boot time and slower boot.
  • January 2019: changed the link to the DCD release notes to point to the release notes for DCD version 1.3.  
Enhancements

  • Added support for SLES 15.
  • Some extended tuning scripts are now managed via a sysconfig variable (disabled by default). The script 20_sap_hana.sh is run when adding HPE_CONFIG_PROFILE=HANA to sysconfig.
  • Implemented NIC naming based on physical location (e.g. chassis, rack unit, slot like 'r001i06s02p0'), allowing to directly identify the network card location in a multiple chassis setup. To activate the new naming, set UV_GEOID_NIC_NAMES to “yes” in /etc/sysconfig/hpe-auto-config, then run hpe-auto-config and reboot. Note: This feature requires distros with systemd, implemented with SLES 12 (or later) and RHEL 7 (or later).

Version:1.2.2 (28 Sep 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • When running sdstats on a heavily loaded system, sdstats now only prints once per node the message "hwperf: WARNING: dashboard db_<node> is unresponsive", to indicate possible slow performance of system performance tools such as hubstats.
  • Fixed an issue where hpe_irqbalance wouldfail/exit, after running for a number of days, with error "Too many open files".
  • sdstats related fixes:
    • Min latency stats are now enabled by default
    • hubstats now ends its collection gracefully when terminated with Ctrl-C
    • Fixed values calculation in the dashboard map file and metrics
    • Fixed an issue where the header was printing twice with sdstats gruMemTraffic option
    • sdstats now correctly computes the minimum and maximum latency statistics

Version:1.21(a) (21 Aug 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • HFS version 1.2.1.1 (bundle 1.21(a)) fixes a signing issue on bits inside HFS 1.2.1 (bundle 1.21), which prevented their successful installation. 

Note: HFS version 1.2.1 is being removed from HPE Support Center. It fixed the following (also fixed in HFS version 1.2.1.1):

  • Added support for two or more MegaRAID 9361-4i controllers per partition.
  • Integrated with newer version of storelib (07.0309.0100.0700)
  • Fixed an issue of segmentation fault that may occur when the DCD service is stopped.
  • Fixed issue of DCD events not being generated if the inventory-refresh happens at a time when a stream of events from MegaRAID 9361-4i are being processed by DCD.

  • Fixed issue of missing inventory in DCD JSON string on a partition where it takes DCD a long time (several minutes or more) to inventory the partition’s hardware configuration.

 


Version:1.21 (9 Aug 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


REMOVED – This version is no longer available for download due to a signing issue preventing to install the bits. For more information, click “Obtain software” to display the advisory.

HFS version 1.2.1 includes DCD version 1.2-6 which contains the following changes:

  • Added support for two or more MegaRAID 9361-4i controllers per partition.
  • Integrated with newer version of storelib (07.0309.0100.0700)
  • Fixed an issue of segmentation fault that may occur when the DCD service is stopped.
  • Fixed issue of DCD events not being generated if the inventory-refresh happens at a time when a stream of events from MegaRAID 9361-4i are being processed by DCD.

  • Fixed issue of missing inventory in DCD JSON string on a partition where it takes DCD a long time (several minutes or more) to inventory the partition’s hardware configuration.


Version:1.02 (2 Aug 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Add retpoline fixes to address Speculative Store Bypass or Variant 4 (CVE-2018-3639) vulnerability
  • Fixed issue with latency stats enablement
  • Failing DIMM slot is now correctly identified
  • Fixed a kdump kernel boot issue on SLES 12 SP2 or SP3
  • Improved IO device descriptions
  • New message generated when device description is missing from pci.id database, recommending to run update-pciids
  • Memlog: nfit driver is no longer blacklisted
  • Disable ERST (Error Record Serialization Table) on RHEL 7 to prevent crashes at boot
Enhancements

  • Add support for RHEL 7.5
  • Uvstats renamed sdstats, add live mode and latency statistics configuration
  • Memlog: improved error reporting

Version:1.01 (16 Mar 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

HPE recommends running with the latest available version.


  • Fix for unloading the ipmi_si kernel module
  • Update-PCI-Ids reports missing devices instead of trying to access the network to find them
  • Fixed issues with hpe-auto-config
Enhancements

  • Support of systems up to 32 sockets and 24 TB memory
  • The uvstats library and its applications, linkstat and hubstats, are now supported on Superdome Flex

Version:1.00 (20 Dec 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.

N/A - Initial Release


N/A - Initial Release


Type: Software (Entitlement Required)
Version: 1.01(16 Mar 2018)
Operating System(s):
OS Independent
Red Hat Enterprise Linux 7 Server
SUSE Linux Enterprise Server 12

Description

This bundle contains a package with the HFS (HPE Foundation Software) ISO image version 1.1 to be installed on HPE Superdome Flex Server running with RHEL, SLES or Oracle Linux. HFS includes DCD (Data Collection Daemon).

Enhancements

  • Support of systems up to 32 sockets and 24 TB memory
  • The uvstats library and its applications, linkstat and hubstats, are now supported on Superdome Flex

Installation Instructions

Prerequisites:

Please note the following pre-requisites prior to installing the Foundation Software update:

  • A supported version of the operating system is installed.
  • You have access to the HPE Foundation Software update file.
  • You have access to the operating system repositories. These may be online repositories provided by the operating system vendors or local repositories managed by the site.
  • You have root access to the system.
    Note: The installation instructions assume that systems are configured so that package dependencies can be resolved by installing additional packages from the operating systems.

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

3c0b771994330f3a82f6419d501333db610589a5a2b46786227193e95640915e hpe-foundation-1.1-cd1-media-rhel74-x86_64.iso
79fb58e5ea620abd11791d14957e252a6792900ba580eb38672fbf8abf64ec4e hpe-foundation-1.1-cd1-media-sles12sp3-x86_64.iso
b17d51291d52228817430bbec0c5692462b1899e4ae4e022126d091bf6dc276a hpe-foundation-1.1-cd1-media-sles12sp2-x86_64.iso
1a925438cddd5156353ff5064e4bd4657b275258f7ef6112887f9f2cf23981e1 hpe-foundation-1.1-cd1-media-rhel73-x86_64.iso

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Please review all instructions and the "Hewlett Packard Enterprise Support Tool License Terms" or your Hewlett Packard Enterprise support terms and conditions for precautions, scope of license, restrictions, and limitation of liability and warranties, before installing this package. It is important that you read and understand these instructions completely before you begin. This can determine your success in completing the software update.

  1. PREPARATION
    1. You must login to the system as root user.
       
    2. In order to install the Foundation Software ISO image Version 1.1, you must first copy the hpe-foundation-1.1-cd1-media-<OS>-x86_64.iso file corresponding to your OS to the Superdome Flex system, where <OS> is rhel73, rhel74, sles12sp2 or sles12sp3
               Note: For Oracle Linux UEK, use the ISO image for rhel74

         Example with /tmp/ as destination directory:
                 scp hpe-foundation-1.1-cd1-media-sles12sp3-x86_64.iso root@<system-name>:/tmp/
         
  2. INSTALLATION
    1. Installation/update for SLES:
      1.  Create a repo file /etc/zypp/repos.d/Foundation.repo that looks like this:  
          -  Replace <OS> with sles12sp2 or sles12sp3
          - /tmp/ is the directory where you copied the file earlier

        [Foundation]
             name=Foundation
             enabled=1
             autorefresh=0
             baseurl=iso:///?iso=hpe-foundation-1.1-cd1-media-<OS>-x86_64.iso&url=dir:///tmp/
             path=/
             type=yast2
             keeppackages=0
         
      2. Refresh zypper:
               zypper clean ; zypper refresh
         
      3.  Install/update the Foundation Software:
               For a fresh install, run: zypper install -t pattern HPE-Foundation
               For an update, run: zypper update -t pattern HPE-Foundation
         
      4.  Install/update DCD (Data Collection Daemon) for Remote Support:
         - For a new instalation: DCD and its dependencies get automatically installed as part of step 'c' above.
         - For an update: use the following commands to update DCD:
               zypper update storelib
               zypper install hpe-dcd-1.1-1.x86_64 
         
      5.  Reboot the system:
               reboot
         After the system reaches the EFI shell, in the RMC command window, enter:
                power reset npar pnum=0
         
    2.  Installation/update for RHEL or Oracle Linux:
      1. Create a mount point for the ISO:
           #mkdir /mnt/Foundation
         
      2. Mount the ISO
         Note: /tmp/ matches the location of the ISO and <OS> is rhel73 or rhel74
          Note: For Oracle Linux, select rhel74
               # mount -o loop /tmp/hpe-foundation-1.1-cd1-media-<OS>-x86_64.iso /mnt/Foundation
         
      3. Create a repo file (ie /etc/yum.repos.d/HPE-Foundation.repo) that looks like this:
          [hpe-foundation]
              name=HPE-Foundation
               baseurl=file:///mnt/Foundation/RPMS
               enabled=1
               gpgkey=file:///mnt/Foundation/RPM-GPG-KEY-hpe
                             file:///mnt/Foundation/RPM-GPG-KEY-sgi
               gpgcheck=1
         
      4. Refresh yum
        # yum clean all
         
      5.  Install/update HPE Foundation Software:
         - For RHEL 7.3 or 7.4, use:
              # yum groupinstall "HPE Foundation Software"
         - For Oracle Linux, use:
              # yum groupinstall -y "HPE Foundation Software for Oracle Linux"
        Note: To see the list of groups to install, use: yum grouplist
         
      6. install/update DCD:
         - For a new installation,
        DCD and its dependencies get automatically installed as part of step 'e' above
         - For an update, use the following commands to update DCD:
              # yum update storelib
              # yum update hpe-dcd
        Note: You can check the installed version by running:
           # rpm -qi hpe-dcd | grep -i version
         
      7. Reboot the system to activate the change:
           reboot
        After the system reaches the EFI shell, in the RMC command window, enter:
           power reset npar pnum=0

Note: Refer to your operating system documentation for details on adding directories of RPM packages as available software sources/repositories for use by zipper and yum.


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

HPE recommends running with the latest available version.


Important:

TITLE: HPE Foundation Software ISO Image for HPE Superdome Flex Server

VERSION: 1.1

DESCRIPTION:

This bundle contains a package with the HFS (HPE Foundation Software) ISO image version 1.1 to be installed on HPE Superdome Flex Server running with RHEL, SLES or Oracle Linux. HFS includes DCD (Data Collection Daemon).

HFS (HPE Foundation Software) 1.1 consists of software packages specifically designed to ensure the smooth operation of the HPE Superdome Flex server. It includes DCD, an agentless service that proactively monitors the health of hardware components on the HPE Superdome Flex server. For more details on DCD, refer to the Readme installed under /opt/hpe/dcd/data/ as well as the full DCD Release notes posted here

Prior to installation, customers are strongly encouraged to familiarize themselves with the documentation provided by the operating system vendors:

For more specific software installation details, you may also refer to the HPE Superdome Flex Server Software Installation and Configuration Guide available under  https://support.hpe.com/hpesc/public/home/documentHome?sp4ts.oid=1010323142.

SUPERSEDES:
Version: 1.0

PRODUCT MODEL(S):
HPE Superdome Flex server

OPERATING SYSTEMS:

  • Red Hat Enterprise Linux 7.3, 7.4
  • SUSE Linux Enterprise Server 12 SP2, 12 SP3
  • Oracle Linux UEK (Unbreakable Enterprise Kernel) 4 update 5

LANGUAGES:
International English

COMPATIBILITY/INTEROPERABILITY:
HPE recommends running with the latest HFS and firmware available versions.

KNOWN ISSUES:

  • DCD does not provide the Serial Number of the Intel C600/X79 SATA RAID Controller (Base IO) in its system inventory data. This is a known behavior.
  • Systems with a large number of I/O cards may experience out of memory or interrupt enablement issues during kdump. See advisory at this link for details.

DISCLAIMER:
The information in this document is subject to change without notice.

Hewlett Packard Enterprise makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Hewlett Packard Enterprise shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

This document contains proprietary information that is protected by copyright. All rights are reserved. No part of this document may be reproduced, photocopied, or translated to another language without the prior written consent of Hewlett Packard Enterprise Company.

(C) Copyright 2017-2018 Hewlett Packard Enterprise Development Company, L.P.

FEEDBACK
As we are continuing to improve the firmware management process we welcome your feedback on this document and on the firmware update process.
TEAM-FWupdateFeedback@groups.ext.hpe.com


Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

HPE recommends running with the latest available version.


  • Fix for unloading the ipmi_si kernel module
  • Update-PCI-Ids reports missing devices instead of trying to access the network to find them
  • Fixed issues with hpe-auto-config

Important

TITLE: HPE Foundation Software ISO Image for HPE Superdome Flex Server

VERSION: 1.1

DESCRIPTION:

This bundle contains a package with the HFS (HPE Foundation Software) ISO image version 1.1 to be installed on HPE Superdome Flex Server running with RHEL, SLES or Oracle Linux. HFS includes DCD (Data Collection Daemon).

HFS (HPE Foundation Software) 1.1 consists of software packages specifically designed to ensure the smooth operation of the HPE Superdome Flex server. It includes DCD, an agentless service that proactively monitors the health of hardware components on the HPE Superdome Flex server. For more details on DCD, refer to the Readme installed under /opt/hpe/dcd/data/ as well as the full DCD Release notes posted here

Prior to installation, customers are strongly encouraged to familiarize themselves with the documentation provided by the operating system vendors:

For more specific software installation details, you may also refer to the HPE Superdome Flex Server Software Installation and Configuration Guide available under  https://support.hpe.com/hpesc/public/home/documentHome?sp4ts.oid=1010323142.

SUPERSEDES:
Version: 1.0

PRODUCT MODEL(S):
HPE Superdome Flex server

OPERATING SYSTEMS:

  • Red Hat Enterprise Linux 7.3, 7.4
  • SUSE Linux Enterprise Server 12 SP2, 12 SP3
  • Oracle Linux UEK (Unbreakable Enterprise Kernel) 4 update 5

LANGUAGES:
International English

COMPATIBILITY/INTEROPERABILITY:
HPE recommends running with the latest HFS and firmware available versions.

KNOWN ISSUES:

  • DCD does not provide the Serial Number of the Intel C600/X79 SATA RAID Controller (Base IO) in its system inventory data. This is a known behavior.
  • Systems with a large number of I/O cards may experience out of memory or interrupt enablement issues during kdump. See advisory at this link for details.

DISCLAIMER:
The information in this document is subject to change without notice.

Hewlett Packard Enterprise makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Hewlett Packard Enterprise shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

This document contains proprietary information that is protected by copyright. All rights are reserved. No part of this document may be reproduced, photocopied, or translated to another language without the prior written consent of Hewlett Packard Enterprise Company.

(C) Copyright 2017-2018 Hewlett Packard Enterprise Development Company, L.P.

FEEDBACK
As we are continuing to improve the firmware management process we welcome your feedback on this document and on the firmware update process.
TEAM-FWupdateFeedback@groups.ext.hpe.com

Revision History

Version:2.4 (1 Dec 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.4:

  • Fix cache_topology_info on hubless
    • Properly handle caching of topology information on hubless systems.

DCD 3.1-2.0

  • Fixed an issue where the CapacityBytes attribute was being reported incorrectly for NVMe controllers in the system inventory data.

  • Fixed an issue where the CapacityBytesDetected attribute for NVMe controllers was being reported in blocks instead of bytes in the system inventory data.

  • Fixed an issue where the VolumeType attribute for a RAID 10 logical drive (managed by MegaRAID 9361-4i controller) was being reported as empty string (instead of "RAID10").

  • Fixed handling of RAID volume consistency check related events for MegaRAID 9361-4i controller so that they are reported correctly to RMC.

Enhancements

HFS 2.4:

  • Added support for HPE Superdome Flex 280 systems (Intel Xeon® Scalable processors 83XX/63XX/53XX)
  • Add CPU_FREQ_DRIVER
    • Add new sysconfig variable CPU_FREQ_DRIVER and associated scriplet 14_cpufreq.sh.  Users can select a CPU frequency driver to use, and hpe-auto-config will disable/blacklist any other CPU frequency drivers.
      Currently, the choices are intel_pstate and acpi_cpufreq. 
      CPU_FREQ_DRIVER defaults to "" and results in no configuration.
       
  • Add geoid nic names for hubless systems
    • The format of "topology --networks --noheader" output changes from 5-column to 3-column on hubless systems.
    • This, and the assumption that a nic port would be determined by its PCI function, causes non-working geoid nic names on HPE Superdome Flex 280 servers.
    • Re-implement geoid based on the assumption that a nic port is determined by its order of appearance.
    • Add option UV_GEOID_NIC_SHORT_NAMES with comment on the changed hardware geoid naming scheme.
       
  • Update hwperf build for UEK6
    • Update hwperf to build with with UEK6.
       
  • Add support for RHEL 8.3.
  • December 2020 update:
    • Added Intel microcode issue under "Known Issues"

DCD 3.1-2.0:

  • Added support for HPE Superdome Flex 280 servers

  • Added support to report the Manufacturer attribute for all resource types in the system inventory data.

  • Added support to inventory the following GPU:

    1) HPE NVIDIA Tesla V100S PCIe 32GB

  • Added support to report RAID battery related events in CAE for MegaRAID SAS 9361-4i controller.

  • Updated part number table for new SSD drives.

  • Updated StorageCore API to version 4.20.11.0 (SR 2.5.2.2 release).


Version:2.3.2(a) (3 Dec 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers  
Enhancements

HFS 2.3.2(a):

  • Added support for RHEL 8.3 on systems with Intel Xeon® Scalable processors 82XX/62XX
  • December 2020 update:
    • Added Intel microcode issue under "Known Issues"

HFS 2.3.2:

  • Added support for RHEL 7.9
  • Added support for RHEL 8.2 and OL 8.1 on systems with Intel Xeon® Scalable processors 81XX/61XX

Version:2.3.2 (26 Oct 2020)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers  
Enhancements

HFS 2.3.2:

  • Added support for RHEL 7.9
  • Added support for RHEL 8.2 and OL 8.1 on systems with Intel Xeon® Scalable processors 81XX/61XX

Version:2.3.1(a) (25 Sep 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3.1:

  • On systems running with RHEL 8.x (8.0, 8.1, 8.2), if BLS is disabled via setting GRUB_ENABLE_BLSCFG=false in /etc/default/grub, and grub2-mkconfig  rebuilds /boot/efi/EFI/redhat/grub.cfg, the kernel command line in the new grub.cfg is now recognized by HFS as HFS now accepts commands that start with either linux or linuxefi.
  • Restarting rsyslog no longer re-runs hpe-auto-config 
  • HFS now remove numa=off from the bootline if it had been added during an OS installation

DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers
Enhancements

HFS 2.3.1(a):

  • September 2020 update:
    • Added support for SPES 15 SP2

DCD 2.3-0-3:

  • Added support to detect and generate an event on state change for Microchip SmartRAID 3162-8i /e storage controllers, physical drives and RAID volumes

Version:2.3.1 (29 Jun 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3.1:

  • On systems running with RHEL 8.x (8.0, 8.1, 8.2), if BLS is disabled via setting GRUB_ENABLE_BLSCFG=false in /etc/default/grub, and grub2-mkconfig  rebuilds /boot/efi/EFI/redhat/grub.cfg, the kernel command line in the new grub.cfg is now recognized by HFS as HFS now accepts commands that start with either linux or linuxefi.
  • Restarting rsyslog no longer re-runs hpe-auto-config 
  • HFS now remove numa=off from the bootline if it had been added during an OS installation

DCD 2.3-0-3:

  • Fixed the issue of DCD_OS_LAST_SHUTDOWN_CRITICAL event being logged even for normal reboots on systems running a Linux operating system
  • Fixed the issue of "show chassis info" reporting missing disks as available in FRU inventory for Smart RAID Controllers
Enhancements

DCD 2.3-0-3:

  • Added support to detect and generate an event on state change for Microchip SmartRAID 3162-8i /e storage controllers, physical drives and RAID volumes

Version:2.3(a) (11 Jun 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3:

  • kdump:
    • Addressed errors such as "crashkernel reservation failed - memory in use" by choosing the appropriate crashkernel= method for the running kernel.
  • Memlog:
    • Addressed memlog errors such as “ERROR SEGV detected. Obtained 8 stack frames” seen with RHEL 7.3.
  • Hwperf:
    • Fixed an issue where topology command would abort stating that it encountered unknown devices. The command now prints the error without aborting. 
       

DCD 2.3-0.1:

  • No changes
Enhancements

HFS 2.3:

  • Added support for RHEL 7.8
  • June 2020 update:
    • Added support for RHEL 8.2; RHEL 8.2 bits were added to bundle 2.3(A)
    • Added support for OL 7.8, 8.1 and for OL 7.8 & OL 8.1 with UEK6 on systems with 62xx/82xx processors

DCD 2.3-0.1:

  • Pre-enabled support for new Samsung PM1733/1735 NVMe cards:
    • HPE 1.6TB PCIe x8 MU HH DS Card (1.6 TB)
    • HPE 3.2TB PCIe x8 MU HH DS Card (3.2 TB)
    • HPE 6.4TB PCIe x8 MU HH DS Card (6.4 TB)
  • Updated part number table for new SSD drives

Version:2.3 (12 May 2020)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.3:

  • kdump:
    • Addressed errors such as "crashkernel reservation failed - memory in use" by choosing the appropriate crashkernel= method for the running kernel.
  • Memlog:
    • Addressed memlog errors such as “ERROR SEGV detected. Obtained 8 stack frames” seen with RHEL 7.3.
  • Hwperf:
    • Fixed an issue where topology command would abort stating that it encountered unknown devices. The command now prints the error without aborting. 
       

DCD 2.3-0.1:

  • No changes
Enhancements

HFS 2.3:

  • Added support for RHEL 7.8
     

DCD 2.3-0.1:

  • Pre-enabled support for new Samsung PM1733/1735 NVMe cards:
    • HPE 1.6TB PCIe x8 MU HH DS Card (1.6 TB)
    • HPE 3.2TB PCIe x8 MU HH DS Card (3.2 TB)
    • HPE 6.4TB PCIe x8 MU HH DS Card (6.4 TB)
  • Updated part number table for new SSD drives

Version:2.2 (4 Dec 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Fixes in HFS 2.2:

  • Fixed an issue where the system would stop writing to memlog after switching to a new log file due to memlog file being full

Fixes in DCD 2.2-0.5:

  • Fixed issue with hpe-dcd rpm package incorrectly owning directory /opt/hpe.
  • Fixed a memory leak in Ethernet events handling support that occurs when there is sudden burst of Ethernet events
  • Fixed an issue in the Ethernet support functionality which was rarely causing DCD service stop process to take time (order of few minutes)
  • Fixed an issue where Intel SATA RAID controller’s Protocol was being reported as "SAS/SATA" instead of "SATA" in system inventory data
Enhancements

January 2020: Added a Known Issue for a panic occurring with SLES 15 SP1 update (4.12.14-197.29.1)

Enhancements in HFS 2.2:

  • Added support for RHEL 8.1, SLES 12 SP5

Enhancements in DCD 2.2-0.5:

  • Added support to inventory the following GPU cards:

1) NVIDIA Quadro RTX 8000

  • "Oem.Slot" JSON attribute type has been changed from an integer to a string for all physical drives attached to SAS/SATA storage controllers.
  • Added support to provide PartNumber values for the Infiniband cards which are represented as Ethernet cards in the Inventory.

Version:2.1 (3 Sep 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS 2.1:

- hpe-auto-config:

  • i40iw driver is blacklisted due to RDMA/iWARP being unsupported on the LOM device 

- hwperf:

  • An explicit dependency for pciutils was added at install time (needed by the topology command for lspci)

DCD 2.1-1:

  • Fixed the issue of DCD IPv4Addresses field not being Redfish-compliant when no IPv4 address is configured on the managed server.
  • Fixed the issue of Protocol being shown as “ATA” (instead of “SATA”) for physical drives attached to Intel SATA RAID controller in the drive online (DCD_DRIVE_OK) event.
  • Fixed the issue of “request sense failed” message being repeated logged in Linux syslog (/var/log/messages) on SLES 12 SP3, when the DCD-requested Device Statistics log page is not supported by the physical drive attached to Intel SATA RAID controller.
  • Fixed issue of RAID10 logical volume (configured on LSI MegaRAID 9361-4i) incorrectly showing volume type as “RAID01” in the inventory string.
  • Fixed issues in DCD service configuration file that was causing systemd (version 232 or higher) to report error messages related to service start rate limiting parameters.
Enhancements

HFS 2.1:

- hpe-auto-config:

  • Do not overwrite the elevator boot parameter value on the kernel cmdline if it is already set in the hpe-auto-config file.
  • Changed CPU idle governor default setting from ‘ladder’ to ‘menu’ to prevent health_check to report a failure

- gr_stats:

  • Fixed an issue where gr_systat would not get an accurate count of traffic volume.

- memlog: 

  • Addressed an issue where memlog output would be garbled  

DCD 2.1-1:

  • Added support to inventory and monitor the following Samsung PM1725B NVMe cards:
    • HPE 6.4TB NVMe x8 MU HH DS Card
    • HPE 3.2TB NVMe x8 MU HH DS Card
    • HPE 1.6TB NVMe x8 MU HH DS Card
  • Added support to inventory the following GPU cards:
    • NVIDIA Quadro RTX 6000
    • AMD Radeon Instinct MI60
  • Added support to inventory Microchip SmartRAID 3154-8e and 3162-8i /e storage controllers.
  • Added PartNumber field for LSI MegaRAID 9361-4i, Intel SATA RAID, and NVIDIA GPU controllers in DCD Inventory JSON.
  • Modified PartNumber field in DCD Inventory JSON for physical disk drives and Fibre Channel controllers to use the Spare Part Number.
  • Updated part number information reported for specific models of HPE Ethernet adapters.

Version:1.6 (14 Jun 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

Note: This is the initial release for systems with with Intel Xeon® Scalable processors 82XX / 62XX.


Hpe-auto-config:

  • i40iw driver is blacklisted due to RDMA/iWARP being unsupported on the LOM device 

Hwperf:

  • An explicit dependency for pciutils was added at install time (needed by the topology command for lspci)
Enhancements

Hpe-auto-config:

  • Newer kernel versions support the newer EFI mapping.  hpe-auto-config looks to see if the kernel supports newer EFI mapping and removes efi=old_map if it does.
  • sap-hana: If HPE_CONFIG_PROFILE=HANA, TCP tunings defined in the following files will be applied by hpe-auto-config :
    • /etc/saptune/extra/HPE-Recommended_OS_settings.conf (SUSE)
    • /etc/tuned/sap-hpe-hana/tuned.conf (RHEL)
  • Added verbose and dry-run functionality to hpe-auto-config:
    • –n (--dry-run): performs all processing but does not edit bootloader_config
    • –v (--verbose): includes additional output in /var/log/hpe-auto-config.log  

Version:1.5 (25 Mar 2019)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.


Critical:

  • Fixed an issue where hpe_irqbalance would stop running due to some recent IO driver versions returning an unexpected error when trying to set/change an IRQ CPU affinity. As a result, IRQ affinity is not being set on subsequent devices.

Memlog:

  • Fixed an issue where memlogd would return a message like "NOTICE error obtaining Dram DDR4 code, row 12 col a width 4" due to missing a rank address map for 128G DIMMs.
  • Fixed an issue where memlogd would sometimes point to the wrong DIMM in case of DIMM failures.

Hwperf:

  • Fixed an issue with Oracle Linux 7.6 UEK5 kernel 4.14.35-1906 where "rmmod hwperf" would get stuck on spinlock
  • Fixed an issue with Oracle Linux 7.6 UEK5 kernel 4.14.35-1844.2.5 where hwperf would display "unknown symbol uv_hwperf_exit"
  • Fixed a spinlock issue where hwperf would go to sleep after taking the spinlock
  • Made changes so the Time Stamp Counter (TSC), important for database apps, works correctly with Oracle Linux 7.6 UEK5 update2 (4.14.35-1844.2.5.el7uek)

Hpe-auto-config:

  • Correctly locate grub.cfg with CentOS

Sdstats:

  • Changed the channel utilization computation to (Avg MiB/s) / (Max Channel MiB/s) and display label as MiB  

Version:1.4 (4 Feb 2019)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Addressed a startup message similar to “SL_GetDimmConfig: Unable to mmap pci space for socket 0 chan 0”, causing memlog to incorreclty decode DIMM information
  • Addressed a startup error message "mmap smbios: Resource temporarily unavailable"
  • Fixed an issue during shutdown where /boot would be unmounted before hpe-auto-config completes, leading to this error being displayed: “sgiconfig: /boot/efi is not mounted as vfat. Grub2 config cannot be updated”
  • DMI (Desktop Management Interface) device locator string is now correctly recognized with newer BIOS versions
  • Ensure that hpe-auto-config uses the proper grub.cfg file on SLES with EFI
  • Compensate for computation time in hubstats interval so interval is as expected
Enhancements

  • Added support for RHEL 7.6 and SLES 12 SP4.

Note: RHEL 7.3 and SLES 12 SP2 are not supported by HFS version 1.4; please use a prior HFS version to run with older OS’es.

 


Version:1.3(A) (27 Nov 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


HFS Bundle 1.3:

  • Addresses an issue seen with SLES15 and RHEL 7.5, where the system would hang during shutdown with an “NMI watchdog: BUG: soft lockup” error.  
  • Starting with HFS version 1.3, it is supported to run Linux on a system with Secure Boot enabled.
  • On all SUSE versions as well as RHEL 7.3 and lower, added nohz=off on the Linux boot line to avoid holdoffs in tickless code, which may cause unpredictable behavior. Also because nohz=off, skew_tick=1 is added to avoid timer tick contention.

HFS Bundle 1.3(A):

  • Addresses an issue seen with HFS version 1.3 where memlog would incorreclty decode DIMM information, potentially resulting in higher CPU usage at boot time and slower boot.
  • January 2019: changed the link to the DCD release notes to point to the release notes for DCD version 1.3.  
Enhancements

  • Added support for SLES 15.
  • Some extended tuning scripts are now managed via a sysconfig variable (disabled by default). The script 20_sap_hana.sh is run when adding HPE_CONFIG_PROFILE=HANA to sysconfig.
  • Implemented NIC naming based on physical location (e.g. chassis, rack unit, slot like 'r001i06s02p0'), allowing to directly identify the network card location in a multiple chassis setup. To activate the new naming, set UV_GEOID_NIC_NAMES to “yes” in /etc/sysconfig/hpe-auto-config, then run hpe-auto-config and reboot. Note: This feature requires distros with systemd, implemented with SLES 12 (or later) and RHEL 7 (or later).

Version:1.2.2 (28 Sep 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • When running sdstats on a heavily loaded system, sdstats now only prints once per node the message "hwperf: WARNING: dashboard db_<node> is unresponsive", to indicate possible slow performance of system performance tools such as hubstats.
  • Fixed an issue where hpe_irqbalance wouldfail/exit, after running for a number of days, with error "Too many open files".
  • sdstats related fixes:
    • Min latency stats are now enabled by default
    • hubstats now ends its collection gracefully when terminated with Ctrl-C
    • Fixed values calculation in the dashboard map file and metrics
    • Fixed an issue where the header was printing twice with sdstats gruMemTraffic option
    • sdstats now correctly computes the minimum and maximum latency statistics

Version:1.21(a) (21 Aug 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • HFS version 1.2.1.1 (bundle 1.21(a)) fixes a signing issue on bits inside HFS 1.2.1 (bundle 1.21), which prevented their successful installation. 

Note: HFS version 1.2.1 is being removed from HPE Support Center. It fixed the following (also fixed in HFS version 1.2.1.1):

  • Added support for two or more MegaRAID 9361-4i controllers per partition.
  • Integrated with newer version of storelib (07.0309.0100.0700)
  • Fixed an issue of segmentation fault that may occur when the DCD service is stopped.
  • Fixed issue of DCD events not being generated if the inventory-refresh happens at a time when a stream of events from MegaRAID 9361-4i are being processed by DCD.

  • Fixed issue of missing inventory in DCD JSON string on a partition where it takes DCD a long time (several minutes or more) to inventory the partition’s hardware configuration.

 


Version:1.21 (9 Aug 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


REMOVED – This version is no longer available for download due to a signing issue preventing to install the bits. For more information, click “Obtain software” to display the advisory.

HFS version 1.2.1 includes DCD version 1.2-6 which contains the following changes:

  • Added support for two or more MegaRAID 9361-4i controllers per partition.
  • Integrated with newer version of storelib (07.0309.0100.0700)
  • Fixed an issue of segmentation fault that may occur when the DCD service is stopped.
  • Fixed issue of DCD events not being generated if the inventory-refresh happens at a time when a stream of events from MegaRAID 9361-4i are being processed by DCD.

  • Fixed issue of missing inventory in DCD JSON string on a partition where it takes DCD a long time (several minutes or more) to inventory the partition’s hardware configuration.


Version:1.02 (2 Aug 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Add retpoline fixes to address Speculative Store Bypass or Variant 4 (CVE-2018-3639) vulnerability
  • Fixed issue with latency stats enablement
  • Failing DIMM slot is now correctly identified
  • Fixed a kdump kernel boot issue on SLES 12 SP2 or SP3
  • Improved IO device descriptions
  • New message generated when device description is missing from pci.id database, recommending to run update-pciids
  • Memlog: nfit driver is no longer blacklisted
  • Disable ERST (Error Record Serialization Table) on RHEL 7 to prevent crashes at boot
Enhancements

  • Add support for RHEL 7.5
  • Uvstats renamed sdstats, add live mode and latency statistics configuration
  • Memlog: improved error reporting

Version:1.01 (16 Mar 2018)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

HPE recommends running with the latest available version.


  • Fix for unloading the ipmi_si kernel module
  • Update-PCI-Ids reports missing devices instead of trying to access the network to find them
  • Fixed issues with hpe-auto-config
Enhancements

  • Support of systems up to 32 sockets and 24 TB memory
  • The uvstats library and its applications, linkstat and hubstats, are now supported on Superdome Flex

Version:1.00 (20 Dec 2017)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.

N/A - Initial Release


N/A - Initial Release


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.