Printable version

Drivers & software

HPE Library and Tape Tools

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Application
Version: 4.29(3 Jun 2019)
Operating System(s): OS Independent
Multi-part download
File name: hpe_ltt429_linux_x86.tar (73 MB)
File name: hpe_ltt429_linux_x86_64.tar (72 MB)
File name: hpe_ltt429_win.exe (72 MB)
HPE Library and Tape Tools is a collection of storage hardware management and diagnostic tools for tape mechanisms and tape automation products. HPE Library and Tape Tools assembles these tools into a single, convenient program.

End User License Agreements:
HPE Software License Agreement v1


HPE Library and Tape Tools 4.29 Release Notes

 

Part Number: P11450-003a

Published: June 2019

Edition: 2

© Copyright 2019 Hewlett Packard Enterprise Development LP

Notices

The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein.

Confidential computer software. Valid license from Hewlett Packard Enterprise required for possession, use, or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Links to third-party websites take you outside the Hewlett Packard Enterprise website. Hewlett Packard Enterprise has no control over and is not responsible for information outside the Hewlett Packard Enterprise website.

Description

This release includes an updated version of HPE Library and Tape Tools (L&TT).

Version

4.29

Update recommendation

Recommended.

Supersedes

All earlier versions of L&TT for the supported Operating Systems.

Devices supported

  • Tape drives - same as L&TT 4.28.

  • Tape libraries - same as L&TT 4.28.

For more information on a full list of supported devices, see the L&TT User Guide.

Languages

English

Operating systems

L&TT operating system support

Operating system

OS variant

Supported version of L&TT

Windows

Windows Server 2019

Windows Server 2016

Windows Server 2012 & 2012 R2

Windows Server 2008 SP2 & R2 SP1 (64-bit)

Windows 10 (64-bit)

Windows 8 / 8.1 (32-bit, 64-bit)

Windows 7 SP1 (32-bit, 64-bit)

L&TT 4.29

Linux

Red Hat Enterprise Linux 7.x

Red Hat Enterprise Linux 6.x

SUSE Linux Enterprise Server 11

L&TT 4.29

HP-UX

HP-UX 11i v3 (PA-RISC, IPF)

HP-UX 11i v2 (PA-RISC, IPF)

HP-UX 11i (PA-RISC)

L&TT 4.28

L&TT 4.28

L&TT 4.26

Solaris

Oracle Solaris 10 Update 9 (x86, SPARC, AMD64)

L&TT 4.28

Mac

MAC 10.7 to 10.14 (Intel) - Standalone drives only

L&TT 4.28

OpenVMS OpenVMS 8.4 (IPF)

L&TT 4.28

Enhancements and fixes in L&TT 4.29

Enhancements:

  • Always runs as Administrator to ensure you can always open support tickets.

Maintenance:

  • Updated support ticket decoding.

Fixes:

  • Minor bug fixes and improvements.

Limitations in L&TT 4.29

NOTE: L&TT 4.29 version only supports Windows and Linux Operating System. For more information, see Operating systems

Known issues and workarounds in L&TT 4.29

Webhelp not accessible

Symptom

Error Message: "You must enable javascript in order to view this page" is seen when clicking on Help .

Action

  1. To access the webhelp you must allow active content on your local drive. Open Internet Browser.
  2. Click Tools > Internet Options.
  3. Click Advance tab and select Allow active content to run in files on my Computer option.
  4. Click Apply.
  5. Click the Help on L&TT application to access the webhelp content.

Media Assessment Full Tape Test fails

Symptom

If you run the LTO Media Assessment Full Tape Test (only available for LTO 1 to 6) it will fail. This is a known issue that will be addressed in a future release.

Failure error message:

Windows: "LTTScript: script aborted (Error: Perl Script Error)"

Linux: "LTT Script Error: For more details please see 'prl.txt' file in 'logs' dir in installed directory"

Action

Use the LTO Media Assessment Tape test as an alternative test.

Prerequisites

  • Windows

    • Device drivers for the connected tape devices/libraries or default device driver must be present.

  • Linux

    • proc/SCSI subsystem must recognize the device .

    • The device driver for connected tape drives and libraries or the default device driver must be present.

Installation instructions

Download L&TT from HPE Library Tape and Tools.

For installation instructions for all supported Operating Systems, see L&TT User Guide.


Version:4.29 (3 Jun 2019)
Version:4.28 (2) (25 Jun 2019)
Version:4.27 (1 Oct 2018)
Version:4.26(1) (1 Jun 2018)
Type: Application
Version: 4.29(3 Jun 2019)
Operating System(s):
OS Independent

Description

HPE Library and Tape Tools is a collection of storage hardware management and diagnostic tools for tape mechanisms and tape automation products. HPE Library and Tape Tools assembles these tools into a single, convenient program.

Release Notes

End User License Agreements:
HPE Software License Agreement v1


HPE Library and Tape Tools 4.29 Release Notes

 

Part Number: P11450-003a

Published: June 2019

Edition: 2

© Copyright 2019 Hewlett Packard Enterprise Development LP

Notices

The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein.

Confidential computer software. Valid license from Hewlett Packard Enterprise required for possession, use, or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Links to third-party websites take you outside the Hewlett Packard Enterprise website. Hewlett Packard Enterprise has no control over and is not responsible for information outside the Hewlett Packard Enterprise website.

Description

This release includes an updated version of HPE Library and Tape Tools (L&TT).

Version

4.29

Update recommendation

Recommended.

Supersedes

All earlier versions of L&TT for the supported Operating Systems.

Devices supported

  • Tape drives - same as L&TT 4.28.

  • Tape libraries - same as L&TT 4.28.

For more information on a full list of supported devices, see the L&TT User Guide.

Languages

English

Operating systems

L&TT operating system support

Operating system

OS variant

Supported version of L&TT

Windows

Windows Server 2019

Windows Server 2016

Windows Server 2012 & 2012 R2

Windows Server 2008 SP2 & R2 SP1 (64-bit)

Windows 10 (64-bit)

Windows 8 / 8.1 (32-bit, 64-bit)

Windows 7 SP1 (32-bit, 64-bit)

L&TT 4.29

Linux

Red Hat Enterprise Linux 7.x

Red Hat Enterprise Linux 6.x

SUSE Linux Enterprise Server 11

L&TT 4.29

HP-UX

HP-UX 11i v3 (PA-RISC, IPF)

HP-UX 11i v2 (PA-RISC, IPF)

HP-UX 11i (PA-RISC)

L&TT 4.28

L&TT 4.28

L&TT 4.26

Solaris

Oracle Solaris 10 Update 9 (x86, SPARC, AMD64)

L&TT 4.28

Mac

MAC 10.7 to 10.14 (Intel) - Standalone drives only

L&TT 4.28

OpenVMS OpenVMS 8.4 (IPF)

L&TT 4.28

Enhancements and fixes in L&TT 4.29

Enhancements:

  • Always runs as Administrator to ensure you can always open support tickets.

Maintenance:

  • Updated support ticket decoding.

Fixes:

  • Minor bug fixes and improvements.

Limitations in L&TT 4.29

NOTE: L&TT 4.29 version only supports Windows and Linux Operating System. For more information, see Operating systems

Known issues and workarounds in L&TT 4.29

Webhelp not accessible

Symptom

Error Message: "You must enable javascript in order to view this page" is seen when clicking on Help .

Action

  1. To access the webhelp you must allow active content on your local drive. Open Internet Browser.
  2. Click Tools > Internet Options.
  3. Click Advance tab and select Allow active content to run in files on my Computer option.
  4. Click Apply.
  5. Click the Help on L&TT application to access the webhelp content.

Media Assessment Full Tape Test fails

Symptom

If you run the LTO Media Assessment Full Tape Test (only available for LTO 1 to 6) it will fail. This is a known issue that will be addressed in a future release.

Failure error message:

Windows: "LTTScript: script aborted (Error: Perl Script Error)"

Linux: "LTT Script Error: For more details please see 'prl.txt' file in 'logs' dir in installed directory"

Action

Use the LTO Media Assessment Tape test as an alternative test.

Prerequisites

  • Windows

    • Device drivers for the connected tape devices/libraries or default device driver must be present.

  • Linux

    • proc/SCSI subsystem must recognize the device .

    • The device driver for connected tape drives and libraries or the default device driver must be present.

Installation instructions

Download L&TT from HPE Library Tape and Tools.

For installation instructions for all supported Operating Systems, see L&TT User Guide.


Revision History

Version:4.29 (3 Jun 2019)
Version:4.28 (2) (25 Jun 2019)
Version:4.27 (1 Oct 2018)
Version:4.26(1) (1 Jun 2018)

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.