Printable version

Drivers & software

* RECOMMENDED * HP QLogic Online Firmware Upgrade Utility for Linux i386

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Firmware - Network
Version: 5.0.0(4 Jun 2012)
Operating System(s): Red Hat Enterprise Linux 5 Server (x86)
Red Hat Enterprise Linux 6 Server (x86)
SUSE Linux Enterprise Server 10 (x86)
SUSE Linux Enterprise Server 11 (x86)
Multi-part download
File name: CP017665.scexe (4.3 MB)
File name: CP017665.txt (5.4 KB)
This package contains the utilities and binaries for upgrading HP ProLiant QLogic P2 and P3 10 Gigabit Ethernet NICs ROM images running under Linux i386 platform.

Prerequisites:

This package version can be used to upgrade firmware versioned:

  • 3.4.336 and later for the NC510C and NC510F network adapters
  • 4.0.230 and later for all other supported network adapters

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

c6865990ce425cd76df5d472f858db03b93b41fef4d49262268db630303d8e30 CP017665.scexe
8cd193b166461e5b212784823d9d634711ca26a7d39b5b072eb22353019aa7eb CP017665.txt

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Notes:

This software package contains the following firmware versions:

NIC ROM Version Firmware File
HP NC510F PCIe 10 Gigabit Server Adapter 3.4.339 xfp_hp_romimage
HP NC510C PCIe 10 Gigabit Server Adapter 3.4.339 cx4_hp_romimage
HP NC522m Dual Port 10GbE Multifunction BL-c Adapter 4.0.585 phantom_romimage
HP NC522SFP Dual Port 10GbE Server Adapter 4.0.585 phantom_romimage
HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter 4.0.585 phantom_romimage
HP NC375i 1G w/NC524SFP 10G Module 4.0.585 phantom_romimage
HP NC375T PCI Express Quad Port Gigabit Server Adapter 4.0.585 phantom_romimage

Supported Devices and Features:

This software supports the following HP QLogic P2 network adapters:

  • HP NC510F PCIe 10 Gigabit Serve Adapter
  • HP NC510C PCIe 10 Gigabit Serve Adapter

This software supports the following HP QLogic P3 network adapters:

  • HP NC522m Dual Port 10GbE Multifunction BL-c Adapter
  • HP NC522SFP Dual Port 10GbE Server Adapter
  • HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter
  • HP NC375i 1G w/NC524SFP 10G Module
  • HP NC375T PCI Express Quad Port Gigabit Server Adapter

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This component utility now provides enhanced reliability for the firmware.

Version:5.6.10 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports Red Hat Enterprise Linux 6 Update 7.

This product now supports SUSE LINUX Enterprise Server 11 SP4.


Version:5.6.8 (15 Jun 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses a kernel panic seen while the firmware is being updated on a system running a Red Hat Enterprise Linux OS.


Version:5.6.3 (30 Mar 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The firmware in this product addresses an incorrect update of the Large Receive Offload (LRO) mask.

Enhancements

This product now supports Red Hat Enterprise Linux 6 Update 6.


Version:5.5.10 (9 Sep 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware no longer incorrectly updates the Large Receive Offload (LRO) mask for flow removal.


Version:5.4.6 (18 Feb 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The P3 firmware in this product corrects the reporting of checksum status for packets with TCP checksum errors while running in promiscuous mode.


Version:5.3.9 (10 Sep 2013)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This package now contains P3 firmware version 4.0.590.


Version:5.2.8 (19 Feb 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware version (4.0.590) addresses the following issues:

  • Link issues with Hitachi switch. AMCC errata implemented with extra pulse for Management Data Input/Output (MDIO) writes.
  • Internal loopback failure when link is down.


This component addresses an issue where the utility failed to determine that newer firmware was available for installation on the system.
 
This component now gracefully manages installation on a system that contains both devices that are supported and devices that are not supported by the component.
 
This software now provides a return code that correctly indicates whether or not a reboot is required to complete the firmware update process.
Enhancements

This component provides firmware version 4.0.590 for P3 devices.
 
This software now provides reboot, re-write, downgrade and version options.
 
The log file produced by this software now resides in /var/cpq and contains more information for better understanding of the results.


Version:5.1.2 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This package now supports Red Hat Enterprise Linux 6 Update 3.

This package now provides firmware version 4.0.588.


Version:5.0.0 (4 Jun 2012)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This component utility now provides enhanced reliability for the firmware.


Version:4.0.585 (4 Jun 2012)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software addresses an issue that prevented automatic installation on systems running Red Hat Enterprise Linux 4 with the NC375T PCI Express Quad Port Gigabit Server Adapter.

This firmware resolves an issue where the link status was not reported correctly for disconnected ports.

This firmware includes an update to gPXE that allows non-standard UDP source ports in Boot Service ACKs. This resolves an issue where the gPXE process would fail in some instances if the PXE Server software used unexpected UDP source port instead of the normal 67 or 4011.

This firmware resolves a "link flapping" or loss-of-connection issue seen with 7 meter or less Direct Attach Copper (DAC) cables used with the HP NC522SFP Dual Port 10GbE Server Adapter.

This software addresses an intermittent hang issue on an NC375i using ESXi 5.0 auto-deploy.

Enhancements

This software no longer requires that the HP QLogic nx_nic Driver for Linux be installed before firmware update.

This software now supports Red Hat Enterprise Linux 5 Update 8.
This software now supports Red Hat Enterprise Linux 6 Update 2.
This software now supports SUSE LINUX Enterprise Server 11 SP2.


Version:4.0.579 (11 Nov 2011)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


4.0.556 firmware includes the following changes:

  • Modified the NX3031 operating voltage and frequency to reduce the potential for a loss of link or a system hang.
  • Modified the firmware to take link down and display a message that half-duplex operation is not supported when half duplex operation is detected.
  • Fixed an issue where NX3031 NIC would not establish link after a server reboot.

4.0.579 firmware includes the following changes:
  • This firmware update corrects an issue with the HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter that may cause Pause Frames to overrun the network while the server is in standby mode.
  • Adds improved recovery for a potential issue that could cause a loss of link or a system hang.
  • Fixed an issue where the firmware upgrade utility incorrectly reported the firmware version.
  • Fixed a LiveUSB boot problem on the HP ProLiant DL585 G7.
Enhancements

This package contains firmware version 4.0.579 for QLogic P3 network adapters.


Version:4.0.556 (27 Jul 2011)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.

Failure to flash this firmware on P3 adapters may result in driver or firmware failures.

When updating firmware on P3 devices, this package requires HP NC-Series QLogic Driver for Linux version >= 4.0.540 and < 4.0.555 for installation. Driver version 4.0.555 must be installed after installing the firmware in this package. Using the P3 firmware in this package without driver version 4.0.555 or later is not a supported configuration.


This firmware resolves a hang seen on some P3 adapters.


Version:4.0.550 (6 May 2011)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now contains firmware versioned 4.0.550 for QLogic P3 devices.


Version:4.0.544 (24 Feb 2011)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports Red Hat Enterprise Linux 6.

This software contains an updated flash tool.


Version:4.0.539 (15 Dec 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware resolves an issue where the shared network port would disconnect the Integrated Remote Console on cold boot.

This firmware resolves an issue where WOL was not functioning.

Enhancements

This version of firmware contains updated gPXE code version 1.0.0 for NC-Series QLogic adapters.


Version:4.0.534 (6 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware resolves an issue where the IRC might hang if the shared network port is being used and VLANs are enabled in the operating system.

This firmware version resolves an issue on some systems where the connection to iLO would be lost during a reboot of the server if the shared network port was used.

Enhancements

This package contains the latest available firmware from QLogic.


Version:4.0.530 (21 Jul 2010)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This firmware version resolves an issue on the NC375T where the firmware initialization would fail because the phy did not initialize.

This software resolves an issue where the NC522SFP adapter was not properly initialized during system POST on some platforms.

This software contains updated PXE and resolves an issue where interrupts were not being generated.

Enhancements

This tool can now downgrade the firmware in silent mode when the “force” switch is used.

This software provides enhanced thermal reporting.


Version:4.0.520(B) (12 Mar 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component has been enhanced to work with HPSUM and is now supported on the FW Maintenance DVD.


Version:4.0.520 (8 Feb 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool now discovers and displays on a per/flash device basis instead of a per/port basis.

This package contains firmware versioned 4.0.520 for HP NC-Series QLogic nx3 devices.


Version:4.0.516 (10 Nov 2009)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Initial release.


Type: Firmware - Network
Version: 5.0.0(4 Jun 2012)
Operating System(s):
Red Hat Enterprise Linux 5 Server (x86)
Red Hat Enterprise Linux 6 Server (x86)
SUSE Linux Enterprise Server 10 (x86)
SUSE Linux Enterprise Server 11 (x86)

Description

This package contains the utilities and binaries for upgrading HP ProLiant QLogic P2 and P3 10 Gigabit Ethernet NICs ROM images running under Linux i386 platform.

Installation Instructions

Prerequisites:

This package version can be used to upgrade firmware versioned:

  • 3.4.336 and later for the NC510C and NC510F network adapters
  • 4.0.230 and later for all other supported network adapters

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

c6865990ce425cd76df5d472f858db03b93b41fef4d49262268db630303d8e30 CP017665.scexe
8cd193b166461e5b212784823d9d634711ca26a7d39b5b072eb22353019aa7eb CP017665.txt

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Release Notes

End User License Agreements:
Hewlett-Packard End User License Agreement


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Notes:

This software package contains the following firmware versions:

NIC ROM Version Firmware File
HP NC510F PCIe 10 Gigabit Server Adapter 3.4.339 xfp_hp_romimage
HP NC510C PCIe 10 Gigabit Server Adapter 3.4.339 cx4_hp_romimage
HP NC522m Dual Port 10GbE Multifunction BL-c Adapter 4.0.585 phantom_romimage
HP NC522SFP Dual Port 10GbE Server Adapter 4.0.585 phantom_romimage
HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter 4.0.585 phantom_romimage
HP NC375i 1G w/NC524SFP 10G Module 4.0.585 phantom_romimage
HP NC375T PCI Express Quad Port Gigabit Server Adapter 4.0.585 phantom_romimage

Supported Devices and Features:

This software supports the following HP QLogic P2 network adapters:

  • HP NC510F PCIe 10 Gigabit Serve Adapter
  • HP NC510C PCIe 10 Gigabit Serve Adapter

This software supports the following HP QLogic P3 network adapters:

  • HP NC522m Dual Port 10GbE Multifunction BL-c Adapter
  • HP NC522SFP Dual Port 10GbE Server Adapter
  • HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter
  • HP NC375i 1G w/NC524SFP 10G Module
  • HP NC375T PCI Express Quad Port Gigabit Server Adapter

Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This component utility now provides enhanced reliability for the firmware.

Revision History

Version:5.6.10 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product now supports Red Hat Enterprise Linux 6 Update 7.

This product now supports SUSE LINUX Enterprise Server 11 SP4.


Version:5.6.8 (15 Jun 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This product addresses a kernel panic seen while the firmware is being updated on a system running a Red Hat Enterprise Linux OS.


Version:5.6.3 (30 Mar 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The firmware in this product addresses an incorrect update of the Large Receive Offload (LRO) mask.

Enhancements

This product now supports Red Hat Enterprise Linux 6 Update 6.


Version:5.5.10 (9 Sep 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware no longer incorrectly updates the Large Receive Offload (LRO) mask for flow removal.


Version:5.4.6 (18 Feb 2014)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


The P3 firmware in this product corrects the reporting of checksum status for packets with TCP checksum errors while running in promiscuous mode.


Version:5.3.9 (10 Sep 2013)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This package now contains P3 firmware version 4.0.590.


Version:5.2.8 (19 Feb 2013)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware version (4.0.590) addresses the following issues:

  • Link issues with Hitachi switch. AMCC errata implemented with extra pulse for Management Data Input/Output (MDIO) writes.
  • Internal loopback failure when link is down.


This component addresses an issue where the utility failed to determine that newer firmware was available for installation on the system.
 
This component now gracefully manages installation on a system that contains both devices that are supported and devices that are not supported by the component.
 
This software now provides a return code that correctly indicates whether or not a reboot is required to complete the firmware update process.
Enhancements

This component provides firmware version 4.0.590 for P3 devices.
 
This software now provides reboot, re-write, downgrade and version options.
 
The log file produced by this software now resides in /var/cpq and contains more information for better understanding of the results.


Version:5.1.2 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This package now supports Red Hat Enterprise Linux 6 Update 3.

This package now provides firmware version 4.0.588.


Version:5.0.0 (4 Jun 2012)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This component utility now provides enhanced reliability for the firmware.


Version:4.0.585 (4 Jun 2012)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software addresses an issue that prevented automatic installation on systems running Red Hat Enterprise Linux 4 with the NC375T PCI Express Quad Port Gigabit Server Adapter.

This firmware resolves an issue where the link status was not reported correctly for disconnected ports.

This firmware includes an update to gPXE that allows non-standard UDP source ports in Boot Service ACKs. This resolves an issue where the gPXE process would fail in some instances if the PXE Server software used unexpected UDP source port instead of the normal 67 or 4011.

This firmware resolves a "link flapping" or loss-of-connection issue seen with 7 meter or less Direct Attach Copper (DAC) cables used with the HP NC522SFP Dual Port 10GbE Server Adapter.

This software addresses an intermittent hang issue on an NC375i using ESXi 5.0 auto-deploy.

Enhancements

This software no longer requires that the HP QLogic nx_nic Driver for Linux be installed before firmware update.

This software now supports Red Hat Enterprise Linux 5 Update 8.
This software now supports Red Hat Enterprise Linux 6 Update 2.
This software now supports SUSE LINUX Enterprise Server 11 SP2.


Version:4.0.579 (11 Nov 2011)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


4.0.556 firmware includes the following changes:

  • Modified the NX3031 operating voltage and frequency to reduce the potential for a loss of link or a system hang.
  • Modified the firmware to take link down and display a message that half-duplex operation is not supported when half duplex operation is detected.
  • Fixed an issue where NX3031 NIC would not establish link after a server reboot.

4.0.579 firmware includes the following changes:
  • This firmware update corrects an issue with the HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter that may cause Pause Frames to overrun the network while the server is in standby mode.
  • Adds improved recovery for a potential issue that could cause a loss of link or a system hang.
  • Fixed an issue where the firmware upgrade utility incorrectly reported the firmware version.
  • Fixed a LiveUSB boot problem on the HP ProLiant DL585 G7.
Enhancements

This package contains firmware version 4.0.579 for QLogic P3 network adapters.


Version:4.0.556 (27 Jul 2011)
Fixes

Upgrade Requirement:
Critical - HPE requires users update to this version immediately.

Failure to flash this firmware on P3 adapters may result in driver or firmware failures.

When updating firmware on P3 devices, this package requires HP NC-Series QLogic Driver for Linux version >= 4.0.540 and < 4.0.555 for installation. Driver version 4.0.555 must be installed after installing the firmware in this package. Using the P3 firmware in this package without driver version 4.0.555 or later is not a supported configuration.


This firmware resolves a hang seen on some P3 adapters.


Version:4.0.550 (6 May 2011)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now contains firmware versioned 4.0.550 for QLogic P3 devices.


Version:4.0.544 (24 Feb 2011)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This software now supports Red Hat Enterprise Linux 6.

This software contains an updated flash tool.


Version:4.0.539 (15 Dec 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware resolves an issue where the shared network port would disconnect the Integrated Remote Console on cold boot.

This firmware resolves an issue where WOL was not functioning.

Enhancements

This version of firmware contains updated gPXE code version 1.0.0 for NC-Series QLogic adapters.


Version:4.0.534 (6 Oct 2010)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This firmware resolves an issue where the IRC might hang if the shared network port is being used and VLANs are enabled in the operating system.

This firmware version resolves an issue on some systems where the connection to iLO would be lost during a reboot of the server if the shared network port was used.

Enhancements

This package contains the latest available firmware from QLogic.


Version:4.0.530 (21 Jul 2010)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This firmware version resolves an issue on the NC375T where the firmware initialization would fail because the phy did not initialize.

This software resolves an issue where the NC522SFP adapter was not properly initialized during system POST on some platforms.

This software contains updated PXE and resolves an issue where interrupts were not being generated.

Enhancements

This tool can now downgrade the firmware in silent mode when the “force” switch is used.

This software provides enhanced thermal reporting.


Version:4.0.520(B) (12 Mar 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This component has been enhanced to work with HPSUM and is now supported on the FW Maintenance DVD.


Version:4.0.520 (8 Feb 2010)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


This tool now discovers and displays on a per/flash device basis instead of a per/port basis.

This package contains firmware versioned 4.0.520 for HP NC-Series QLogic nx3 devices.


Version:4.0.516 (10 Nov 2009)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Initial release.


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.