Printable version

Drivers & software

* RECOMMENDED * HPE Dynamic Smart Array B120i/B320i SATA RAID Controller Driver for SUSE LINUX Enterprise Server 11 (x86)

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Driver - Storage Controller
Version: 1.2.16-100(15 Sep 2017)
Operating System(s):
SUSE Linux Enterprise Server 11 (x86)
Multi-part download
File name: hpvsa-kmp-default-1.2.16-100.sles11sp1.i586.rpm (659 KB)
File name: hpvsa-kmp-default-1.2.16-100.sles11sp2.i586.rpm (664 KB)
File name: hpvsa-kmp-default-1.2.16-100.sles11sp3.i586.rpm (664 KB)
File name: hpvsa-kmp-default-1.2.16-100.sles11sp4.i586.rpm (664 KB)
File name: hpvsa-kmp-pae-1.2.16-100.sles11sp1.i586.rpm (661 KB)
File name: hpvsa-kmp-pae-1.2.16-100.sles11sp2.i586.rpm (665 KB)
File name: hpvsa-kmp-pae-1.2.16-100.sles11sp3.i586.rpm (665 KB)
File name: hpvsa-kmp-pae-1.2.16-100.sles11sp4.i586.rpm (665 KB)
File name: hpvsa-kmp-xen-1.2.16-100.sles11sp1.i586.rpm (660 KB)
This RPM is used to provide binary driver modules that have been pre-built for SUSE Linux Enterprise Server 11 (x86) to enable the HPE Smart Array B120i/B320i SATA RAID controller.

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Improved Performance Levels.

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

4abb02f48a41e4f53441007c4fbeba4ef87f299a4ea17523ade86e2ec3a7dea9 hpvsa-kmp-default-1.2.16-100.sles11sp3.i586.rpm
788b6c49faf77381777b8cdf9e0502331c45b9a07fafe936ca9d69b2d8cf4325 hpvsa-kmp-default-1.2.16-100.sles11sp2.i586.rpm
9f4533e18877c9fffd9741d99b2ef302ae1fa3a3e0d0a57fad689111dc6e33a9 hpvsa-kmp-default-1.2.16-100.sles11sp1.i586.rpm
acf73193c5fcd984c7fdbbe1798e6ae8ddb6e52981add86d0cda42ef25f19cc8 hpvsa-kmp-pae-1.2.16-100.sles11sp2.i586.rpm
c6a00cec267c24381ec22d70b1fdab72a2a469bb5997268cd0343001e24887b9 hpvsa-kmp-pae-1.2.16-100.sles11sp3.i586.rpm
7cb1970427cce1d07811bea12e1768fac57c1951b6027c02deb0c193b52a7618 hpvsa-kmp-default-1.2.16-100.sles11sp4.i586.rpm
49c756de2dd9be64e3e6367248c871d4e948674963e572dfc2768f269a940e13 hpvsa-kmp-pae-1.2.16-100.sles11sp1.i586.rpm
01e08acc0a647ce30cf121009fa96b25b82dfbfa75ac0e7586e95b1e84eee233 hpvsa-kmp-pae-1.2.16-100.sles11sp4.i586.rpm
371cb50caf20d1ca288e7fbd41715b7b288e782264e0dd74d59b20e2be63208d hpvsa-kmp-xen-1.2.16-100.sles11sp1.i586.rpm

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Login as the system administrator (root), download the RPM to a directory on
your hard drive and change to that directory.

To install or upgrade the driver type:

# rpm -Uvh hpvsa-kmp-{kernel-flavor}-<version>.<OSupdate>.i686.rpm

Setup is now complete. Please REBOOT your computer NOW!!

NOTE: If the installation fails or if you see any warning or error messages, STOP, do NOT reboot the computer. The driver will not be operational and you must uninstall the driver by typing the following command:

# rpm -e hpvsa-kmp-{kernel-flavor}-<version>.<OSupdate>.i686.rpm

Enterprise Support
For support on Smart Array controllers, visit http://www.hpe.com/support


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Supported Devices and Features:

SUPPORTED KERNELS:
The kernels of SUSE LINUX Enterprise Server 11 (x86) supported by this binary rpm are:
2.6.32.12-0.7 - SUSE LINUX Enterprise Server 11 SP 1 (x86) and future errata kernels for SP 1.
3.0.13-0.27.1 - SUSE LINUX Enterprise Server 11 SP 2 (x86) and future errata kernels for SP 2.
3.0.76-0.11.1 - SUSE LINUX Enterprise Server 11 SP 3 (x86) and future errata kernels for SP 3.
3.0.101-63-default - SUSE LINUX Enterprise Server 11 SP 4 (x86) and future errata kernels for SP 4.


Version:1.2.16-100 (15 Sep 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Improved Performance Levels.


Version:1.2.14-110 (25 Nov 2015)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The following issues were resolved:

  • Intermittent blue screen 0x133 (DPS_WATCHDOG_VIOLATION) error would display and the system would stop responding. This error was caused by a race condition that was exposed under particular IO patterns for controllers with write cache enabled.
  • CPU pinning enabled- PARSE and FLUSH tasks are pinned to the same CPU to prevent a potential race condition in the driver which might result in an OS panic with system restart.

 


Version:1.2.14 (B) (26 Aug 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added support for SLES11SP4.


Version:1.2.14-100 (15 Jun 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes the below issue:

When issuing the "shutdown -h now" command at the Linux prompt, the server begins shutting down, but instead of halting and powering off, the server resets itself and boots back up.


Version:1.2.12 (30 Mar 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Spin lock update to fix a potential boot hang.

Version:1.2.10 (9 Sep 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.



Version:1.2.8-160 (12 Mar 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fix for CA referenced below titled “SPP HOT FIX - HP ProLiant Gen8 Servers - DRIVER UPGRADE REQUIRED to Avoid NMI in Linux on HP ProLiant Servers Under Heavy Load and Low Memory Configured with HP Dynamic Smart Array B120i / B320i Controllers Using the Optional FBWC”
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c04184273


Version:1.2.8-140 (18 Feb 2014)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added Optical drive support improvements.


Version:1.2.6-27 (10 Sep 2013)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Kernel panics no longer occur on systems which attempt to exceed virtual memory.

Enhancements

  • Updated driver to support new servers with increased CPU core count.
  • Added Support for SUSE LINUX Enterprise Server 11 SP3.

Version:1.2.6-26 (10 Sep 2013)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes to handle systems which attempt to exceed virtual memory.

Enhancements

Added Support for SUSE LINUX Enterprise Server 11 SP3.


Version:1.2.6-11a (11 Jun 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added support to HP ProLiant DL320e Gen8 v2 Server and HP ProLiant ML310e Gen8 v2 Server.


Version:1.2.6-11 (19 Feb 2013)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


RAIDstack cache fix.

Enhancements

General performance enhancement. Updates to /sysfs to provide better driver information.


Version:1.2.4-4 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Added support to take advantage of NUMA for increased performance.
  • Included sysfs attributes, to aid in the collection of data.

Version:1.2.2-3 (4 Jun 2012)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Initial release to support HP Smart Array B120i/B320i SATA RAID Controller.


Type: Driver - Storage Controller
Version: 1.2.16-100(15 Sep 2017)
Operating System(s):
SUSE Linux Enterprise Server 11 (x86)

Description

This RPM is used to provide binary driver modules that have been pre-built for SUSE Linux Enterprise Server 11 (x86) to enable the HPE Smart Array B120i/B320i SATA RAID controller.

Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Improved Performance Levels.

Installation Instructions

To ensure the integrity of your download, HPE recommends verifying your results with the following SHA-256 Checksum values:

4abb02f48a41e4f53441007c4fbeba4ef87f299a4ea17523ade86e2ec3a7dea9 hpvsa-kmp-default-1.2.16-100.sles11sp3.i586.rpm
788b6c49faf77381777b8cdf9e0502331c45b9a07fafe936ca9d69b2d8cf4325 hpvsa-kmp-default-1.2.16-100.sles11sp2.i586.rpm
9f4533e18877c9fffd9741d99b2ef302ae1fa3a3e0d0a57fad689111dc6e33a9 hpvsa-kmp-default-1.2.16-100.sles11sp1.i586.rpm
acf73193c5fcd984c7fdbbe1798e6ae8ddb6e52981add86d0cda42ef25f19cc8 hpvsa-kmp-pae-1.2.16-100.sles11sp2.i586.rpm
c6a00cec267c24381ec22d70b1fdab72a2a469bb5997268cd0343001e24887b9 hpvsa-kmp-pae-1.2.16-100.sles11sp3.i586.rpm
7cb1970427cce1d07811bea12e1768fac57c1951b6027c02deb0c193b52a7618 hpvsa-kmp-default-1.2.16-100.sles11sp4.i586.rpm
49c756de2dd9be64e3e6367248c871d4e948674963e572dfc2768f269a940e13 hpvsa-kmp-pae-1.2.16-100.sles11sp1.i586.rpm
01e08acc0a647ce30cf121009fa96b25b82dfbfa75ac0e7586e95b1e84eee233 hpvsa-kmp-pae-1.2.16-100.sles11sp4.i586.rpm
371cb50caf20d1ca288e7fbd41715b7b288e782264e0dd74d59b20e2be63208d hpvsa-kmp-xen-1.2.16-100.sles11sp1.i586.rpm

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Login as the system administrator (root), download the RPM to a directory on
your hard drive and change to that directory.

To install or upgrade the driver type:

# rpm -Uvh hpvsa-kmp-{kernel-flavor}-<version>.<OSupdate>.i686.rpm

Setup is now complete. Please REBOOT your computer NOW!!

NOTE: If the installation fails or if you see any warning or error messages, STOP, do NOT reboot the computer. The driver will not be operational and you must uninstall the driver by typing the following command:

# rpm -e hpvsa-kmp-{kernel-flavor}-<version>.<OSupdate>.i686.rpm

Enterprise Support
For support on Smart Array controllers, visit http://www.hpe.com/support


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Supported Devices and Features:

SUPPORTED KERNELS:
The kernels of SUSE LINUX Enterprise Server 11 (x86) supported by this binary rpm are:
2.6.32.12-0.7 - SUSE LINUX Enterprise Server 11 SP 1 (x86) and future errata kernels for SP 1.
3.0.13-0.27.1 - SUSE LINUX Enterprise Server 11 SP 2 (x86) and future errata kernels for SP 2.
3.0.76-0.11.1 - SUSE LINUX Enterprise Server 11 SP 3 (x86) and future errata kernels for SP 3.
3.0.101-63-default - SUSE LINUX Enterprise Server 11 SP 4 (x86) and future errata kernels for SP 4.


Revision History

Version:1.2.16-100 (15 Sep 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Improved Performance Levels.


Version:1.2.14-110 (25 Nov 2015)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


The following issues were resolved:

  • Intermittent blue screen 0x133 (DPS_WATCHDOG_VIOLATION) error would display and the system would stop responding. This error was caused by a race condition that was exposed under particular IO patterns for controllers with write cache enabled.
  • CPU pinning enabled- PARSE and FLUSH tasks are pinned to the same CPU to prevent a potential race condition in the driver which might result in an OS panic with system restart.

 


Version:1.2.14 (B) (26 Aug 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added support for SLES11SP4.


Version:1.2.14-100 (15 Jun 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes the below issue:

When issuing the "shutdown -h now" command at the Linux prompt, the server begins shutting down, but instead of halting and powering off, the server resets itself and boots back up.


Version:1.2.12 (30 Mar 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Spin lock update to fix a potential boot hang.

Version:1.2.10 (9 Sep 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.



Version:1.2.8-160 (12 Mar 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fix for CA referenced below titled “SPP HOT FIX - HP ProLiant Gen8 Servers - DRIVER UPGRADE REQUIRED to Avoid NMI in Linux on HP ProLiant Servers Under Heavy Load and Low Memory Configured with HP Dynamic Smart Array B120i / B320i Controllers Using the Optional FBWC”
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c04184273


Version:1.2.8-140 (18 Feb 2014)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added Optical drive support improvements.


Version:1.2.6-27 (10 Sep 2013)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Kernel panics no longer occur on systems which attempt to exceed virtual memory.

Enhancements

  • Updated driver to support new servers with increased CPU core count.
  • Added Support for SUSE LINUX Enterprise Server 11 SP3.

Version:1.2.6-26 (10 Sep 2013)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Fixes to handle systems which attempt to exceed virtual memory.

Enhancements

Added Support for SUSE LINUX Enterprise Server 11 SP3.


Version:1.2.6-11a (11 Jun 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Added support to HP ProLiant DL320e Gen8 v2 Server and HP ProLiant ML310e Gen8 v2 Server.


Version:1.2.6-11 (19 Feb 2013)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


RAIDstack cache fix.

Enhancements

General performance enhancement. Updates to /sysfs to provide better driver information.


Version:1.2.4-4 (4 Sep 2012)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • Added support to take advantage of NUMA for increased performance.
  • Included sysfs attributes, to aid in the collection of data.

Version:1.2.2-3 (4 Jun 2012)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Initial release to support HP Smart Array B120i/B320i SATA RAID Controller.


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.