Printable version

Drivers & software

* RECOMMENDED * HPE Fibre Channel Enablement Kit for Red Hat Enterprise Linux 7 Server - Emulex

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Software - Storage Controllers - FC HBA
Version: 10.7.110.34(1 Apr 2016)
Operating System(s):
Red Hat Enterprise Linux 7 Server
File name: HP-CNA-FC-Emulex-Enablement-Kit-10.7.110.34-1.rhel7.x86_64.rpm (572 KB)
This package contains utilities and libraries to enable HPE Storage fibre channel array connectivity on Red Hat Enterprise Linux 7 Server.

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 10.7.110.34-1

Added support for the following devices:

  • HPE FlexFabric 10Gb 2-port 556FLR-T Adapter
  • HPE StoreFabric CN1200E-T 10GBASE-T Converged Network Adapter

Prerequisites:
The target environment must have the libHBAAPI Package installed prior to the installation of the enablement kit. (If not already present, the libHBAAPI Package can be obtained from the operating system installation media.)


To ensure the integrity of your download, HPE recommends verifying your results with this MD5 Checksum value:

af00bc9129e692bd435afb565b85e94b HP-CNA-FC-Emulex-Enablement-Kit-10.7.110.34-1.rhel7.x86_64.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

There has been a change to the enablement kits in this release.  They are now vendor specific kits.   It is recommended that you uninstall any previous kits prior to installation of this component.

To uninstall the hp-fc-enablement RPM use the following command:

   # rpm -e hp-fc-enablement-<version>.noarch.rpm

To install the hp-fc-enablement RPM use the following command:

   # rpm -ivh HP-CNA-FC-Emulex-Enablement-Kit-<version>.<OS>.<architecture>.rpm

This version of the enablement kit does not provide the additional functionality of rebuilding the ram disk or setting driver parameters as the previous versions had done.  Please refer to the “Additional setup” section of the Native Linux Device-Mapper Multipath for HP StorageWorks Arrays reference guide for instructions on how to perform these functions.  The reference guide is available at the following link:
 
               http://www.hpe.com/storage/spock/
 


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Important:

Release Notes:
HPE StoreFabric Emulex Adapters Release Notes
 


Supported Devices and Features:

  • HP SN1000E 16Gb Dual Port Fibre Channel Host Bus Adapter
  • HP SN1000E 16Gb Single Port Fibre Channel Host Bus Adapter
  • HP 82E 8Gb Dual Port PCIe Fibre Channel Host Bus Adapter
  • HP 81E 8Gb Single Port PCIe Fibre Channel Host Bus Adapter
  • HP CN1100E Dual Port Converged Network Adapter
  • HP NC551i Dual Port FlexFabric 10Gb Network Adapter
  • HP NC553m 10Gb 2-port FlexFabric Converged Network Adapter
  • HP NC553i 10Gb 2-port FlexFabric Converged Network Adapter
  • HP FlexFabric 10Gb 2-port 554M Adapter
  • HP FlexFabric 10Gb 2-port 554FLR-SFP+ Adapter
  • HP FlexFabric 10Gb 2-port 554FLB Adapter
  • HP LPe1205A 8Gb Fibre Channel Host Bus Adapter for BladeSystem c-Class
  • Emulex LPe1205 8Gb Fibre Channel Host Bus Adapter for c-Class BladeSystem
  • HP SN1100E 16Gb Dual Port Fibre Channel Host Bus Adapter
  • HP SN1100E 16Gb Single Port Fibre Channel Host Bus Adapter
  • HP LPe1605 16Gb Fibre Channel Host Bus Adapter for BladeSystem c-Class
  • HP FlexFabric 20Gb 2-port 650FLB Adapter
  • HP FlexFabric 20Gb 2-port 650M Adapter
  • HP FlexFabric 10Gb 2-port 556FLR-SFP+ Adapter
  • HP StoreFabric CN1200E Dual Port Converged Network Adapter (FCoE)
  • HPE FlexFabric 10Gb 2-port 556FLR-T Adapter
  • HPE StoreFabric CN1200E-T 10GBASE-T Converged Network Adapter
  • HP StoreFabric 84E 4-Port Fibre Channel Host Bus Adapter

Version:12.0.346.16 (2 Apr 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 12.0.346.16

Added support for Red Hat Enterprise Linux 7 update 6 (RHEL 7.6).


Version:11.4.334.2 (26 Jun 2018)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support to Red Hat Enterprise Linux 7u5

Updated to version 11.4.334.2


Version:11.4.207.0 (5 Feb 2018)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 11.4.207.0


Version:11.2.307.3 (25 Sep 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 11.2.307.3

Added support for Rhel7u4


Version:11.2.254.6 (12 Jul 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 11.2.254.6


Version:11.1.183.22 (24 Oct 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This kit, version 11.1.183.22, adds support for the following devices:

  • HPE StoreFabric SN1200E 16Gb 2P FC HBA
  • HPE StoreFabric SN1200E 16Gb 1P FC HBA
  • HPE StoreFabric SN1600E 32Gb 2p FC HBA
  • HPE StoreFabric SN1600E 32Gb 1p FC HBA

Version:10.7.310.0 (24 Oct 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated enablement kit to version 10.7.310.0

Added HPE Smart SAN 1.0 support


Version:10.7.300.3 (17 Jun 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated  to version 10.7.300.3

Initial support for:

  • HPE StoreFabric SN1100E 4P 16Gb FC HBA
  • Smart SAN 1.0

 

 


Version:10.7.110.34 (1 Apr 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 10.7.110.34-1

Added support for the following devices:

  • HPE FlexFabric 10Gb 2-port 556FLR-T Adapter
  • HPE StoreFabric CN1200E-T 10GBASE-T Converged Network Adapter

Version:10.5.152.1 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Updated to version 10.5.152.1-1


Version:10.5.65.10 (15 Jun 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Updated to version 10.5.65.10-1


Version:10.2.477.10-1 (30 Mar 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Updated to version 10.2.477.10-1.


Version:10.2.340.5-1 (9 Sep 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Updated to version 10.2.340.5-1


Version:10.2.303.0-1 (17 Jun 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Initial version to support Red Hat Enterprise Linux 7 operating system


Type: Software - Storage Controllers - FC HBA
Version: 10.7.110.34(1 Apr 2016)
Operating System(s):
Red Hat Enterprise Linux 7 Server

Description

This package contains utilities and libraries to enable HPE Storage fibre channel array connectivity on Red Hat Enterprise Linux 7 Server.

Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 10.7.110.34-1

Added support for the following devices:

  • HPE FlexFabric 10Gb 2-port 556FLR-T Adapter
  • HPE StoreFabric CN1200E-T 10GBASE-T Converged Network Adapter

Installation Instructions

Prerequisites:
The target environment must have the libHBAAPI Package installed prior to the installation of the enablement kit. (If not already present, the libHBAAPI Package can be obtained from the operating system installation media.)


To ensure the integrity of your download, HPE recommends verifying your results with this MD5 Checksum value:

af00bc9129e692bd435afb565b85e94b HP-CNA-FC-Emulex-Enablement-Kit-10.7.110.34-1.rhel7.x86_64.rpm

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

There has been a change to the enablement kits in this release.  They are now vendor specific kits.   It is recommended that you uninstall any previous kits prior to installation of this component.

To uninstall the hp-fc-enablement RPM use the following command:

   # rpm -e hp-fc-enablement-<version>.noarch.rpm

To install the hp-fc-enablement RPM use the following command:

   # rpm -ivh HP-CNA-FC-Emulex-Enablement-Kit-<version>.<OS>.<architecture>.rpm

This version of the enablement kit does not provide the additional functionality of rebuilding the ram disk or setting driver parameters as the previous versions had done.  Please refer to the “Additional setup” section of the Native Linux Device-Mapper Multipath for HP StorageWorks Arrays reference guide for instructions on how to perform these functions.  The reference guide is available at the following link:
 
               http://www.hpe.com/storage/spock/
 


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Important:

Release Notes:
HPE StoreFabric Emulex Adapters Release Notes
 


Supported Devices and Features:

  • HP SN1000E 16Gb Dual Port Fibre Channel Host Bus Adapter
  • HP SN1000E 16Gb Single Port Fibre Channel Host Bus Adapter
  • HP 82E 8Gb Dual Port PCIe Fibre Channel Host Bus Adapter
  • HP 81E 8Gb Single Port PCIe Fibre Channel Host Bus Adapter
  • HP CN1100E Dual Port Converged Network Adapter
  • HP NC551i Dual Port FlexFabric 10Gb Network Adapter
  • HP NC553m 10Gb 2-port FlexFabric Converged Network Adapter
  • HP NC553i 10Gb 2-port FlexFabric Converged Network Adapter
  • HP FlexFabric 10Gb 2-port 554M Adapter
  • HP FlexFabric 10Gb 2-port 554FLR-SFP+ Adapter
  • HP FlexFabric 10Gb 2-port 554FLB Adapter
  • HP LPe1205A 8Gb Fibre Channel Host Bus Adapter for BladeSystem c-Class
  • Emulex LPe1205 8Gb Fibre Channel Host Bus Adapter for c-Class BladeSystem
  • HP SN1100E 16Gb Dual Port Fibre Channel Host Bus Adapter
  • HP SN1100E 16Gb Single Port Fibre Channel Host Bus Adapter
  • HP LPe1605 16Gb Fibre Channel Host Bus Adapter for BladeSystem c-Class
  • HP FlexFabric 20Gb 2-port 650FLB Adapter
  • HP FlexFabric 20Gb 2-port 650M Adapter
  • HP FlexFabric 10Gb 2-port 556FLR-SFP+ Adapter
  • HP StoreFabric CN1200E Dual Port Converged Network Adapter (FCoE)
  • HPE FlexFabric 10Gb 2-port 556FLR-T Adapter
  • HPE StoreFabric CN1200E-T 10GBASE-T Converged Network Adapter
  • HP StoreFabric 84E 4-Port Fibre Channel Host Bus Adapter

Important

Revision History

Version:12.0.346.16 (2 Apr 2019)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 12.0.346.16

Added support for Red Hat Enterprise Linux 7 update 6 (RHEL 7.6).


Version:11.4.334.2 (26 Jun 2018)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Added support to Red Hat Enterprise Linux 7u5

Updated to version 11.4.334.2


Version:11.4.207.0 (5 Feb 2018)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 11.4.207.0


Version:11.2.307.3 (25 Sep 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 11.2.307.3

Added support for Rhel7u4


Version:11.2.254.6 (12 Jul 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 11.2.254.6


Version:11.1.183.22 (24 Oct 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


This kit, version 11.1.183.22, adds support for the following devices:

  • HPE StoreFabric SN1200E 16Gb 2P FC HBA
  • HPE StoreFabric SN1200E 16Gb 1P FC HBA
  • HPE StoreFabric SN1600E 32Gb 2p FC HBA
  • HPE StoreFabric SN1600E 32Gb 1p FC HBA

Version:10.7.310.0 (24 Oct 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated enablement kit to version 10.7.310.0

Added HPE Smart SAN 1.0 support


Version:10.7.300.3 (17 Jun 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated  to version 10.7.300.3

Initial support for:

  • HPE StoreFabric SN1100E 4P 16Gb FC HBA
  • Smart SAN 1.0

 

 


Version:10.7.110.34 (1 Apr 2016)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Updated to version 10.7.110.34-1

Added support for the following devices:

  • HPE FlexFabric 10Gb 2-port 556FLR-T Adapter
  • HPE StoreFabric CN1200E-T 10GBASE-T Converged Network Adapter

Version:10.5.152.1 (1 Oct 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Updated to version 10.5.152.1-1


Version:10.5.65.10 (15 Jun 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Updated to version 10.5.65.10-1


Version:10.2.477.10-1 (30 Mar 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Updated to version 10.2.477.10-1.


Version:10.2.340.5-1 (9 Sep 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Updated to version 10.2.340.5-1


Version:10.2.303.0-1 (17 Jun 2014)
Enhancements

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


Initial version to support Red Hat Enterprise Linux 7 operating system


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.