Printable version

Drivers & software

* RECOMMENDED * HPE Power Device Flash Utility

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Firmware - Power Management
Version: 3.3.2(14 Dec 2017)
Operating System(s):
OS Independent
File name: HPE-Power-Device-Flash-Utility_3.3.2.zip (85 KB)
HPE Power Device Flash Utility is a universal tool for flashing Firmware and replicate configuration settings for Intelligent PDU(iPDU), Monitored PDU, Managed PDU, UPS Management Module(HPMM)and PDU Management Module(PDUMM). This Utility supports three transfer modes: serial, FTP and FTPS.

Prerequisites:

  • .NET 2.0& above has to be installed for this application to run.         
  • Default Managed PDU certificate must be placed under certificate folder of application to upgrade Managed PDU firmware through FTPS and the required certificate is available in the downloadable zip file under 'Certificate' folder.

To ensure the integrity of your download, HPE recommends verifying your results with this SHA-256 Checksum value:

1af7503f6929047e3957abaa70b65c117bdd5a118b981e7d05fad43514c87323 HPE-Power-Device-Flash-Utility_3.3.2.zip

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Steps:

  1. Download the application Zip file.    
  2. Extract contents of the zip file to a directory    
  3. Click on HPE Power Device Flash Utility.exe to run application.       


To refer help content, click on help button after launching the flash utility applciation to perform flash upgrade.

Flash Utility and HPE Managed PDU FTPS certificate must be under application folder to flash maPDU through FTPS.    
 
 


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Important:

  • Certificate Directory with maPDU.cer and flash Utility  are required to be placed under application folder to flash maPDU through FTPS.
  • HPE Managed PDU firmware version 02_00_0038& above will support only FTPS flash mode and lower versions will support  only FTP flash mode. Flash utility will show an error message “All pinged units could not be flashed.” when user selects the wrong flash mode.
  • Certificate name should be maPDU.cer for maPDU to upgrade through FTPS.
  • HPE Monitored PDU Flashing supports only FTP mode.
     

Notes:

  • HPE Monitor PDU (mPDU) Flashing supports only FTP mode.
  • HPE Managed PDU (maPDU) firmware version 02.00.0038 & above will support only FTPS flash mode and lower versions will support only FTP flash mode. Flash utility will show an error message "All pinged units could not be flashed." when user selects the wrong flash mode.
  • Certificate name should be "maPDU.cer" for maPDU to upgrade through FTPS and must be placed under "certificate" folder
  • Both "certificate" folder and Flash Utility are required to be placed under "application" folder for FTPS mode to work properly.
  • Downgrade from iPDU firmware from v2.1 to v2.0 will display an error message "All pinged units could not be flashed ". But still, the image would be successfully transferred and iPDU will go for a reboot.
  • The Acronym "DFUPSMM" is used in the help file, whereas, in the application it is referred as DirectFlow UPS Management Module (DF UPSMM)

 


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Unhandled exception error is fixed.
  • Disable FTP option when iPDU configuration file selected has been fixed.
  • Certificate Directory with maPDU.cer and flash Utility  are required to be placed under application folder to flash maPDU through FTPS.
  • HPE Managed PDU firmware version 02_00_0038& above will support only FTPS flash mode and lower versions will support  only FTP flash mode. Flash utility will show an error message “All pinged units could not be flashed.” when user selects the wrong flash mode.
  • Certificate name should be maPDU.cer for maPDU to upgrade through FTPS.
  • HPE Monitored PDU Flashing supports only FTP mode.
     
Version:3.3.2 (14 Dec 2017)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Unhandled exception error is fixed.
  • Disable FTP option when iPDU configuration file selected has been fixed.

Version:3.3.1 (15 Jun 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Application Usuability Enhancements.
  • Include a certificate (maPDU.cer) when choosing FTPS mode to flash firmware for maPDU.
  • It now supports firmware upgrade for High-Volatge PDU (HPE Apollo Monitored PDU) in FTPS mode only.

Version:3.2.7 (1 Aug 2016)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Following Issues has been Fixed:

  • Flash button stays in enable state when serial option is selected without any COM port connected.
  • An Exception error is thrown when invalid file is uploaded.

 

Enhancements

  • HPE Rebranding.
  • Support for FTPS Flash for maPDU - Include a certificate (maPDU.cer) when choosing FTPS mode to flash FW for maPDU

Version:3.2.1 (15 Sep 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Support for flashing HP Intelligent Power Distribution Unit (iPDU) boot loader (v3.0 and above)


Version:3.0.9 (12 Jun 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Support for flashing HP DirectFlow UPS Management Module firmware image


Version:3.0.8 (5 May 2011)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.



- Serial flashing of iPDU firmware from G7 servers is fixed
- Removes the repetitive text "PDU" message box for iPDU firmware
- Adds "insufficient privilege" to log file when non-admin user tries to flash firmware
- Flash utility now opens when no serial ports are found

Enhancements


- An information message will pop up when the Flash button is click for iPDU firmware


Version:3.0.5 (11 Jan 2011)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Adds support for iPDU products


Type: Firmware - Power Management
Version: 3.3.2(14 Dec 2017)
Operating System(s):
OS Independent

Description

HPE Power Device Flash Utility is a universal tool for flashing Firmware and replicate configuration settings for Intelligent PDU(iPDU), Monitored PDU, Managed PDU, UPS Management Module(HPMM)and PDU Management Module(PDUMM). This Utility supports three transfer modes: serial, FTP and FTPS.

Installation Instructions

Prerequisites:

  • .NET 2.0& above has to be installed for this application to run.         
  • Default Managed PDU certificate must be placed under certificate folder of application to upgrade Managed PDU firmware through FTPS and the required certificate is available in the downloadable zip file under 'Certificate' folder.

To ensure the integrity of your download, HPE recommends verifying your results with this SHA-256 Checksum value:

1af7503f6929047e3957abaa70b65c117bdd5a118b981e7d05fad43514c87323 HPE-Power-Device-Flash-Utility_3.3.2.zip

Reboot Requirement:
Reboot is required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Steps:

  1. Download the application Zip file.    
  2. Extract contents of the zip file to a directory    
  3. Click on HPE Power Device Flash Utility.exe to run application.       


To refer help content, click on help button after launching the flash utility applciation to perform flash upgrade.

Flash Utility and HPE Managed PDU FTPS certificate must be under application folder to flash maPDU through FTPS.    
 
 


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Important:

  • Certificate Directory with maPDU.cer and flash Utility  are required to be placed under application folder to flash maPDU through FTPS.
  • HPE Managed PDU firmware version 02_00_0038& above will support only FTPS flash mode and lower versions will support  only FTP flash mode. Flash utility will show an error message “All pinged units could not be flashed.” when user selects the wrong flash mode.
  • Certificate name should be maPDU.cer for maPDU to upgrade through FTPS.
  • HPE Monitored PDU Flashing supports only FTP mode.
     

Notes:

  • HPE Monitor PDU (mPDU) Flashing supports only FTP mode.
  • HPE Managed PDU (maPDU) firmware version 02.00.0038 & above will support only FTPS flash mode and lower versions will support only FTP flash mode. Flash utility will show an error message "All pinged units could not be flashed." when user selects the wrong flash mode.
  • Certificate name should be "maPDU.cer" for maPDU to upgrade through FTPS and must be placed under "certificate" folder
  • Both "certificate" folder and Flash Utility are required to be placed under "application" folder for FTPS mode to work properly.
  • Downgrade from iPDU firmware from v2.1 to v2.0 will display an error message "All pinged units could not be flashed ". But still, the image would be successfully transferred and iPDU will go for a reboot.
  • The Acronym "DFUPSMM" is used in the help file, whereas, in the application it is referred as DirectFlow UPS Management Module (DF UPSMM)

 


Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Unhandled exception error is fixed.
  • Disable FTP option when iPDU configuration file selected has been fixed.

Important

  • Certificate Directory with maPDU.cer and flash Utility  are required to be placed under application folder to flash maPDU through FTPS.
  • HPE Managed PDU firmware version 02_00_0038& above will support only FTPS flash mode and lower versions will support  only FTP flash mode. Flash utility will show an error message “All pinged units could not be flashed.” when user selects the wrong flash mode.
  • Certificate name should be maPDU.cer for maPDU to upgrade through FTPS.
  • HPE Monitored PDU Flashing supports only FTP mode.
     

Revision History

Version:3.3.2 (14 Dec 2017)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Unhandled exception error is fixed.
  • Disable FTP option when iPDU configuration file selected has been fixed.

Version:3.3.1 (15 Jun 2017)
Enhancements

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


  • Application Usuability Enhancements.
  • Include a certificate (maPDU.cer) when choosing FTPS mode to flash firmware for maPDU.
  • It now supports firmware upgrade for High-Volatge PDU (HPE Apollo Monitored PDU) in FTPS mode only.

Version:3.2.7 (1 Aug 2016)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.


Following Issues has been Fixed:

  • Flash button stays in enable state when serial option is selected without any COM port connected.
  • An Exception error is thrown when invalid file is uploaded.

 

Enhancements

  • HPE Rebranding.
  • Support for FTPS Flash for maPDU - Include a certificate (maPDU.cer) when choosing FTPS mode to flash FW for maPDU

Version:3.2.1 (15 Sep 2015)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Support for flashing HP Intelligent Power Distribution Unit (iPDU) boot loader (v3.0 and above)


Version:3.0.9 (12 Jun 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Support for flashing HP DirectFlow UPS Management Module firmware image


Version:3.0.8 (5 May 2011)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.



- Serial flashing of iPDU firmware from G7 servers is fixed
- Removes the repetitive text "PDU" message box for iPDU firmware
- Adds "insufficient privilege" to log file when non-admin user tries to flash firmware
- Flash utility now opens when no serial ports are found

Enhancements


- An information message will pop up when the Flash button is click for iPDU firmware


Version:3.0.5 (11 Jan 2011)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


Adds support for iPDU products


Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.