Print | Rate this content

HPESBGN03740 rev.1 - HPE Network Automation, Multiple Remote Vulnerabilities

SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: hpesbgn03740en_us

Version: 1

HPESBGN03740 rev.1 - HPE Network Automation, Multiple Remote Vulnerabilities
NOTICE: The information in this Security Bulletin should be acted upon as soon as possible.

Release Date: 2017-05-04

Last Updated: 2017-05-04


Potential Security Impact: Local: Authentication Bypass; Remote: Code Execution, Elevated Privileges, SQL Injection

Source: Hewlett Packard Enterprise, HPE Product Security Response Team

VULNERABILITY SUMMARY

Potential security vulnerabilities have been identified in HPE Network Automation. The vulnerabilities could be remotely exploited to allow SQL injection, code execution, information disclosure, authentication bypass, elevated privilege execution, and invalid session management.

References:
  • CVE-2017-5810 - SQL injection
  • CVE-2017-5811 - remote code execution
  • CVE-2017-5812 - remote information disclosure
  • CVE-2017-5813 - remote unauthenticated access
  • CVE-2017-5814 - remote authentication bypass, elevated privilege execution

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.

HP Network Automation Software 9.1x, 9.2x, 10.0x, 10.1x and 10.2x

BACKGROUND

CVSS Version 3.0 and Version 2.0 Base Metrics
Reference
V3 Vector
V3 Base Score
V2 Vector
V2 Base Score
CVE-2017-5810
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
7.5
(AV:N/AC:L/Au:N/C:C/I:N/A:N)
7.8
CVE-2017-5811
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
7.5
(AV:N/AC:L/Au:N/C:C/I:N/A:N)
7.8
CVE-2017-5812
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
5.3
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
5.0
CVE-2017-5813
CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
4.6
(AV:N/AC:M/Au:S/C:P/I:P/A:P)
6.0
CVE-2017-5814
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
8.8
(AV:N/AC:L/Au:S/C:C/I:C/A:C)
9.0
Information on CVSS is documented in HPE Customer Notice: HPSN-2008-002

Hewlett Packard Enterprise thanks the following for reporting security issues to security-alert@hpe.com:

  • CVE-2017-5810 rgod working with Trend Micro's Zero Day Initiative
  • CVE-2017-5811 rgod working with Trend Micro's Zero Day Initiative
  • CVE-2017-5812 rgod working with Trend Micro's Zero Day Initiative
  • CVE-2017-5814 Christophe Schleypen of NATO NCIRC

RESOLUTION

HPE has made the following software updates and mitigation information available to resolve the vulnerabilities in HPE Network Automation:

Customers on version 9.1x or 9.2x need to upgrade to a patched version of 10.0x, or 10.1x or 10.2x noted below

For 10.0x, first patch to 10.00.021, and then apply the patch 10.00.022:

For 10.10, customers should first upgrade to 10.11: https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/LID/NA_00030 and then apply the 10.11 patch below.

For NA 10.20, customers should first upgrade to 10.21 https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/LID/NA_00040 and then apply the 10.21 patch below:

HISTORY
Version:1 (rev.1) - 4 May 2017 Initial release

Third Party Security Patches: Third party security patches that are to be installed on systems running Hewlett Packard Enterprise (HPE) software products should be applied in accordance with the customer's patch management policy.

Support: For issues about implementing the recommendations of this Security Bulletin, contact normal HPE Services support channel. For other issues about the content of this Security Bulletin, send e-mail to security-alert@hpe.com.

Report: To report a potential security vulnerability for any HPE supported product:

Subscribe: To initiate a subscription to receive future HPE Security Bulletin alerts via Email: http://www.hpe.com/support/Subscriber_Choice

Security Bulletin Archive: A list of recently released Security Bulletins is available here: http://www.hpe.com/support/Security_Bulletin_Archive

Software Product Category: The Software Product Category is represented in the title by the two characters following HPSB.

3C = 3COM
3P = 3rd Party Software
GN = HP General Software
HF = HP Hardware and Firmware
MU = Multi-Platform Software
NS = NonStop Servers
OV = OpenVMS
PV = ProCurve
ST = Storage Software
UX = HP-UX

©Copyright 2017 Hewlett Packard Enterprise Company, L.P.
Hewlett Packard Enterprise Company shall not be liable for technical or editorial errors or omissions contained herein. The information provided is provided "as is" without warranty of any kind. To the extent permitted by law, neither HPE nor its affiliates, subcontractors or suppliers will be liable for incidental, special or consequential damages including downtime cost; lost profits; damages relating to the procurement of substitute products or services; or damages for loss of data, or software restoration. The information in this document is subject to change without notice. Hewlett Packard Enterprise Company and the names of Hewlett Packard Enterprise Company products referenced herein are trademarks of Hewlett Packard Enterprise Company in the United States and other countries. Other product and company names mentioned herein may be trademarks of their respective owners.

Legal Disclaimer: Products sold prior to the November 1, 2015 separation of Hewlett-Packard Company into Hewlett Packard Enterprise Company and HP Inc. may have older product names and model numbers that differ from current models.

Provide feedback

Please rate the information on this page to help us improve our content. Thank you!
Document title: HPESBGN03740 rev.1 - HPE Network Automation, Multiple Remote Vulnerabilities
Document ID: emr_na-hpesbgn03740en_us-1
How helpful was this document?
How can we improve this document?
Note: Only English language comments can be accepted at this time.
Please wait while we process your request.