Print | Rate this content

HPSBNS03635 rev.1 - HPE NonStop Servers OSS Script Languages running Perl and PHP, Multiple Local and Remote Vulnerabilities

SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: c05240731

Version: 1

HPSBNS03635 rev.1 - HPE NonStop Servers OSS Script Languages running Perl and PHP, Multiple Local and Remote Vulnerabilities
NOTICE: The information in this Security Bulletin should be acted upon as soon as possible.

Release Date: 2016-08-19

Last Updated: 2016-08-19


Potential Security Impact: Local Denial of Service (DoS), Elevation of Privilege, Remote Denial of Service (DoS), Execution of Arbitrary Code, Unauthorized Disclosure of Information, Unauthorized Modification

Source: Hewlett Packard Enterprise, HPE Product Security Response Team

VULNERABILITY SUMMARY

Multiple potential remote and local vulnerabilities impacting Perl and PHP have been addressed by HPE NonStop Servers OSS Script Languages. The vulnerabilities include Perl's opportunistic loading of optional modules which might allow local users to gain elevation of privilege via a Trojan horse library under the current working directory.

References:
  • CVE-2016-1238 - Perl Local Elevation of Privilege
  • CVE-2016-2381 - Perl Remote Unauthorized Modification
  • CVE-2014-4330 - Perl Local Denial of Service (DoS)

    Note: applies only for the H/J-series SPR. Fix was already provided in a previous L-series SPR.

  • CVE-2015-8383 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8386 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8387 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8389 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8390 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8391 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8393 - Perl Remote Unauthorized Disclosure of Information
  • CVE-2015-8394 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8607 - Perl Remote Unauthorized Disclosure of Information, Unauthorized Modification, Denial of Service (DoS)
  • CVE-2015-8853 - Perl Remote Denial of Service (DoS)
  • CVE-2015-8865 - Perl Remote Denial of Service (Dos), Execute Arbitrary Code
  • CVE-2013-7456 - PHP Remote Denial of Service (DoS)
  • CVE-2015-8874 - PHP Remote Denial of Service (DoS)
  • CVE-2016-1903 - PHP Remote Unauthorized Disclosure of Information, Denial of Service (DoS)
  • CVE-2016-2554 - PHP Remote Denial of Service (DoS)
  • CVE-2016-3074 - PHP using GD Graphics Library 2.1.1 (aka libgd or libgd2) Remote Denial of Service (Dos), Execute Arbitrary Code
  • CVE-2016-4070 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4071 - PHP Remote Execute Arbitrary Code
  • CVE-2016-4072 - PHP Remote Execute Arbitrary Code
  • CVE-2016-4073 - PHP Remote Denial of Service (Dos), Execute Arbitrary Code
  • CVE-2016-4342 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4343 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4537 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4538 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4539 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4540 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4541 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4542 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4543 - PHP Remote Denial of Service (DoS)
  • CVE-2016-4544 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5093 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5094 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5096 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5114 - PHP Remote Unauthorized Disclosure of Information, Denial of Service (DoS)
  • CVE-2016-5766 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5767 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5768 - PHP Remote Denial of Service (Dos), Execute Arbitrary Code
  • CVE-2016-5769 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5770 - PHP Remote Denial of Service (DoS)
  • CVE-2016-5771 - PHP Remote Denial of Service (Dos), Execute Arbitrary Code
  • CVE-2016-5772 - PHP Remote Denial of Service (Dos), Execute Arbitrary Code
  • CVE-2016-5773 - PHP Remote Denial of Service (Dos), Execute Arbitrary Code
  • NonStop Hotstuff HS03333
  • PSRT110206

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.

OSS Script Languages (T1203) T1203H01 through T1203H01^AAD, T1203L01 and T1203L01^AAC

Impacted releases:

  • L15.02
  • L15.08.00, L15.08.01
  • L16.05.00

  • J06.14 through J06.16.02

  • J06.17.00, J06.17.01
  • J06.18.00, J06.18.01
  • J06.19.00, J06.19.01, J06.19.02
  • J06.20.00

  • H06.25 through H06.26.01

  • H06.27.00, H06.27.01
  • H06.28.00, H06.28.01
  • H06.29.00, H06.29.01

BACKGROUND

CVSS Version 3.0 and Version 2.0 Base Metrics
Reference
V3 Vector
V3 Base Score
V2 Vector
V2 Base Score
CVE-2013-7456
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
7.6
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
6.8
CVE-2014-4330
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
4.0
(AV:L/AC:L/Au:N/C:N/I:N/A:P)
2.1
CVE-2015-8383
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8386
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8387
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8389
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8390
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8391
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
8.6
(AV:N/AC:L/Au:N/C:P/I:P/A:C)
9.0
CVE-2015-8393
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
5.3
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
5.0
CVE-2015-8394
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8607
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8853
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
7.5
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
5.0
CVE-2015-8865
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
7.3
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2015-8874
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
7.5
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
5.0
CVE-2016-1238
CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
6.7
(AV:L/AC:H/Au:N/C:C/I:C/A:C)
6.2
CVE-2016-1903
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
9.1
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
6.4
CVE-2016-2381
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
6.5
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
5.0
CVE-2016-2554
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
10.0
CVE-2016-3074
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4070
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
7.5
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
5.0
CVE-2016-4071
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4072
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4073
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4342
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
8.8
(AV:N/AC:M/Au:N/C:P/I:P/A:C)
8.3
CVE-2016-4343
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
8.8
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
6.8
CVE-2016-4537
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4538
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4539
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4540
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4541
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
9.1
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4542
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4543
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-4544
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5093
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
8.6
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5094
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
8.6
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5096
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
8.6
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5114
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
9.1
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
6.4
CVE-2016-5766
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
8.8
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
6.8
CVE-2016-5767
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
8.8
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
6.8
CVE-2016-5768
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5769
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5770
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5771
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5772
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
CVE-2016-5773
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
9.8
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
7.5
Information on CVSS is documented in HPE Customer Notice: HPSN-2008-002

RESOLUTION

HPE has released the following software updates to resolve the vulnerabilities in NonStop Servers OSS Script Languages running Perl and PHP.

Install one of the SPRs below as appropriate for the system's release version:

  • L-Series:

    • T1203L01^AAE (OSS Scripting Languages) - already available

      This SPR already is present in these RVUs: None

      This SPR is usable with the following RVUs:

      • L15.02 through L16.05.00
  • H and J-Series:

    • T1203H01^AAF (OSS Scripting Languages) - already available

      This SPR already is present in these RVUs: None

      This SPR is usable with the following RVUs:

      • J06.14 through J06.20.00

      • H06.25 through H06.29.01

Note: Please refer to NonStop Hotstuff HS03333 for more information.

HISTORY
Version:1 (rev.1) - 19 August 2016 Initial release

Third Party Security Patches: Third party security patches that are to be installed on systems running Hewlett Packard Enterprise (HPE) software products should be applied in accordance with the customer's patch management policy.

Support: For issues about implementing the recommendations of this Security Bulletin, contact normal HPE Services support channel. For other issues about the content of this Security Bulletin, send e-mail to security-alert@hpe.com.

Report: To report a potential security vulnerability for any HPE supported product:

Subscribe: To initiate a subscription to receive future HPE Security Bulletin alerts via Email: http://www.hpe.com/support/Subscriber_Choice

Security Bulletin Archive: A list of recently released Security Bulletins is available here: http://www.hpe.com/support/Security_Bulletin_Archive

Software Product Category: The Software Product Category is represented in the title by the two characters following HPSB.

3C = 3COM
3P = 3rd Party Software
GN = HP General Software
HF = HP Hardware and Firmware
MU = Multi-Platform Software
NS = NonStop Servers
OV = OpenVMS
PV = ProCurve
ST = Storage Software
UX = HP-UX

©Copyright 2016 Hewlett Packard Enterprise Company, L.P.
Hewlett Packard Enterprise Company shall not be liable for technical or editorial errors or omissions contained herein. The information provided is provided "as is" without warranty of any kind. To the extent permitted by law, neither HPE nor its affiliates, subcontractors or suppliers will be liable for incidental, special or consequential damages including downtime cost; lost profits; damages relating to the procurement of substitute products or services; or damages for loss of data, or software restoration. The information in this document is subject to change without notice. Hewlett Packard Enterprise Company and the names of Hewlett Packard Enterprise Company products referenced herein are trademarks of Hewlett Packard Enterprise Company in the United States and other countries. Other product and company names mentioned herein may be trademarks of their respective owners.

Provide feedback

Please rate the information on this page to help us improve our content. Thank you!